Questions tagged [magento2.4]

Denotes questions related to the features included in Magento version 2.4.x

Filter by
Sorted by
Tagged with
42 votes
10 answers
34k views

You need to configure Two-Factor Authorization in order to proceed

Having just installed 2.4.0 from scratch, I ran into an "issue" when logging into Magento Backend for the first time: Failed to send the message. Please contact the administrator You need ...
user avatar
  • 2,490
40 votes
3 answers
61k views

How to disable Two factor Authentication module in Magento 2.4 [closed]

Anyone, please help me with how to disable the Two-factor Authentication module using a command-line. Thanks.
user avatar
  • 1,735
31 votes
26 answers
88k views

Magento 2.4.0 - Getting Error Could not validate a connection to Elasticsearch. No alive nodes found in your cluster

I am getting below error while installing Magento 2.4.0 using command line. Could not validate a connection to Elasticsearch. No alive nodes found in your cluster I have run below two commands. ...
user avatar
10 votes
6 answers
13k views

Magento 2.x Elasticsearch Category Products Not Showing

I tried to upgrade my Magento 2.3.5 install to Magento 2.4.0, but am unable to get category pages to display products. Everything is in Docker, so I am using Elasticsearch 7.6 and have specified ...
user avatar
10 votes
1 answer
2k views

Sanitizing HTML output in templates in 2.4

Before 2.4 the way you could sanitize an html value in a template was to use $block->escapeHtml($valueHere);. Where $blick is the instance of the current block. This still works in 2.4, but the ...
user avatar
  • 195k
9 votes
6 answers
14k views

Magento 2.4.3 admin dashboard - Invalid security or form key. Please refresh the page

After upgrading to Magento 2.4.3 Community Edition I am getting Invalid security or form key. Please refresh the page. on the admin dashboard site after logging in. Reloading the page makes the error ...
user avatar
8 votes
3 answers
26k views

magento/composer-root-update-plugin is locked to version 1.0.0 and an update of this package was not requested

i am trying to install the extension through composer but i am getting below error. Your requirements could not be resolved to an installable set of packages. Problem 1 - magento/composer-root-update-...
user avatar
7 votes
6 answers
7k views

Logging in Magento 2.4+

What are the different way a developer can log messages in Magento 2.4+? Zend logger can't be used anymore either.
user avatar
  • 482
6 votes
5 answers
3k views

In Magento 2.4 Cart page showing "Estimate Shipping and Tax"

I am doing fresh setup on Magento Cloud server and facing below issue. Issue: Page break with error while redirecting to Cart page. Steps followed : Add product into Cart Click on "Shopping ...
user avatar
  • 115
5 votes
3 answers
21k views

Upgrade Magento 2.3.3 to 2.4

How to upgrade Magento 2.3.3 to Magento 2.4?
user avatar
5 votes
3 answers
6k views

Compatible MariDB version for Magento 2.4

We are upgrading from magento 2.3 to 2.4. Would like to know the compatible MariaDB version to be used for the upgraded magento version. As per official magento site, it mentions MySQL8.0 for on ...
user avatar
  • 151
5 votes
4 answers
14k views

Magento 2.4.0 ElasticSearch not alive

When performing the setup:upgrade I get this error : "Could not validate a connection to Elasticsearch. No alive nodes found in your cluster" I have not enabled It previously, updating from ...
user avatar
  • 121
5 votes
7 answers
8k views

Magento 2.4 Best way setup with Docker environment

What is the best way to Configure Docker environment with Magento 2.4. If some know please give me a solution.
user avatar
5 votes
0 answers
402 views

Declarative schema uses padding in 2.3, gone in 2.4, do we have to use it?

In a module we're developing we declare a new database table with a foreign key relationship to the sales_order table. We want to support Magento 2.3 and 2.4, so we use the declarative schema (...
user avatar
4 votes
3 answers
5k views

Magento 2.4 Class Magento\Framework\Search\Adapter\Mysql\Mapper does not exist

I just upgraded my Magento version to the latest Magento version 2.4.0. after a successful upgrade, while I am trying to set production mode I am getting error like Compilation was started. Area ...
user avatar
4 votes
2 answers
3k views

How to install Magento 2.4.0?

I would like to install Magento 2.4.0 on server without Elasticsearch require during installation. Can anybody tell me the way to disable Elasticsearch require when I run setup:install ... ? Thank you ...
user avatar
  • 101
4 votes
3 answers
7k views

Magento 2.4 - Composer php 7.4 error magento/magento2-functional-testing-framework

We run Magento 2.4 with php7.4, that should be supported. But we get the following error when we try to update a module using composer: magento/magento2-functional-testing-framework 2.6.5 requires php ...
user avatar
  • 1,474
4 votes
2 answers
2k views

Proper way to update stock in >= 2.4?

I'm finding inconsistent documentation on how to update product stock for M2 2.4.1. Magento\Catalog\Model\Product::setStockData is documented in code to be deprecated and points to Magento\...
user avatar
  • 6,770
4 votes
2 answers
2k views

Magento Controller deprecated action class confusion

On Magento 2.4 i found this class extends (extends \Magento\Framework\App\Action\Action) show deprecated. Ref : Screenshot at end of the question But Magento core use this code. I mean in core code ...
user avatar
4 votes
2 answers
2k views

Magento 2.4 - Search by SKU

I'm trying to figure out why Magento 2 Search is working that way. My products have SKUS like 111-222-333. When i'm trying to search by SKU, magento 2.4 returns a product collection of ther product ...
user avatar
  • 231
4 votes
0 answers
371 views

Magento 2.4: Uncaught TypeError: base is not a constructor

After Magento update to 2.4, I'm getting this "base is not a constructor" error which is causing other grids to unable load in the admin. When I run the command: ->sudo chmod 777 -R Var/ ...
user avatar
3 votes
6 answers
4k views

Magento 2.4.3 - Checkout JS knockout error - renderReCaptcha

We upgrade to Magento 2.4.3 and now face the following JS knockout error in the checkout: TypeError: Unable to process binding "afterRender: function (){return renderReCaptcha() }" Message: ...
user avatar
  • 1,474
3 votes
1 answer
2k views

Unable to activate integration with Oauth 1.0

I have been trying to create my own external application using Oauth, but I get to filling out the details for the callback URL and Identity link URL (and the name), which creates fine, but when I go ...
user avatar
3 votes
4 answers
4k views

Type Error occurred when creating object: Magento\Framework\Session\Generic\Interceptor, setcookie() expects parameter 3 to be integer, array given

After clear/setting/configuring so many errors & configurations installed the Magento V2.4.1 successfully, now getting below errors. Type Error occurred when creating object: Magento\Framework\...
user avatar
  • 3,896
3 votes
2 answers
2k views

RabbitMQ and cron_consumers_runner

If you are running RabbitMQ in M 2.3/2.4 and have the env.php section set up for amqp: 'queue' => [ 'amqp' => [ 'host' => '127.0.0.1', 'port' => '5672', '...
user avatar
3 votes
6 answers
145 views

How to enable Two-Factor Authentication in Magento 2?

How do I enable it for all account types in Magento 2? Anyone, please help me with how to enable the Two-factor Authentication module using a command line.
user avatar
3 votes
1 answer
94 views

Add additional info based on country selection condition in one page checkout country field

The condition should be like if the country is the UK then the text should not be shown. If the country is other than the UK then the text should be shown. On the cart page, I achieved using the ...
user avatar
3 votes
2 answers
313 views

How to interact with APCu?

Magento DevDocs recommends to use APCu. I have enabled it and it works somehow, but I don't why and, and when to do what. I use already apc.php. Can anyone share some knowledge regarding APCu and ...
user avatar
  • 301
3 votes
3 answers
1k views

Magento 2.4 with AWS ES not able to install

I'm trying to install Magento 2.4. I have set up AWS ES that I tasted and it works fine! But I keep getting an error: In SearchConfig.php line 81: Could not validate a connection to Elasticsearch....
user avatar
  • 43
3 votes
3 answers
4k views

Magento 2.4.1 and Elasticsearch 7.6.2 "no mapping found" issue

I'm facing an issue with a fresh install of Magento 2.4.1 and Elasticsearch 7.6.2. The products appear for a moment, and I have to reindex again to see them. The main issue appears to be "No ...
user avatar
3 votes
1 answer
69 views

getFullActionName() returning __ on CMS & Category Pages

Anyone noticed that if you observe the event controller_action_predispatch in Magento 2.4.4 public function execute(Observer $observer) { $request = $observer->getEvent()->getRequest(); $...
user avatar
  • 4,632
3 votes
1 answer
3k views

Magento 2 - The requested class did not generate properly, because the 'generated' directory permission is read-only

I got this issue after running bin/magento setup:di:compile $ bin/magento setup:di:compile Compilation was started. Interceptors generation... 4/9 [============>---------------] 44% 16 secs 300.0 ...
user avatar
  • 31
3 votes
5 answers
2k views

Magento 2.4.1-p1 CE?: "main.ERROR: Can not resolve reCAPTCHA parameter..."

In /var/log/exception.log, I've been getting the following ERROR for over a week and can't figure out how to fix it: main.ERROR: Can not resolve reCAPTCHA parameter. {"exception":"[...
user avatar
3 votes
1 answer
250 views

Is PWA Studio ready for production use?

Going throught the demo store https://venia.magento.com/ and installing the headless version with our production instance it seems a lot of basic features are still msissing with PWA Studio provided ...
user avatar
  • 161
3 votes
1 answer
964 views

No such entity cartId when send POST on /rest/default/V1/carts/mine/payment-information

According to documentation - https://devdocs.magento.com/guides/v2.4/rest/tutorials/orders/order-create-order.html I'm trying to make call on /rest/default/V1/carts/mine/payment-information with body: ...
user avatar
3 votes
1 answer
2k views

Upgrade Magento 2.3.5-p1 to Magento 2.4

I'm trying to upgrade Magento 2.3.4 and Magento 2.3.5-p1 to the latest release of Magento 2.4, Is that possible ? And How can I do this with composer ? Thanks in advance
user avatar
  • 103
3 votes
0 answers
1k views

Magento 2.4.1 Elastic Search critical error failed to create query "all shards failed"

I updated my site to Magento 2.4.1 after that in my exception.log i continueously get folllowing error : main.CRITICAL: {"error":{"root_cause":[{"type":"...
user avatar
3 votes
0 answers
824 views

How to create modifier for admin customer form in magento 2?

I have created a new virtualType to change newly added customer attribute value in customer form. But I am unable to modify attribute data. What is wrong with the below code?
user avatar
2 votes
5 answers
6k views

Upgrade to magento 2.4.3

I'm trying to upgrade Magento 2.4.2 to the latest release of Magento 2.4.3 How can I do this with the composer?
user avatar
  • 103
2 votes
6 answers
3k views

Magento 2.4 - Two factor authentication

I'm upgrading my development migration to 2.4. I was surprised to see that 2FA was enabled. Can this be turned off? I have enough issues to deal with and prefer not to go through this learning curve....
user avatar
  • 121
2 votes
3 answers
557 views

Missing css from source code magento 2.4.2

When upgrading to Magento 2.4.2 all of the core css is missing front both the back and frontends. Looking at the source I see no reference to such lines such as <link rel="stylesheet" ...
user avatar
  • 2,429
2 votes
3 answers
2k views

Upgrade Magento 2.4.1-ee to Magento 2.4.2-ee return 404

I upgraded Magento 2.4.1-ee to Magento 2.4.2-ee and after that, I execute the command for upgrade and deploy. Commands run successfully. But, the front URL and admin URL return the 404 page. How to ...
user avatar
  • 16.6k
2 votes
4 answers
3k views

M2.4 Exception throwing while executing composer require: Higher matching version 2.3.x of xxx/module-xxxx was found in public repository packagist

While executing composer require xxxx/module-xxxx I'm facing below error on the console. Repository is private at the moment. [Exception] ...
user avatar
  • 3,572
2 votes
2 answers
2k views

Magento 2 Media Gallery doesn't show any images in 2.4.1

I installed Magento 2.4.1. all is working fine but the newer feature that Media Gallery is does not show any images.Here is the Image Is there any other configuration requires for seeing images? I ...
user avatar
2 votes
2 answers
863 views

Magento 2.3.x: Data Migration - product show out of stock after migration

After migration all product showing out of stock
user avatar
  • 1,039
2 votes
2 answers
496 views

Magento 2.4.3 Bundle Product getting issue on frontend Magento\Catalog\Model\ResourceModel\Product\Flat::getLinkField()

We have upgraded magento to 2.4.3-p1 and added new bundle product. On frontend when we access bundle product it show error Call to undefined method Magento\Catalog\Model\ResourceModel\Product\Flat::...
user avatar
2 votes
1 answer
2k views

Magento 2.4 Add Recaptcha in Custom From

Magento 2.4 How to add Google Recaptcha in Custom Form ?
user avatar
  • 5,800
2 votes
2 answers
121 views

How to Add a Link to the Top Menu in Magento 2?

I am want to know how to add programmatically a new link (to the main top menu in the header) with a submenu. How to achieve that, via XML or via (PHP) plugin? Thanks in advance.
user avatar
2 votes
4 answers
1k views

MAGENTO 2.4 EXPORT CSV FILE STUCK IN QUEU AND NEVER APPEARS TO DOWNLOAD IT

HELP..!! I am on Magento 2.4 trying to export products but EXPORT FILE STUCK IN QUEUE.... it never appears.. what can i do? Thanks in advance!
user avatar
2 votes
1 answer
3k views

Compose error show in upgrade command

I have updated Magento version Magento 2.3.5-p1 to Magento 2.4.0 When I am running Magento setup upgrade command php bin/magento setup:upgrade then it's showing me below error Module '...
user avatar

1
2 3 4 5
25