Questions tagged [laminas]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
10 views

\Zend\Stdlib & Laminas - \Zend\Stdlib\ParametersFactory - Failing Module

After (unwisely it seems) doing composer update on our Magento 2.4.6p1 (php 8.2), some recent updates seem to have caused problems with Zend and Laminas. Most of which were easily fixed by replacing ...
DomiGuy's user avatar
  • 11
0 votes
2 answers
42 views

Zend Class issue Upgrade From Magento 2.4.3 to 2.4.6

We are Upgrading Magento Version from 2.4.3 to 2.4.6. Area configuration aggregation... 5/9 [===============>------------] 55% 34 secs 498.0 MiB In ClassReader.php line 57: Impossible to process ...
Kushal Dani's user avatar
  • 2,104
0 votes
2 answers
424 views

Zend framework is deprecated in magento 2.4.6

I have just upgraded my Magento version from 2.4.0 to 2.4.6 and it is giving this error while opening admin. please suggest any solution 1 exception(s): Exception #0 (Exception): User Deprecated ...
Tisha Jhanwar's user avatar
0 votes
0 answers
41 views

Laminas Uncaught exception

I am facing this issue: Uncaught exception 'Laminas\View\Exception\RuntimeException' with message 'Laminas\View\Renderer\PhpRenderer::render: Unable to render template "error"; resolver ...
Rana Zain's user avatar
  • 640
0 votes
2 answers
279 views

How Can I Remove Decimal From Price in Magento 2.4.6?

how can I remove the decimal section after the price in Magento 2.4.6 on the admin and frontend ?
Peren's user avatar
  • 27
3 votes
7 answers
3k views

Which class replace for "Zend_Validate" in Magento 2.4.6?

I have one function that uses the "Zend_Validate" Now I upgraded my Magento version to 2.4.6 and I got an error like.. https://prnt.sc/z3i-VQY7VFvp with class replace my code is if (!\...
Jay Parmar's user avatar
3 votes
1 answer
3k views

Zend_Filter_Input replacement

in a module that I have to maintain, the function Zend_Filter_Input is used, but in 2.4.6 it throws an error. Is there a replacement ? (I know for Zend_Json for example it's Laminas\Json\Json) but ...
JG Cabanas's user avatar
4 votes
1 answer
3k views

ZendClient replacement with LaminasClient in Magento 2.4.6

In magento 2.4.5, I use some function below to connect with QBO sandbox ZendClient and it's working perfectly: setUri() setConfig(array()) setHeaders() setRawData() request($method) ($method can be ...
Shou's user avatar
  • 160
3 votes
1 answer
842 views

Magento 2.4.6 update - extension problem - zendframework replaced with laminas

l just updated Magento to version 2.4.6. Everything works fine but i have problem with one extension, it is very important to me and there is no substitute for it. Problem is that zendframework is ...
Raul Baričević's user avatar
8 votes
3 answers
6k views

Zend replacement in 2.4.6

I have a theme and extensions that use widely the Zend_Json function i.e.for example : window.checkout = getConfig()); ?>; in 2.4.5 I had no problem using this code, in 2.4.6 it throws an exception : &...
JG Cabanas's user avatar
0 votes
1 answer
793 views

Declaration of Laminas\Stdlib\ArrayObject::offsetExists(Laminas\Stdlib\mixed $key) error after updating to 2.4.5-p1

After updating from Magento 2.4.4 running on PHP 7.4 to Magento 2.4.5-p1 running on PHP 8.1 I am getting this error: Declaration of Laminas\Stdlib\ArrayObject::offsetExists(Laminas\Stdlib\mixed $key) ...
user4095519's user avatar
0 votes
2 answers
2k views

PHP Fatal error: Uncaught Error: Interface 'Laminas\ServiceManager\Factory\FactoryInterface' not found

anyone encountered this issues after upgrading from Magento 2.3.1 to 2.4. This happened when I tried to compile the magento. PHP Fatal error: Uncaught Error: Interface 'Laminas\ServiceManager\Factory\...
Tora's user avatar
  • 105
0 votes
1 answer
615 views

PHP Fatal error: Cannot use ::class with dynamic class name in ../vendor/laminas/laminas-servicemanager/src/ServiceManager.php on line 984

i use Magento 2.4.3 with php7.4 after composer update: - Updating laminas/laminas-dependency-plugin (2.4.0 => 2.5.0): Checking out 8f2d101993 - Updating laminas/laminas-stdlib (3.13.0 => 3....
FloWord's user avatar
  • 155
0 votes
2 answers
4k views

Magento 2 PHP Fatal error during setup:di:compile at 33%

Currently running Magento 2.4.1-p1. When I run setup:di:compile I've got this output: Interface 'Laminas\ServiceManager\Factory\FactoryInterface' not found in /chroot/home/af5d329a/851f14efb2.nxcli....
Ace Optics's user avatar
0 votes
2 answers
2k views

Uncaught Exception: Warning: fwrite(): SSL operation failed with code 1

Magento 2.4 is using this module facinf error while sending success email: error:1420C0CF:SSL routines:ssl_write_internal:protocol is shutdown in /app/vendor/laminas/laminas-mail/src/Protocol/...
Hassan Ali Shahzad's user avatar
2 votes
4 answers
6k views

Magento 2.4.3: Zend removed?

Has Zend been finally depreciated? I'm having issues on Catalog page using an Amasty plugin: Error: Class 'Zend\Serializer\Serializer' not found in /var/www/php/vendor/amasty/shopby-seo/Helper/Data....
Kalvin Klien's user avatar
0 votes
2 answers
2k views

Magento 2.4.3 Using \Laminas\Log\Logger::WARN or EMERG, DEBUG not working anymore

I have implemented the plugin which uses some constants of \Laminas\Log\Logger::WARN di.xml <type name="Magento\Elasticsearch\SearchAdapter\ResponseFactory"> <plugin name=&...
sandip's user avatar
  • 3,954
2 votes
1 answer
838 views

Declaration of Laminas\ServiceManager\ServiceLocatorInterface::get($name) must be compatible with Psr\Container\ContainerInterface::get(string $id)

Magento 2.3.5-p1 having issue Declaration of Laminas\ServiceManager\ServiceLocatorInterface::get($name) must be compatible with Psr\Container\ContainerInterface::get(string $id) /var/www/html/vendor/...
Ramesh's user avatar
  • 986
1 vote
2 answers
723 views

TypeError: rawurlencode() expects parameter 1 to be string, int given in /var/www/html/ee242p1/vendor/laminas/laminas-escaper/src/Escaper.php:246

While doing some of the operations like product edit at admin side, viewing category pages facing an error as follows: TypeError: rawurlencode() expects parameter 1 to be string, int given in /var/www/...
sandip's user avatar
  • 3,954