A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.

Questions tagged [frontend-model]

The tag has no usage guidance.

5 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
4answers
533 views

Admin Module goes to 404 page

I am new in magento and creating a module for use of both frontend and backend. Module works perfectly on frontend but it does not work in Magento Admin. It goes to 404 page.Here is the config file ...
2
votes
0answers
33 views

ReferenceError: {var} is not defined

I have a problem with the frontend_model of the system.xml This is the system.xml <field id="words" translate="label" sortOrder="92" showInDefault="1" showInWebsite="1" showInStore="1"> ...
1
vote
0answers
273 views

Save Config Button does not work when <frontend_model> tag is added in system.xml file

I am adding color picker in system configuration fields. My block class is at vendor/Module/Block/Color.php <?php namespace PME\SuccessPage\Block\Adminhtml\System\Config; class Color extends \...
0
votes
0answers
22 views

Get configValue in _prepareToRender function of a block

I want to get the configValue of system.xml in this block <?php namespace Module\Vendor\Block\Adminhtml\Menu\Field; use Magento\Config\Block\System\Config\Form\Field\FieldArray\...
0
votes
2answers
163 views

Adding new model to Contacts module breaks contacts configuration

Recently I tried to extend the contact form on our website. I wanted to add a drop-down with some possible subjects the user could select. To do this I created a new module MyCompany/Contacts in the ...