The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
1
vote
1answer
74 views

Magento 2, DI & Composer

I would like to know if all dependency injections used in a module have to be declared in the "module dependencies". And, in this case, as "soft" dependencies (in module.xml file), as "hard" ...
1
vote
2answers
2k views

Unable to upgrade to Magento 2.1.0 GA via command line

I've already applied the patch MDVA-532. When I run composer update magento/magento-composer-installer I got this error: Your requirements could not be resolved to an installable set of packages....
1
vote
1answer
48 views

How to Upgrade Magento 2.1.5 to latest version using via composer

I have installed my previous Magento 2.1.5 years ago by downloading , Now I want to upgrade to 2.3.2 using the composer. Can I directly do that. What issues may occur ?
1
vote
2answers
26 views

is it possible to add Magento 2 keys after the installation

I installed Magento 2 without using composer, because I encountered issues and the hosting company helped me with the installation and did not use composer. Is it possible to add my private and ...
1
vote
1answer
55 views

Magento 2 upgrade 2.3

Currently trying to upgrade to the newest magento 2.3 using a script. https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html Whenever I type: php -f pre_composer_update_2.3.php -- --...
1
vote
1answer
37 views

How to make my module available in github (via composer.json) in magento 2

I wish to make my module available in github repository and then i wish to install it to my local using composer.json. How is this possible? Please provide me a solution, to install my module using ...
1
vote
1answer
777 views

Issues while upgrade to Magento 2.3

I am upgrading to Magento 2.2.5 to Magento 2.3.0, Some of the third party module is giving error while composer update. my current php version is 7.2.12 Can you please help me out? Please refer below ...
1
vote
1answer
140 views

When is the setup folder created by Magento?

Can I gitignore it in a composer based installation? I tried deleting vendor/ and composer install, but the setup folder was not newly created. EDIT It is not happening on each composer install - ...
1
vote
1answer
656 views

Magento 2.2.5: Error on cron:run after every production deployment

Since we upgraded Magento to 2.2.5, after every deployment to production (which includes git pull..., composer update & all other relevant Magento CLI commands for production deployment), our ...
1
vote
2answers
2k views

Can't install module using composer on Magento 2.1

I am trying to install M2ePro module on my Magento ver. 2.1.8 application using composer and getting this error: [http]$ php-7.0 /usr/local/bin/composer require m2e/ebay-amazon-magento2 Could not ...
1
vote
2answers
33 views

Magento2 Module installable through composer

We are in the middle of the process to submit an extension to the Magento Marketplace. We have one question about composer installation. Right now, we test our module copying files by hand, is it ...
1
vote
2answers
51 views

Using composer with Magento2

I installed Magento2 without composer. I would like to install a few extensions and another language but all tutorials I have seen use composer. Is it possible to "add" composer when Magento is ...
1
vote
2answers
720 views

How to include files inside pub, lib folder to composer?

I am a developer myself and I built extension for Magento 2. So far it is only zip package file. User just unzip the file, uploads it to ftp and then runs php bin/magento setup:upgrade. Now I need to ...
1
vote
2answers
1k views

Magento 2 not able to login to admin pane;

I just installed a plugin via composer. Note the site and admin panel worked just fine prior and the customer facing sie of the site seems to work fine. After the plugin install I then re-compiled via ...
1
vote
1answer
139 views

Magento 2: How to install modules that are not on the marketplace without breaking the setup interface?

I have this issue when I go to the "Web Setup Wizard" & try to install extensions that I just bought from the marketplace & it gets stuck because there are some modules that have been ...
1
vote
1answer
813 views

Trying to upgrade from 2.1.6 to 2.1.7 and getting a composer error

I am trying to upgrade from Magento 2.1.6 to 2.1.7 using this https://stackoverflow.com/documentation/magento2/9022/upgrading-magento#t=201704130958117574309 as my guide. I type in- composer require ...
1
vote
2answers
2k views

Running composer with php7.0

I have a server where I have two versions of PHP installed (PHP-7.0 and PHP-7.1). I also have two sites one using magento2.1.5 (running PHP-7.0.18) and the other a Code Ignitor project(running PHP-7.1....
1
vote
2answers
584 views

How to exclude app/code/<vendor>/<module>/vendor from code generation in Magento 2

I'm developing Magento 2 module. My composer.json file contains a dependency ("require") to netresearch/jsonmapper. I run php composer update in app/code/<vendor>/<module> folder. It ...
1
vote
1answer
784 views

Magento 2, install security patch without composer

I download magento 2 and install on my machine. I didn't use composer. There is any way to install de security patch without using composer? Thank you
1
vote
1answer
221 views

“Unable to find deploy strategy for module: no known mapping” / when Snowdog SASS theme / or updating any dependency

I have installed the "snowdog/theme-blank-sass": "^0.10.1" Now I am trying to replace it with our fork, versioned 0.110.1 (just added 100) "repositories": [ { "type": "composer", ...
1
vote
1answer
3k views

Could not find package * at any version for your minimum-stability (stable). Check the package spelling or your min imum-stability

Kindly help me on this error I get when I run this command: The extension's composer.json: { "name": "veriteworks/m2-price", "type": "magento2-module", "license": [ "OSL-3.0", "AFL-3.0" ], "...
1
vote
2answers
557 views

Set up theme after Magento 2 composer install

Sorry, but all the doc I found are referring to classic Magento 2 install. The composer installation gives a different Magento file system, so theme tutorials looks useless. I have tried a lot of ...
1
vote
1answer
484 views

Multiple magento-2 modules in single git repository

I am trying to host my magento 2 extensions in a bitbucket repository. each extension will be a branch of that repository. The problem is that, we need to create tag for particular version of the ...
1
vote
1answer
21 views

Installing Magento 2 extension via composer.json file

I bought an extension on Magento store.On my magento installation, I don't have web setup wizard and when I checked the solution for this it requires to change main config file which I don't have ...
1
vote
1answer
50 views

Magento2: How to add dependency in composer for private Gitlab modules?

I'm installing a custom module in M2 using composer from my private Gitlab repo and it is working fine. After I've added the dependency of other modules(using composer require) in my custom module ...
1
vote
1answer
34 views

Autoload error: Vendor autoload is not found. Please run 'composer install' under application root directory in Magento 2

I cloned one gitlab project into the local system in windows. When I am running the project it shows the error like this. Vendor autoload is not found. Please run 'composer install' under the ...
1
vote
3answers
407 views

Composer install issue in Magento 2.3?

I have one issue when I run composer install command. How to solve this issue. Thanks.
1
vote
2answers
495 views

Magento 2.3 composer install issue

I am tring to install to get vendor files in magento 2.3 instance using composer.But i am getting following log: dealsouq@dcwsrv2401:~/public_html$ composer install Loading composer ...
1
vote
2answers
152 views

Magento Twitter Bootstrap 4 composer conflict

When I try and install Magento via composer I'm running into some kind of conflict with twitter bootstrap. If I remove the bootstrap dependency("twbs/bootstrap": "4.1.0") everything install correctly. ...
1
vote
1answer
578 views

Upgrade Magento 2.2.6 to 2.3.0 Resolving dependencies through SAT

I am trying to update my Magento CE 2.2.6 to CE 2.3 with composer but am getting the following. Reading C:/Users/garry/AppData/Local/Composer/repo/https---repo.packagist.org/provider-php-cs-fixer$...
1
vote
1answer
402 views

Ignore platform requirements for sample data installation using Composer

I have a module installed via Composer where the latest master version requires PHP 7.0.x, while the updated version I'm using allows PHP 7.1.x which I have installed. This causes a problem that on ...
1
vote
1answer
182 views

Issues using the Code Migration to migrate to Magento CE v2.2.3 w/ PHP 7.1

I'm attempting to use the code-migration toolkit provided by Magento to assist in our migration to Magento CE v2.2.3 (from v1.9.3.4), but after I clone the latest branch and execute either composer ...
1
vote
1answer
34 views

Testing Pull Requests and Patches from Magento 2's GitHub

I'd like to test the following patch applied by the community. As seen here, https://github.com/magento/magento2/pull/13359/files. Since I've always installed Magento via composer, is there an easy ...
1
vote
1answer
43 views

Installing a downloaded extension with a composer

I am new to M2 and don't exactly know much about composer. I am able to install extensions from GitHub or Magento store with composer just fine. But I don't know what to do with extensions where "...
1
vote
2answers
3k views

How To Download Magento 2.2.2 with Sample data using Composer?

I know how to install Magento 2 using composer. Magento latest release of version Magento 2.2.2. I don't know how to download or Installation with sample data Using Composer. I try to run direct "...
1
vote
1answer
487 views

Magento 2.2 : How To Specify External Library/Dependency In Your Custom Magento Module Deployed under the app/code folder

I have a (Not Open-Source) custom Magento 2.2x module that I'm working on, that has a dependency on an external composer package (bugsnag/bugsnag) Here's how my project is currently structured: ...
1
vote
1answer
107 views

How to add Unirest to Magento 1.9.3.2?

I am trying to integrate Prompt Cloud API with magento. For it the basic requirement is to install Unirest library. I am trying to install using composer: composer require mashape/unirest-php And ...
1
vote
1answer
100 views

Namespaces for “Magento\\Framework\\”, “Magento\\” and physical directory structure

I have a custom class 'class ProductsList extends\Magento\CatalogWidget\Block\Product\ProductsList' and wonder where is the physical file containing the class? Looking at the top level composer ...
1
vote
1answer
674 views

Magento 2: Use Google API client library for PHP

I want to use Google API client library for PHP in my extension to upload YouTube video. I ran following composer command to add this library. composer require google/apiclient:~2.0 But I got ...
1
vote
1answer
271 views

Magento2 Install extension from multiple-extensions repository

I want to modify one extension from public GitHub repository(fork), and install it to my Magento2 via composer. Extensions stored here GitHub. Really, i need only one sample-external-links. I tried ...
1
vote
1answer
495 views

Error while installing language pack via composer require in magento 2

I am getting below while running composer require mageplaza/magento-2-dutch-language-pack:* The requested package mageplaza/magento-2-dutch-language-pack * is satisfiable by mageplaza/magento-2-dutch-...
1
vote
1answer
437 views

Modules/Extensions installed via Composer Problem [closed]

I've installed Magento 1.9.3 locally on my computer and then installed a couple of extensions via composer. Modules/Extensions are Fontis Australia Post and Better404 They seem to have installed OK, ...
1
vote
1answer
725 views

Magento 2: Is there a “safer” way to run Composer Upgrade without enable allow_url_fopen?

I had an issue with running Composer Upgrade command due to allow_url_fopen is not enabled in PHP.ini. I ended up consulting the host provider and they recommended against having this parameter ...
1
vote
2answers
1k views

Composer package requirements unresolved

I created a package on packagist.org for the de_CH locale which is basically cloned from de_DE. Installing the de_DE package works fine via composer with Magento 2.1, but de_CH doesn't, although ...
1
vote
1answer
511 views

Magento 2 Composer Update

The "https://repo.magento.com/packages.json" file could not be downloaded: SSL: Connection reset by peer How can I fix this? I already updated my credentials. This is my ~/.composer/auth.json ...
1
vote
2answers
620 views

app/code folders missing in magento 2

The tutorial I'm working through: http://alanstorm.com/category/magento-2 does not explain what to do with the missing app/code directory. I got Magento by compressed archive and I understand — the ...
1
vote
1answer
1k views

Composer Update Not working

I have googled everywhere to find an answer to my issues. Loading composer repositories with package information [Composer\Downloader\TransportException] Your configuration does not allow ...
1
vote
2answers
985 views

Install magento via Puppet or Composer?

There are several modern ways to install Magento: Magento as Puppet Module: cmuench/Magento-Vagrant-Puppet-Nginx or bippo/puppet-magento Magento as Composer Dependency - so you create composer.json ...
1
vote
1answer
13 views

Magento Update to 2.3.3 backend after login Specified invalid parent id Magento_Analytics

i have a problem while upgrading Magento from 2.3.2 to 2.3.3. The update works fine and i have all done which mentioned here: https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html ...
1
vote
1answer
57 views

Error in Upgrade Magento CE version from 2.2.3 to 2.3.0 with composer?

I have tried using below command but getting errors when update Command 1: composer require magento/product-community-edition 2.3.0 --no-update Command 2: composer update Output: Your ...