Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
0 votes
1 answer
23 views

Why isn't a package showing showing for update?

Using composer I would like to update xtento/productexport I am on version 2.9.0 and the most recent version is 2.14.4. When I run composer outdated it doesn't show that it needs an update. In order ...
  • 873
0 votes
2 answers
58 views

Proper environment for magento2-2.3 on windows 10

I'm working on Win 10 OS. And am going to install magento2-2.3 on my local computer. Which xampp version and composer version should I use?
2 votes
1 answer
5k views

Downgrade composer version 2 to 1

The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). ...
  • 1,451
3 votes
2 answers
532 views

How to interact with APCu?

Magento DevDocs recommends to use APCu. I have enabled it and it works somehow, but I don't why and, and when to do what. I use already apc.php. Can anyone share some knowledge regarding APCu and ...
  • 301
1 vote
1 answer
548 views

Installation with composer fails

Trying to install M2 using Composer with the following: composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition /var/www/m2 PHP: PHP 7.4.12 (cli) (built: ...
0 votes
1 answer
770 views

Updating Module Via Composer will NOT Update Module?

When Updating Module Via Composer it will not Update Module on my localhostx? When I put this line. I get this error on my local host. composer require "route/route-m2" Could not find a ...
0 votes
1 answer
322 views

Composer update fail: [UnexpectedValueException]

Magento 2 Composer error when trying to install modules [UnexpectedValueException] https://magento.stackexchange.com/a/316793/70292 During composer update command UnexpectedValueException was occur. ...
2 votes
1 answer
2k views

Magento v2.3.5 to v2.3.6 update, composer version issue

I believe this is due to the recent update to composer, but would appreciate any thoughts... Trying to update Magento from 2.3.5 to 2.3.6, having just updated to the latest version of composer (2.0.4) ...
1 vote
1 answer
193 views

Installation failed, reverting ./composer.json to its original content. Authentication always fail even though the credential are correct in magento 2

I am alwaays getting the below error when running composer require like that. I am currently giving the authentication keys but still it displays error. Please help Installation failed, reverting ./...
0 votes
0 answers
38 views

Magento admin dashboard showing after login

My admin dashboard after logging in is showing the following error: does any one know the reason behind it or how can we solve it? I have recently installed this module through composer I have ...
0 votes
2 answers
150 views

Error Upgrading from Magento 2.3.4 to Magento 2.4.1

I tried to upgrade from Magento 2.3.4 to Magento 2.4.1 using these commands: composer require magento/product-community-edition=2.4.0 --no-update composer update then i got the following error like ...
0 votes
0 answers
273 views

Composer install magento: Class PayPal\Braintree\Console\VaultMigrate does not exist

we are installing magento and seeing Composer install magento: Class PayPal\Braintree\Console\VaultMigrate does not exist Braintree is neither required neither replaced ... How can it go missing? Or ...
  • 5,342
0 votes
2 answers
748 views

Magento 2 Composer error - The contents from the "/vendor/magento/module-media-gallery-synchronization-api/etc/module.xml" file can't be read

We upgraded to Magento 2.4 and exec recompile All is OK no warning Only when I open the frontend I see the error below Magento 2 Composer error - The contents from the "/vendor/magento/module-...
  • 5,342
0 votes
1 answer
791 views

unable to remove patch from composer.json

I have to update extension https://i.imgur.com/SgHq8YK.png but it has an error, Can I remove it manually? I think it cant be good practice. how can I safe remove it? dockergento composer remove iwd/...
1 vote
1 answer
688 views

InvalidArgumentException during Magento upgrade via Composer [Package is not installed: magento/project-community-edition-2.4.0.0]

We are seeing InvalidArgumentException during Magento upgrade via Composer [InvalidArgumentException] Package is not installed: magento/project-community-edition-2.4.0.0 It seems to be related to ...
  • 5,342
0 votes
1 answer
393 views

Magento 2 upgrade from 2.3.5 to 2.4 not working via composer - php is already at version 7.4 before the upgrade!

Situation: Magento 2 upgrade from 2.3.5 to 2.4 not working via composer - php is already at version 7.4 before the upgrade! These commands executed fine COMPOSER_MEMORY_LIMIT=8G composer remove ...
  • 5,342
5 votes
3 answers
8k views

Magento 2.4 - Composer php 7.4 error magento/magento2-functional-testing-framework

We run Magento 2.4 with php7.4, that should be supported. But we get the following error when we try to update a module using composer: magento/magento2-functional-testing-framework 2.6.5 requires php ...
  • 1,522
1 vote
2 answers
304 views

Class NewRelic\Monolog\Enricher\Handler does not exist

I just reinstalled magento using composer install Then I tried to run this command php bin/magento setup:upgrade and also tried running other setup commands. I got the following error: Class NewRelic\...
0 votes
1 answer
47 views

Magento 2.3.2 version upgrade to 2.4.0

I am afraid of upgrading my magento version because my store is all setup. My php version is 7.3.20 and I thinking of upgrading to magento version 2.4.0 composer require magento/product-community-...
0 votes
1 answer
42 views

Magento 2 Composer install error

The following are causeing PHP version error plz suggest solution
0 votes
0 answers
2k views

How to install "authorizenet/magento-module-authorizenet" on Magento 2.4?

There is no Authorize.net payments in Magento 2.4 by default. Magento recommends to "use the official extension from marketplace instead". 'Official extension' is compatible with Magento ...
  • 1,989
1 vote
1 answer
1k views

Magento 2.3.4 to 2.3.5-p2 upgrade composer google shopping error. Any ideas?

I am trying to upgrade Magento 2.3.4 to 2.3.5-p2 but i am facing a composer error regarding Google shopping. First i upgraded from 2.3.4 to 2.3.5-p1 without any problems, but when trying to upgrade ...
  • 23
0 votes
1 answer
37 views

incorrect magento 2 version being installed on composer update

I'm trying to install Magento 2.3.3 but for some reasons it keeps on installing 2.4.0. I tried clearing the composer cache and reinstalling everything(delete vendor and composer.lock). but it always ...
  • 133
0 votes
1 answer
291 views

Magento 2 - Install extension using composer error - Plugin class Searchanise\SearchAutocomplete\Plugins\Toolbar doesn't exist

After install extension using composer, extension installed successfully but not visible on back-end how to solve this issue. Screenshot : extension : https://marketplace.magento.com/searchanise-...
  • 145
0 votes
2 answers
41 views

Magento 2 - Composer require "extension" installation error

Can't able to install extension using composer,
  • 145
0 votes
1 answer
168 views

Magento 2.3.4 - How to properly remove or uninstalled Temando extension including tables from database?

I have faced lot issue based on this extension, i can't able to remove by using following cmd, composer remove Temando_Shipping Now i just disabled, how to remove properly?
  • 145
0 votes
1 answer
725 views

Module not found after composer require

im using a fresh magento install from Ionos 1&1 (CentOS 8), and just after doing composer require, I test if the module installed correctly, but it says it cant be found. Here is the output: [root@...
1 vote
2 answers
3k views

Magento 2.4 error when try to install sample data

I've installed Magento 2.4 (fresh) with the Composer. Installation work fine (frontend and admin) But when try to install demo data using manual get an error. $ magento deploy:mode:show ...
2 votes
2 answers
454 views

Magento 2, How to make users to install the plugin via composer

In my module, I have created a composer.json file with this code and pushed it to git { "name": "lovat/magento2-api", "description": "Lovat Api Sales Module ...
0 votes
0 answers
60 views

magento 2.x using composer in windows localhost

I not able to set the Megento 2.4.0 as the setup button is not displaying on screen after downloading megento. Attaching screenshot for the reference of Where am I actually stuck .
2 votes
1 answer
3k views

Compose error show in upgrade command

I have updated Magento version Magento 2.3.5-p1 to Magento 2.4.0 When I am running Magento setup upgrade command php bin/magento setup:upgrade then it's showing me below error Module '...
0 votes
1 answer
506 views

Magento 2 cannot update module with composer

I'm trying to update a module from Mageworx , currently I have the version 2.31.0, it's "mageworx/module-seosuiteultimate": "^2.30", there is not something like an specific module ...
2 votes
2 answers
736 views

Installing magento 2.4 issue

After running the composer command: composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition magento2 I am receiving the following error: An error has ...
  • 3,716
2 votes
3 answers
1k views

Magento 2.4 installation using composer MagentoHackathon/Composer/Magento/Plugin.php failed to open stream: No such file or directory), rolling back

I am trying to install Magento2.4 Open source on the following setup. VirtualBox 6.1 on Windows 10 Nginx server Ubuntu 20.4 server installed on the Virtualbox Php 7.3.20 Command used: composer create-...
  • 1,406
1 vote
1 answer
667 views

Why I'm receiving an error messages Class does not exist when running DI compile?

Why am I receiving error messages "Class does not exist" when running DI compile? I removed some modules using the node replace in my composer.json, as you can see below. "replace"...
1 vote
0 answers
97 views

Magento 2.3.4l: When installing PHP SDK I find "Your requirements could not be resolved to an installable set of packages"

I'm attempting to install walmart-partner-api-sdk-php from github using composer. Below is what I see on running the command to install. Any advice as to how to fix this is appreciated. Your ...
2 votes
1 answer
780 views

How to check all Magento 2 versions available to install via Composer?

I work with different projects using Magento 2.1, 2.2 and 2.3, I'd like to update each project to the last version available of each release, for example: Magento 2.2.4 -> Magento 2.2.11 How could ...
0 votes
2 answers
1k views

Accidentally deleted the Vendor folder

I accidentally deleted the vendor folder in my Magento 2 installation and I'm getting an autoload error and I also noticed that the env file is missing, is there any way to solve the problem ? I also ...
user avatar
1 vote
0 answers
33 views

composer/composer 1.10.8 requires composer/semver ^1.0 -> no matching package found

i am trying to do composer update on my magento2 installation, which is at version 2.3.4 i am getting following error [Composer\DependencyResolver\SolverProblemsException] ...
  • 11
1 vote
1 answer
26 views

Error on install modules with composer in Magneto 2.3.1

I have installed Magento 2.3.1 and PHP 7.2.31 and I have run below command, COMPOSER_MEMORY_LIMIT=-1 composer require company/module --no-plugins and getting error like below, Problem 1 - magento/...
  • 107
1 vote
0 answers
30 views

Not able to install modules with composer in Magneto 2.3.1

I have installed Magento 2.3.1 and PHP 7.2.31, I am trying install modules with composer and getting error like below, Fatal error: Uncaught TypeError: Return value of Magento\...
  • 107
0 votes
1 answer
67 views

composer install magento2.3.5-p1

I try to install magento2.3.5-p1 by use composer, when it is finished the folder structure looks like: Anyone knows why it is like that?
  • 125
2 votes
1 answer
540 views

css and js not found in magento 2.3.5

Refused to apply style from http://localhost/magento2-2.3.5-p1/pub/static/version1593595791/adminhtml/Magento/backend/en_US/extjs/resources/css/ext-all.css because its MIME type ('text/html') is not ...
1 vote
0 answers
7k views

Composer " The "https://repo.packagist.org/packages.json" file could not be downloaded"

I'm using a mac, virtualbox with a bridged connection and Ubuntu server 20.04. I'm following this tutorial to install Magento 2 on this server. https://websiteforstudents.com/install-magento-2-on-...
  • 21
1 vote
1 answer
3k views

Magento 2 replace dotmailer/dotmailer-magento2-extension errors with compiler error

We have added the following to composer json in M 2.3.5 "replace": { "dotmailer/dotmailer-magento2-extension": "*", Then we run php bin/magento setup:di:compile ...
  • 5,342
0 votes
1 answer
501 views

Cannot upgrade from 2.3.4 to 2.3.5 because of Temando

After running this command: composer require magento/product-community-edition 2.3.5 I get the following error: Your requirements could not be resolved to an installable set of packages. Problem 1 - ...
0 votes
0 answers
42 views

Error When Install Data Migration Tool to Magento 2.3.1 with composer

I have run below commands with composer in Magento 2.3.1 and getting error like below. composer config repositories.magento composer https://repo.magento.com composer require magento/data-migration-...
  • 107
0 votes
0 answers
18 views

Magento 2.3.1 installation error with composer

I have used PHP 7.2.31 and Magento version 2.3.1 but when Magento 2.3.1 installation with composer getting error like below, ===================== Your requirements could not be resolved to an install-...
  • 107
1 vote
1 answer
289 views

Is it possible to remove extension installed via composer without composer?

I've got a problem with a website that i have inherited from another developer, it's Magento 2.3.2 with quite a few extensions installed... The majority of the extensions are installed at /app/code - ...
0 votes
1 answer
2k views

Magento 2 - How to upgrade to magento 2.4.0?

I try to upgrade from 2.3.5-p1 to 2.4.0. I changed the version in composer.json and executed composer update but I get: Loading composer repositories with package information Updating dependencies (...
  • 2,842

1 2 3
4
5
15