Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
0 votes
1 answer
2k views

composer update failed with "Failed to set PHP CodeSniffer installed_paths Config"

New to magento I wanted to upgrade my Magento to 2.4.4 . Using php 7.4 with Ubuntu 20.04 and nginx composer -vvv update I get this: Dependency resolution completed in 0.003 seconds Installing ...
  • 105
0 votes
1 answer
101 views

Setup composer.json for updating to lasted version later

I want to set up my composer.json then able to update the to newest version lately For example: module has composer.json { "name": "vendor/module", "description": ...
0 votes
0 answers
685 views

error install module with composer: PluginManager.php(273) : eval()'d code line 188

I have a problem when installing a module with composer, no matter which module, I get the same error. (In PluginManager.php(273) : eval()'d code line 188) Magento v2.4, PHP 8.1 run composer require ...
  • 101
0 votes
1 answer
189 views

Magent 2.3.4 Installation error

I was do setup the magento 2.3.4 version in Php 7.3 version But Frontend throw error Fatal error: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">...
0 votes
2 answers
264 views

Magento 2.4.3 upgrade composer dependencies issues

I want to install league/flysystem-cached-adapter 1.1 but it throws the following error on composer require Problem 1 - Root composer.json requires magento/product-enterprise-edition 2.4.3-p1 ->...
  • 580
0 votes
1 answer
203 views

Upgrade problem from 2.4.2-p1 to 2.4.3-p2

When I try and upgrade from 2.4.2-p1 to 2.4.3-p2 these are the steps I follow- composer require magento/product-enterprise-edition:2.4.3-p2 --no-update composer update magento/product-enterprise-...
  • 873
0 votes
1 answer
77 views

Magento installing different modules to those stated in composer.json

I have successfully updated to 2.4.3 and in doing so have upgraded a number of modules. For some reason, however, Magento is ignoring the module versions stated in the composer: Two modules for ...
1 vote
1 answer
60 views

Magento 2 restrict run composer update during setup upgrade

I have run setup:upgrade and Magento has run the composer update command automatically. Can we restrict this?
0 votes
0 answers
118 views

How to resolve composer file not found - Magento 2.4 / AWS

This issue appeared in Magento 2.4 hosted in AWS. Magento root is having composer.json as it was before these errors appeared. The issue appeared after running these commands, not sure whether that ...
2 votes
0 answers
309 views

Composer replace no longer working for Magento Cloud 2.4.3

I was trying to setup a new Magento Cloud 2.4.3 project, and wanted to remove unnecessary module from the installation. I usually use yireo/magento2-replace-all package to clear out some of the module ...
0 votes
2 answers
1k views

Failed to upgrade from Magento 2.4.1 to Magento 2.4.3-p1

I'm using magento version 2.4.1 and composer version 1.10.25. i tried to update it to magento 2.4.3-p1 using composer but i always received an error. First i run this command: composer require magento/...
  • 89
0 votes
0 answers
131 views

Composer.json cannot be found

I am currently trying to install Magento Cloud locally using Docker on my Windows 10 Pro. The issue I am having is when I run the command: curl -sL https://github.com/magento/magento-cloud-docker/...
  • 41
0 votes
1 answer
278 views

Update Magento 2.3.3 with Composer 2

I manage a multisite system for work, with Magento 2.3.3 Community Edition My hosting is managed, and they recently rolled out Composer 2 for all customers on their hosting. I'm trying to update the ...
0 votes
2 answers
444 views

"You can only install one version of a package" error when upgrading from 2.2.6 to 2.4.3

I am trying to upgrade from Magento 2.2.6 to 2.4.3. This is what I have done so far: php composer require magento/product-community-edition=2.4.3-p1 --no-update --> That worked without errors Now ...
0 votes
0 answers
56 views

Magento 2 - How to install composer.json of a third party module?

I created a new extension. I have this composer.json in my project: app/code/Company/App/composer.json: { "name": "company/module-app", "description": "...
  • 2,842
0 votes
1 answer
61 views

Change magento2 installation

I have taken over a magento 2.3.3-p1 project. Unfortunately, the installation was done by cloning the repo from github and not using composer. So all magento core modules are under app/code/magento. ...
0 votes
2 answers
370 views

Magento cloud setup install failure

I am trying to install magento in magento cloud. To do so I did: check out https://github.com/magento/magento-cloud setup auth.json setup env:COMPOSER_AUTH in the project with same values stored in ...
0 votes
1 answer
111 views

Upgrade magento from 2.4.2 to 2.4.3-p1

I'm trying to upgrade magento 2.4.2 to 2.4.3-p1 with composer 2, but I'm stuck with is error: Updating dependencies Your requirements could not be resolved to an installable set of packages. ...
7 votes
2 answers
7k views

Why Composer install is asking to allow-plugins?

Why when I run composer install using Composer 2, I'm receiving these messages below asking to "trust" the Composer plugins? magento/magento-composer-installer contains a Composer plugin ...
0 votes
1 answer
328 views

Magento 2 Setup Custom Module Download Using Composer

GitHub Link -> https://github.com/mahesh-code-work/Module-Learn/ I create one small basic module and try to install using composer. How to set up the whole setting and what is the right way to do ...
  • 7,090
1 vote
1 answer
209 views

How to upgrade a Magento Cloud project via Composer?

In a Magento Enterprise or Magento Community version I just need to change the package version in my composer.json. How could I do the same in my Magento 2.3.7-p1 Cloud to update to Magento 2.3.7-p2?
1 vote
3 answers
3k views

Syntax error when compiling / Upgrade from 2.4 to 2.4.3

I am getting this error when compiling my updated MCE 2.4.3 install. I have php 7.4.27 in magento and outside in the shell. I have read that this might be connected to wrong version of php but i ...
0 votes
1 answer
59 views

How to use Library installed using composer in your custom module?

I have installed the Authorize.net library in Magento using composer. Now, this library is available in the vendor directory but I don't have any idea how to use it in my custom module. The directory ...
0 votes
1 answer
55 views

Issue installing Composer package, file couldn't be dowloaded

I have "meetanshi/magento-2-defer-parsing-javascript": "1.0.4" dependencie in my project. When running composer install inside my Dockerfile, I got the following error: - ...
0 votes
2 answers
115 views

need help for installation of a extension WebP Optimized Images

I want install an extension: Magento 2 Open Source (CE) WebP Optimized Images Component name: jajuma/module-webpimages Versions: 2.1.8 and tried to install with the installation sheet: https://devdocs....
0 votes
0 answers
27 views

Magento 2.3 install issue with php warning

I am trying to install Magento 2.3 by using composer install / update. I got below error. Any idea what problem I am facing? I did try to use different php & composer version. Still having this ...
  • 592
0 votes
1 answer
191 views

Removing "require-dev" section from composer.json

Is this a sane thing to do on Production site? "require-dev": { "allure-framework/allure-phpunit": "~1.2.0", "friendsofphp/php-cs-fixer": "~2....
0 votes
2 answers
187 views

URI is not valid and cannot be converted into a string when trying to load website

Preconditions (*) PHP 7.4.27 composer 2.1.4 Magento version 2.4.2-p2 enterprise Elasticsearch 7.16.2 Redis Cache 5.0.14 Grunt 1.0.4 Steps to reproduce (*) Install a fresh installation of Magento ...
0 votes
2 answers
168 views

Memory size exhausted when trying to update Magento 2.3.0 to 2.3.1 through putty

I'm trying to update my Magento 2.3.0 installation to Magento 2.3.1. I'm trying to do this through putty, but when I try to do "composer update" I get this error: - magento/inventory-...
  • 1,457
0 votes
1 answer
89 views

magento2 custom module installation from git using composer

how to install my custom module on another magento2 project from git using composer I tried with composer config ->this works fine. when I run composer require its shows an error [RuntimeException] ...
  • 66
0 votes
1 answer
224 views

Upgrade from Magento 2.3.4 to Magento 2.4.3 still shows old version in admin

After upgrading to 2.4.3 (after several issues down the line), the admin still shows the previous version (2.3.4) in the footer, although the CLI version displays 2.4.3. Here are the steps: Using ...
0 votes
1 answer
3k views

Magento 2 - dealerdirect/phpcodesniffer-composer-installer v0.5.0 requires composer-plugin-api

I try to update my packages via composer with composer update but I get this: The "dealerdirect/phpcodesniffer-composer-installer" plugin was skipped because it requires a Plugin API ...
  • 2,842
0 votes
2 answers
161 views

Price is automatically rewritten to 0.00 on the product detail page for Magento 2.4.3-p1

Price is overwritten in the product detail page to 0.00 for non-English/United States locale options. I tried to find a solution to solve this problem but found nothing on the forum. There are several ...
  • 1
0 votes
0 answers
56 views

Magento 2.4.0 upgrade to 2.4.3 error

I am getting error while upgrading Magento 2.4.0 CE to 2.4.3 while executing setup:upgrade command. Cannot instantiate interface Magento\MediaContentSynchronizationApi\Model\GetEntitiesInterface#0 /...
0 votes
3 answers
104 views

Composer memory size fatal error

I keep getting this error every time i run anything related to composer (install, update, require, etc.) Ive tried almost every website or solution I could find to no avail. Can anyone tell me how to ...
  • 71
0 votes
1 answer
365 views

Magento 2 : Magento\Setup\Mvc\Bootstrap\InitParamListener containes 1 abstract method

I am facing issue when I execute command of upgrade & deploy. I executed composer update command. I know it's repeat question and tried solution But I didn't solve issue yet. Can anyone please ...
0 votes
3 answers
514 views

How do I install the latest Magento 2 via composer with sample data and Elasticsearch?

Using Debian 10, I installed PHP 7.4, PHP-FPM 7.4, Mysql 8, NGINX, Elasticsearch, Magento2 via composer, Redis-Server, varnish, Changed the ownership of all files to a user, and run NGINX using this ...
0 votes
1 answer
385 views

Magento 2.4, Error: Your requirements could not be resolved to an installable set of packages

I'm trying to install extinctions to Magento 2.4 and I have the following error: composer command: composer require mageplaza/module-core Updating dependencies Your requirements could not be ...
  • 103
0 votes
2 answers
1k views

Failed to open stream: Permission denied on only one module

One of our extensions give the following error message on the front page: Warning: require_once(/var/www/html/magento2/app/code/xxxVendor/xxxModule/registration.php): failed to open stream: ...
  • 7
0 votes
2 answers
39 views

Can't install extension prisync/pricer over composer

Marketplace Magento doesn't let customer install by package download. They only let customer install extension over composer. But when I try to install extension composer require prisync/pricer. It ...
0 votes
1 answer
444 views

get magento to use Composer 2

I'm actually having this issue but first I want to resolve why it's still looking at Composer 1. me@server:/.../magentoproject$ sudo ./bin/magento sampledata:deploy [sudo] password for me: <warning&...
  • 103
0 votes
2 answers
600 views

Update Magento 2.3.0 to 2.4 Error in "Check Component Dependency"

I'm trying to update Magento from 2.3.0 to 2.4 using the setup Wizard. In the Readiness Check, I'm getting the following error: **Check Component Dependency We found conflicting component dependencies....
0 votes
1 answer
77 views

Magento 2 : Getting Error while upgrade magento from 2.2.6 to latest version 2.4.3

I am try to upgrade magento version from 2.2.6 to 2.4.3 using composer method. When try to that, I face following error which attached in screenshot: https://i.imgur.com/wGoTAFn.png, please help..
0 votes
1 answer
1k views

No lockfile found. Unable to read locked packages Magento2.4.3 composer update issue

/app/magento2# composer update Loading composer repositories with package information In Laminas\DependencyPlugin\DependencyRewriterV2::onPrePoolCreate Updating dependencies Nothing to modify in lock ...
0 votes
2 answers
54 views

How to configure Magento 2 to have personal/private develpment extensions just for myself

I have several development tools which I personally use like: https://github.com/ho-nl/magento2-Ho_Templatehints https://github.com/mage2tv/magento-cache-clean Is it possible to somehow configure ...
  • 1,394
0 votes
5 answers
2k views

Magento 2.4.3 Installation Error

I am try to install Magento 2.4.3 with the command in Ubuntu. After follow all the steps, when I try to run the Magento from browser, it show me error like this : Composer detected issues in your ...
0 votes
1 answer
726 views

Getting "Vendor autoload is not found." error even the composer install succeeded

When i open Magento in browser i got Autoload error Vendor autoload is not found. Please run 'composer install' under application root directory. even i have run composer update composer install on ...
  • 103
1 vote
3 answers
2k views

Magento 2.4.3 and Composer error messages for allure phpunit and ramsey uuid - Can't continue with update

I'm getting some error messages from composer, when I try to upgrade from Magento 2.4.2 to Magento 2.4.3, and these are: - Root composer.json requires magento/product-community-edition 2.4.3 -> ...
  • 330
3 votes
1 answer
2k views

Multiple users keys for the same repository

Hey guys I'm building a Magento 2 app where there are 2 different teams working on the project. 1 internally and the other outside of our premises and we have 2 separate Magento marketplace accounts. ...
  • 147
0 votes
2 answers
1k views

Laminas compile error at update to 2.4.3

I was updating Magento Community from 2.4.2 to 2.4.3 and get this error at compile on 55%: Deprecated Functionality: Class Laminas\Hydrator\Reflection is deprecated, please use Laminas\Hydrator\...

1
2
3 4 5
15