The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

158 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
7
votes
1answer
91 views

Magento module:uninstall orphans any dependencies (required modules)

I have some modules that are dependent on a core module. When I use the command composer require stti/module-catalogbook Magento installs 2 modules.. Stti_Catalogbook and Stti_Catalogcore. If i ...
6
votes
3answers
459 views

how to install extension without composer

I want to install this extension in my project where i have integrated a new template :evincemage/module-trackorder . I tried with empty project(without template ) it works but with template it does '...
6
votes
1answer
969 views

Error during upgrade to Magento 2.1 from 2.0.7

Since a couple of days i try to upgrade my "native" Magento 2.0.7 I use composer as suggested by documentation : composer require magento/product-community-edition 2.1.0 --no-update; composer update; ...
5
votes
0answers
105 views

Module version in composer.json

I'm running the static tests on one of my modules and on magento version 2.3 it reports an inconsistency: Version must not be specified in the root and package composer JSON files in Git Failed ...
5
votes
1answer
3k views

Magento 2.2.0 - Upgrade / Migrate from Magento 2.1.9 to Magento 2.2.0 with Sample Data

Followed below commands to upgrade Magento 2.1.9 to 2.2.0 using terminal 1. composer require magento/product-community-edition 2.2.0 --no-update 2. composer require \ magento/module-bundle-...
4
votes
0answers
482 views

Could not install B2B extension for magento 2.2.0-EE

I have installed Magento-EE-2.2.0 with sample data. After installation, i tried to install B2B extension using composer composer require magento/extension-b2b Used the following reference site ...
4
votes
0answers
127 views

Validating composer.json in magento giving me the following error

Updating through the command line and with market place took 1) Once you have packaged your extension in .zip file move it to a directory. 2) Download the validation script and extract it to the ...
3
votes
1answer
53 views

Magento 2.3.0 Shared Server Are Different PHP Version(s) An Issue

I’m trying to install Magento 2.3 with Composer, with php 72. I am hosted on a shared cloud server that has php 70 as the server version (what php -v returns). I can set the local version of php to ...
3
votes
1answer
269 views

How to make and install my module via composer with two private repositories in magento 2

Problem Description: I have created two private repositories in github under same user name. Each repository contains different modules. But while trying to install the package via composer throws ...
3
votes
1answer
509 views

composer connection refused

Context: magento 2.1.7 community-edition composer.phar 1.7.2 installed and setup on a development server then deployed on a production server (dictinct from the previous) All worked well, including ...
3
votes
3answers
83 views

How to solve this error?

I am trying to upgrade magento version from 2.1.9 to 2.1.10 I got following error. Module 'Magento_Ui' from '/home/zitomer/upgrade.zitomer.com/app/code/Magento/Ui' has been already defined in '...
3
votes
0answers
541 views

Magento 2 InvalidArgumentException Could not find a matching version of package

I am trying to install the module using the composer in Magento 2. I have created a module and publish on the GIT repository and also added the GIT repository URL at packagist. Module GIT URL: ...
3
votes
0answers
161 views

Publishing extension to Marketplace

I'm trying to publish extension to the magento marketplace. I receive an error when i press submit button on magento's web from: Can't connect to package repository i have added my GitHub ...
3
votes
0answers
255 views

How to upgrade new version of module code by using composer in Magento 2 from third party repository

We have installed third party modules successfully using command composer update by Adding below repository to composer.json "repositories": { "0": { "type": "composer", "url": "...
3
votes
0answers
317 views

Composer\Downloader\TransportException

Invalid credentials for https://repo.magento.com/archives/magento/module-sales-archive/magento-module-sales-archive-100.1.1.0.zip I've successfully configured Composer credentials with my Magento Key ...
2
votes
0answers
27 views

Magento 2: How to install custom module in app/code folder only using composer.json file?

I'm trying to install my custom module using composer.json file and after run composer update command my custom module installed successfully in magento2. Actually I want to install my custom module ...
2
votes
1answer
31 views

Best Practice Magento 2 / Composer / Custom Module

Can you tell me what are the best practice when you create a custom module for a project. I would say to put the custom module related to the project in app/code/MyNamespace/MyModule and all Generic ...
2
votes
0answers
44 views

Magento2: How to install an external package without composer?

I have some packages installed under the vendor dir. Now, I need a way to take one of them out & place it somewhere else that'll allow editing the files (same as moving a Magento module to app/...
2
votes
3answers
45 views

How to install composer in magento

I am trying to install composer using "composer install" from my command terminal display error.
2
votes
0answers
46 views

why deployVeniaSampleData.sh runs out of memory

Trying to run the Venia sample data deploy script bash deployVeniaSampleData.sh --yes but keeps getting mmap() failed: [12] Cannot allocate memory PHP Fatal error: Out of memory (allocated ...
2
votes
0answers
185 views

Magento 2.3.1 JSON.parse: unterminated string at line 2 column 1009

I am unable to set payment method in Magento 2.3.1. As soon as I click on the payment method button all JavaScript functions are killed. open error log nothing to show, but browser console point me ...
2
votes
0answers
54 views

NGINX 404 error despite Magento Installation complete on CentOS 7 terminal

I am trying to load the /admin part of my development build of the website. I am unsure what could be the cause of this. Using this command: (Some of these details are intentionally not in line with ...
2
votes
2answers
44 views

Composer merge conflicts

We have a develop branch. Every new feature gets created on a branch that runs off the develop branch. Then a pull request is made to the develop branch. This triggers our CI/CD and slowly but ...
2
votes
0answers
428 views

Setup page not getting loaded after install

I have been trying to install magento 2, When i am trying to access the setup page from url, but the url is not accessible it says This page isn’t working xx.xx.xxx.xxx is currently unable to ...
2
votes
2answers
109 views

Changing from a git to a composer installation

I'm afraid, I've got a Magento 2 installation which has been done via git. I'm not a developer and would like to upgrade simply via composer update. Is it somehow possible to move or migrate from one ...
2
votes
0answers
73 views

Can't upgrade to Magento Commerce 2.2.3

Trying to upgrade Magento Commerce (EE) to 2.2.3 from 2.2.2 using composer, however, the package doesn't seem to be available in repo.magento.com - anyone else had this problem? Tried a lot of ...
2
votes
5answers
602 views

Magento 2 Install extension but not upgrade Magento via composer

So if I understand it right the php bin/magento setup:upgrade is used for both, upgrading magento 2 and also for installing extensions via composer. How can I just install the extension without ...
2
votes
3answers
387 views

Magento 2.1.9 Composer error

I'm getting the following error using Magento 2.1.9: "Package magento/composer's source key should be specified as {"type": ..., "url": ..., "reference": ...}, {"type":"git","url":"https:\/\/github....
2
votes
0answers
330 views

Custom theme installed via composer require not showing in setup:static-content:deploy or admin panel

I've created my own custom theme and uploaded it to my private package repository. This works fine and downloads my folder into vendor/<vendor>/theme-my-theme I run: php bin/magento setup:...
2
votes
0answers
403 views

Magento2 Compile command ends at Repositories code generation 1/7

Magento v2.1.7 CE PHP 7.0 Permissions double checked When I run compile command through cli, it ends at step 2 as seen in the image below. I found that it might be due to a wrong auth.json in ...
2
votes
0answers
86 views

Choosing Magento 2 branches, using patches or fixing bugs in custom modules?

I recently ran into a pretty annoying bug with Magento 2.1.6, which made it impossible to save categories with a lot of products (performance issue). I soon discovered that the solution was quite easy,...
2
votes
0answers
150 views

Magento 2 : Why my module is on the vendor and app folder?

I use these commands to install my dependencies today: composer config repositories.myvendor_cli vcs git@github.com:myvendor/my-cli.git composer require myvendor/cli:dev-master To work well I ever ...
2
votes
0answers
2k views

Invalid argument supplied for foreach() magento version 2.1.3

php bin/magento setup:upgrade [Exception] Warning: Invalid argument supplied for foreach() in G:\workspace1\magento2- alexa\vendor\magento\module-store\Model\Config\Processor\Fallback.php ...
2
votes
5answers
4k views

Magento Installation Error - Magento 2

I have uploaded Magento2 source code on centos Rackspace server, and I have changed credentials whenever required, but when I run my website, I get an error like "Vendor autoload is not found. Please ...
2
votes
1answer
606 views

Magento 2 deployment from Dev to Staging using Git

I have a local Dev environment and installed Magento 2 using composer I initialized the local /magneto2/ folder as a Git repo I added this .gitignore file to the root of my /magneto2/ folder I have a ...
2
votes
0answers
1k views

Installing Data-Migration-Tool with Composer: git not found error

when I try to install the Data-Migration-Tool with Composer: composer config repositories.data-migration-tool git https://github.com/magento/data-migration-tool composer require magento/data-...
1
vote
1answer
57 views

Error in Upgrade Magento CE version from 2.2.3 to 2.3.0 with composer?

I have tried using below command but getting errors when update Command 1: composer require magento/product-community-edition 2.3.0 --no-update Command 2: composer update Output: Your ...
1
vote
0answers
50 views

Directory / folder path?

I am Trying to upgrade from 2.3.0 -> 2.3.1 This issue began as I'm trying to add my logo to the top of emails and have been told the upgrade has a fix to the bug. i am used the luma theme. Error ...
1
vote
2answers
189 views

How to disable all optional modules in Magento 2.3?

I want to disable all third-party modules and Magento's optional modules, for example, DHL, Klarna, Temando, Vertex, etc. I disabled via admin panel and CLI There is a different way to exclude them?
1
vote
2answers
70 views

Stop composer replacing the .htacces file

When updating Magento 2 via Composer, the .htaccess file in the Magento root directory gets overwritten with the default repository version. Therefore losing my customisations, which I have to go in ...
1
vote
1answer
36 views

Mismatched Magento version while using composer

I currently have Magento running on Ubuntu Xampp, and attempted to run composer on a theme file, which prompted me to install a load of PHP extensions. I did this (7.2 for all of them, same as system ...
1
vote
0answers
65 views

Magento2 error while extension installation in create backup step

In my magento2 store I want to install the extension. I have tried this via composer as well as admin extension manager. Every time the process failed in Backup stage after generating the 4Gb of data ...
1
vote
0answers
14 views

How magento2 extension available in composer

We have planning to submit a magento2 extension into Magento marketplace. Currently extension hosted in GitHub private repository. After successful approval from "Magento marketplace" (Marketing ...
1
vote
0answers
116 views

Magento 2.3 Composer stuck while downloading https://repo.magento.com/packages.json

I have a problem since about 24 hours I guess. When I try to download Magento 2 with composer I stuck after logging with my user-credentials. The credentials are ok, it pass and go through the next ...
1
vote
0answers
115 views

Magento Server is at 100% CPU after installing Extension

I just installed a new Extension via Composer: $ composer require mageworx/module-advancedproductoptions This is the output: Using version ^2.16 for mageworx/module-advancedproductoptions ./...
1
vote
0answers
48 views

install magento on virtualbox from bitbucket

After I clone magento files from bitbucket, i try to run composer install but it gives me this error, "[RuntimeException] Failed to execute git clone --no-checkout "ssh://git@stash.studio.com:7 ...
1
vote
0answers
18 views

Validate composer requirements from modules in app/code

Is there a way to validate the version constraints from modules in app/code during updates?
1
vote
0answers
28 views

How can I add a 3rd party dependency in a custom module?

I'm building a module which requires a 3rd party library, how can I make the 3rd party library available to the module without without adding it to the composer.json magento root file? I added it ...
1
vote
0answers
47 views

Magento 2.1.9 to 2.2.0 composer update problem

Basically i want to update my store from 2.1.9 to 2.2.0. But when i run composer update i'm getting this error: - magento/product-community-edition 2.2.0 requires zendframework/zend-stdlib ^2.7.7 -&...
1
vote
2answers
1k views

Unsupported declare 'strict_types' in Magento 2.3.0

Error : Unsupported declare strict_types in ../vendor/magento/inventory-composer-installer while install the extension using composer in Magento 2.3.0.