The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
1
vote
1answer
18 views

Magento Update to 2.3.3 backend after login Specified invalid parent id Magento_Analytics

i have a problem while upgrading Magento from 2.3.2 to 2.3.3. The update works fine and i have all done which mentioned here: https://devdocs.magento.com/guides/v2.3/comp-mgr/cli/cli-upgrade.html ...
0
votes
1answer
28 views

Magento 2.3: InvalidAgumentException: Composer could not find the config file

I have a problem with Magento, I use X-debug for trying to debug Magento and I have the following Exception: Exception Has ocurred. InvalidArgumentException: Composer could not find the config ...
1
vote
2answers
1k views

Win 10, WAMP, Magento 2.x install using either method help

Is there a detail and current guide for a newbie to install Magento 2 in my test environment? I am good at following detail instructions. I have spent over 3 days downloading and reading html and you ...
0
votes
0answers
16 views

Magento 2.3.2 EE Composer Install Could Not Resolve

I am using Magento version 2.3.2 EE. I am trying to run the "composer install" step (I have not modified the composer.json file in any way) and I'm seeing the following error: $ composer install ...
2
votes
0answers
33 views

Magento 2: How to install custom module in app/code folder only using composer.json file?

I'm trying to install my custom module using composer.json file and after run composer update command my custom module installed successfully in magento2. Actually I want to install my custom module ...
2
votes
5answers
602 views

Magento 2 Install extension but not upgrade Magento via composer

So if I understand it right the php bin/magento setup:upgrade is used for both, upgrading magento 2 and also for installing extensions via composer. How can I just install the extension without ...
0
votes
1answer
139 views

The HOME or COMPOSER_HOME environment variable must be set for composer to run correctly Error

When I try to complete the checkout by paying with Hosted Payment Form (mastercard module) I get an error 400 Bad request. I was reading the exception.log file and I found an error that says the ...
0
votes
0answers
19 views

How to resolve this Composer Update problem?

Please have a look on the screen shot below and let me know: What's the concrete problem here (it is not clear to me)? How to sort it out? Is there any way to do this update ignoring these ...
0
votes
3answers
52 views

Magento 2 - Table not deleting while uninstalling custom module using module:uninstall command

I'm a newbie in magento 2 development. I'm creating magento 2 module and testing with composer. My test project is in github. https://github.com/hussain-badusha/magento-badusha-test In my module, i ...
0
votes
0answers
14 views

Own module in bitbucket - different branch for 2.2.x and 2.3.x. How to install with composer?

i have own module in bitbucket (written at the time when was magento 2.2.x) which is overwriting magento-catalog ImageBuilder.php file. Now after testing this with 2.3.x i found, that it isnt working....
1
vote
1answer
48 views

How to Upgrade Magento 2.1.5 to latest version using via composer

I have installed my previous Magento 2.1.5 years ago by downloading , Now I want to upgrade to 2.3.2 using the composer. Can I directly do that. What issues may occur ?
1
vote
1answer
811 views

Magento 2 .gitignore template in combination with Deploybot and Git workflow

I installed Magento 2 using composer locally (on my local Dev environment using MAMP). I added my custom theme and did all my frontend work on my local Dev site. I want my code and changes to be ...
2
votes
6answers
2k views

Magento 2.1.9 upgrade to 2.2.0 - Error on setup:upgrade with Magento_Sales table

Upgrading magento from 2.1.9 to 2.2.0 and during the automatic bin/magento setup:upgrade process it runs all upgrades fine until it reaches the magento_sales table where it produces this error. There ...
1
vote
2answers
86 views

Composer Based Modules and PSR4 Autoloaders

Is it safe to assume that any composer based module package will have a PSR 4 autoloader section whose prefix is the full module name? i.e. "autoload": { "psr-4": { "Foo\\Bar\\": "src/" ...
0
votes
4answers
35 views

Magento2 : How To Solve Out Of Memory Limit Error While Using Composer Update Command [duplicate]

i got out of memory error while run "composer update" command, i already check memory_limit and that is 2048 M than also i am getting above error . does anyone know how can i solve this problem ?
3
votes
2answers
2k views

Upgrade Magento from 2.2.6 to 2.3

I am trying to update Magento from version 2.2.6 to 2.3, but i get this errors: sh-4.2# composer require magento/product-community-edition 2.3.0 --no-update ./composer.json has been updated sh-4.2# ...
0
votes
0answers
19 views

Magento 2 Composer is not working for installing third party module on local server

I have a setup of Magento2.3.2 version and I need installation of some third party module with composer but when I try to install the module it throws below error. Installation failed, reverting ./...
2
votes
5answers
4k views

Magento Installation Error - Magento 2

I have uploaded Magento2 source code on centos Rackspace server, and I have changed credentials whenever required, but when I run my website, I get an error like "Vendor autoload is not found. Please ...
1
vote
3answers
837 views

Outdated Amazon_core after composer update (Magento 2.2.4)

I am getting this error: Amazon_Core db schema version: defined in codebase - 2.0.12, currently installed - 2.0.4 and Amazon_Core db data version: defined in codebase - 2.0.12, currently installed -...
1
vote
1answer
57 views

Error in Upgrade Magento CE version from 2.2.3 to 2.3.0 with composer?

I have tried using below command but getting errors when update Command 1: composer require magento/product-community-edition 2.3.0 --no-update Command 2: composer update Output: Your ...
0
votes
3answers
41 views

Magento2.3 install extention via composer but in app/code

I have an extension which was installed in app/code and override from app/code, now I have only the zip for the composer installation, is it a way to install this extension by composer but in app/code/...
1
vote
1answer
21 views

Installing Magento 2 extension via composer.json file

I bought an extension on Magento store.On my magento installation, I don't have web setup wizard and when I checked the solution for this it requires to change main config file which I don't have ...
0
votes
3answers
54 views

Magento 2.3 & composer : update extension

I would like to update my extension (I updated magento 2.2.6 to 2.3.1 from composer but looks like the extension also need to be updated because it's not working and it should be compatible). Then i ...
4
votes
2answers
2k views

Magento 2: usage of composer.json file?

I would like to know that why we create compose.json and What is it use. Can someone briefly explain that to me? company --module composer.json
0
votes
1answer
31 views

Magento 2 root composer.json file content?

What should the content be in the Magento 2 root folder composer.json file AFTER Magento is installed? When I add a new module, should I add this to the existing list (require, etc)? Should all the ...
0
votes
1answer
18 views

Magento update version

I'm currently running a Magento store version 2.3.0 and trying to upgrade it to version 2.3.2. If I try to update on the Magento admin I receive the message bad credentials after entering the access ...
1
vote
2answers
1k views

Unsupported declare 'strict_types' in Magento 2.3.0

Error : Unsupported declare strict_types in ../vendor/magento/inventory-composer-installer while install the extension using composer in Magento 2.3.0.
0
votes
0answers
36 views

Invalid credentials for magento/module-store

After creating my auth.json file and adding the credentials: { "http-basic": { "repo.magento.com": { "username": "publickey", "password": "privatekey" } } } and doing a ...
5
votes
1answer
3k views

Magento 2.2.0 - Upgrade / Migrate from Magento 2.1.9 to Magento 2.2.0 with Sample Data

Followed below commands to upgrade Magento 2.1.9 to 2.2.0 using terminal 1. composer require magento/product-community-edition 2.2.0 --no-update 2. composer require \ magento/module-bundle-...
3
votes
1answer
275 views

How to make and install my module via composer with two private repositories in magento 2

Problem Description: I have created two private repositories in github under same user name. Each repository contains different modules. But while trying to install the package via composer throws ...
0
votes
1answer
13 views

Installing Zend_Barcode

I'm not having any luck getting Zend_Barcode to work in Magento 2. Zend_PDF is working, and I notice that it has a class in: /vendor/zendframework1/library/Zend/ but Zend_Barcode does not. I've ...
1
vote
2answers
194 views

Im trying to install Magento via composer can't insert password

composer create-project --repository-url=https://repo.magento.com/ magento/project-enterprise-edition Authentication required (repo.magento.com): Username: d89125c*********************** ...
1
vote
1answer
644 views

Upgrade Magento 2 via composer not working

I try to upgrade Magento 2.1.6 to Magento 2.1.9. To do this I ran this command: composer require magento/product-community-edition 2.1.9 --no-update after this I ran : composer update and I ...
1
vote
1answer
50 views

Magento2: How to add dependency in composer for private Gitlab modules?

I'm installing a custom module in M2 using composer from my private Gitlab repo and it is working fine. After I've added the dependency of other modules(using composer require) in my custom module ...
0
votes
1answer
55 views

Magento 2: Problem updating Magneto v2.2.1 to v2.3.2

i want to update my Magento to v2.3.2, when i run composer update, i get this error: Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request ...
0
votes
2answers
2k views

Magento 2: Cannot load my library using composer

Sorry for the lengthy message. I just wanted to provide as much information as possible. I am writing a new module. I have a custom library that I need to load to use in my module. I have the ...
20
votes
1answer
8k views

How to install a specific Magento 2 version with Composer?

I want to install Magento version 2.1.7 with the Composer, I found in the docs that I can use in the require: "magento/product-community-edition": "2.1.7", but composer says that requested package ...
1
vote
1answer
34 views

Autoload error: Vendor autoload is not found. Please run 'composer install' under application root directory in Magento 2

I cloned one gitlab project into the local system in windows. When I am running the project it shows the error like this. Vendor autoload is not found. Please run 'composer install' under the ...
2
votes
1answer
2k views

Error failed opening

Can someone tell me what I have to do to fix it ? local:/data/web/public/app/code/community:/data/web/public/app/code/core:/data/web/public/lib:.:/usr/share/php:/usr/share/pear') in /data/web/public/...
0
votes
2answers
98 views

Upgrade Magento vendor module(dependency|library) to a newer version

Magento uses multiple "external" dependencies|libraries for example one of them is dotmailer-magento2-extension. This specific module is at version 3.1.1 as it can be seen here vendor/dotmailer/...
2
votes
1answer
607 views

Magento 2 deployment from Dev to Staging using Git

I have a local Dev environment and installed Magento 2 using composer I initialized the local /magneto2/ folder as a Git repo I added this .gitignore file to the root of my /magneto2/ folder I have a ...
0
votes
1answer
654 views

Why wont my extension update using composer?

I am trying to update Amasty Layered Navigation. Following their documentation it says to type in the command- composer update amasty/shopby When I do that it says Package "amasty/shopby" listed ...
2
votes
2answers
270 views

Is it safe to have composer in production?

Is it safe/ok to have composer in production on a server hosting Magento?
0
votes
2answers
342 views

Plugin class Magento\NewRelicReporting\Plugin\StatePlugin doesn't exist

I just update my Magento 2.2 core components using the command composer update -vvvv and then I got a lot of updates which caused this issue below when I tried to run php bin/magento setup:upgrade. ...
0
votes
0answers
24 views

Composer Error When try to Update or Upgrade Magento 2.2

I have in my system installed Centos 7 and php-fpm with some version of PHP 7, when I try to use composer update I get this message I would like to know how to fix that problem
0
votes
3answers
45 views

How to deploy to production server customizations made in vendor folder?

So, We have 3 environments: development, staging and production. .gitignore file includes "vendor" folder and it has been working fine for us fine. Once We pull changes in Staging We would just run: ...
4
votes
5answers
7k views

Why I'm having errors after install an update from 2.1.0 to 2.1.2 with composer?

Errors after installing update from 2.1.0 to 2.1.2 PHP Warning: require(/var/www/vendor/composer/../../app/etc/NonComposerComponentRegistration.php): failed to open stream: No such file or ...
6
votes
1answer
970 views

Error during upgrade to Magento 2.1 from 2.0.7

Since a couple of days i try to upgrade my "native" Magento 2.0.7 I use composer as suggested by documentation : composer require magento/product-community-edition 2.1.0 --no-update; composer update; ...
0
votes
1answer
762 views

How to use a library using composer in a Magento 2 module

At the moment I'm developing a module for Magento 2. I'm using a third party library ("twizo/lib-api-php") and installed it using composer. When I use a class from this library, Magento gives me the ...
0
votes
1answer
61 views

Product page fails to render

When you click on a product page, it only shows a one image. Looking at the stack trace, it looks like there is some PHP error. I think when I patched to 2.3.2, maybe something didn't updated? How ...