Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
0
votes
1answer
511 views

Updating from 2.1.3 to 2.1.4 on magento

Magento: I am trying to update the magento via Web setup and its giving me error Check Component Dependency We found conflicting component dependencies. Hide detail Command "update" failed: Loading ...
0
votes
1answer
3k views

Could not find package * at any version for your minimum-stability (stable). Check the package spelling or your min imum-stability

Kindly help me on this error I get when I run this command: The extension's composer.json: { "name": "veriteworks/m2-price", "type": "magento2-module", "license": [ "OSL-3.0", "AFL-3.0" ], "...
0
votes
1answer
157 views

Rename(/usr/lib64/plesk-9.0/composer.phar): failed to open stream: Permission denied

I tried to run the composer self-update method and I'm getting this error message and I'm not sure where to start to fix this issue: rename(/usr/lib64/plesk-9.0/composer.phar): failed to open stream: ...
0
votes
1answer
305 views

magento 2 third party module installation through composer

I'm developing and trying to install a module through composer in Magento. My module's composer.json looks like this { "name": "amit/test", "description": "N/A", "require": { "php": "~5.6.0|...
0
votes
1answer
696 views

Error while trying to upgrade magento through composer

I am trying to update magento/product-community-edition 2.0.5 to version 2.1.0. To do that I replaced version in composer.json and tried to run composer update -vvv. Unfortunately, script is failing ...
0
votes
1answer
98 views

Magento 2 - Create a composer module with .less files in it

I'm trying to figure out how I can package a module with some .less files in it through composer. For example, let's say You wrote a module which has few frontend parts, of course this parts needs ...
0
votes
1answer
52 views

Installing Magento 2.0 with Composer

I have generated a private key on my Magento account. But composer will only let me enter the username (public key) and won't allow me enter the password (private key). Why is this?
0
votes
1answer
16 views

Magento 2 upgrade killed process

I want to upgrade Magento 2.1.7 to Magento 2.3.2 and I follow below commands sudo composer require magento/product-community-edition=2.3.2 --no-update sudo composer require --dev phpunit/phpunit:~6.2....
0
votes
0answers
8 views

composer installed.json emptying

My installed.json randomly gets empty what causes composer errors at magento page, It happens randomly, mostly after php bin/magento setup:upgrade command. The only solution I can fix it is composer ...
0
votes
0answers
17 views

I can not install anything via Setup Wizard

I'm using magento 2.2.6. I used to have an error on the ComponentDependencies in the readiness check. I passed that error, by removing the: "require-dev": { "phpunit/phpunit": "~6.2.0", ...
0
votes
1answer
20 views

setting up local environment from private git

I started a new project and am pretty new to Magento 2. The person gave me access to there personal git repo with there magento that they use fro production. They also gave a dump of the database. ...
0
votes
1answer
32 views

Errors Installing Data Migration 2.2.0 Tool with Composer

Running the different commands below and getting errors with each of them. How do I get the data migration tool to install? I also pasted in our composer.json file below. First Attempt This one ...
0
votes
0answers
65 views

The HOME or COMPOSER_HOME environment variable must be set for composer to run correctly Error

When I try to complete the checkout by paying with Hosted Payment Form (mastercard module) I get an error 400 Bad request. I was reading the exception.log file and I found an error that says the ...
0
votes
0answers
14 views

Magento2 symfony/finder not found and unable to update

I have a plugin I am trying to install and when I run the composer install on the command line I get a error that says Updating symfony/finder (v3.4.22 => v3.4.28): Update failed (Could ...
0
votes
0answers
26 views

How to fix “There are no commands define in the namespace” error?

I have upgraded the Magento version from 2.2.6 to 2.3.0 via composer. I have tried running the command php bin/magento setup:upgrade but it says the below error There are no commands defined in the ...
0
votes
1answer
79 views

Magento 2.3.1 Composer Fatal error when installing Ext

Trying to install anything on Magento 2.3.0 & 2.3.1 using Composer I get the following error. Does anyone know how to fix this? Fatal error: Uncaught TypeError: Return value of Magento\...
0
votes
0answers
79 views

Magento 2.3.1 Composer Fatal error installing anything

After thing to install a few other extensions, I'm getting the Fatal error message with anything when using Composer. I have installed a fresh copy of Magento 2.3.1 and I'm trying to install the data ...
0
votes
0answers
40 views

Fatal error: Uncaught Error: Class 'Cm_Cache_Backend_File' not found

Going through an upgrade from 2.2.6 to 2.3.1 and i have this populating on the frontend. Additionally, on command line if i try to run an upgrade or pretty much anything even php bin/magento list i ...
0
votes
0answers
16 views

Magento 2 Install Composer and Setup Upgrade in 1 step: how do we get the package name?

I am reading through the Magento guide and understand the steps. However it appears to me that many -if not all - of the steps are the same everytime. https://devdocs.magento.com/guides/v2.3/comp-mgr/...
0
votes
1answer
270 views

Magento 2.3 Upgrade issue

I'm trying to upgrade to Magento 2.3.1 and I'm running into a problem. I was on PHP 7.1.3 and noticed in the system requirements that it requires 7.1.3 and 7.2.X. We've upgraded the server PHP version ...
0
votes
0answers
14 views

Changing from Magento2 github install to composer install

We have installed Magento2 using GitHub but later we realized that we should be installing it with the composer from Magento. Will it be an issue if we switch it to the composer as we have done a lot ...
0
votes
1answer
62 views

Download failed, retrying… Downloading https://repo.magento.com/archives/magento/magento2-base/magento-magento2-base-2.3.0.0.zip

I need to say, its really hard and sadly magento typically that nothing works out of the box as it should if you follow offical step-by-step tutorials. Since a few hours or better days I try to ...
0
votes
0answers
29 views

Difference between Magento Composer install and release install

What are the differences between the various Magento installs? I installed it using the released code from github(v2.3.0.zip) and I installed it using composer create-project --repository=https://...
0
votes
0answers
25 views

Convert from Cloud Enterprise to Enterprise issue

I passed my site from cloud to another server (with same files and some fixes on removing fastly) the site was up and no issues . It was magento/magento-cloud-metapackage v 2.2.6 . Now i want to ...
0
votes
1answer
125 views

Magento 2.2.7: how to run composer update command under Ampps/Xampp php version instead to base php

I am using LAMP on which I have PHP 7.2 I install Ampps on which I have PHP 7.1 How I have to run composer update command? If I run it gave me PHP version error (definitely it will give 2.2.7 don't ...
0
votes
0answers
9 views

WordPress with composer alongside M2

I would like to add a WordPress blog to our magento2 site. WordPress is not officially available as a composer package. I can create my own package - that's not an issue. How would I go about ...
0
votes
0answers
20 views

Wrong version in composer outdated

When I run composer outdated I receive the information below: Why does it not show that 2.3.x is available? Is it because I started the project with Magento 2.1.x? Even when I moved to 2.2.x, it was ...
0
votes
0answers
31 views

How to load vendor files in custom extension

Im making a custom extension - how do I load custom vendor files ? Do I add them to my extension composer file or the global Magento one ? I asking because I cant load Yaml. In my extension ...
0
votes
0answers
137 views

Magento 2 - Install Mirasvit Profiler (Missing symfony/yaml)

I am running Magento 2.2.6 and it's a slow instance so I wanted to try out the Mirasvit profiler. However, when I try to enable it, I get an error about yaml not being installed. I dug through the ...
0
votes
1answer
165 views

Copy files from /vendor/* to another server? Mailchimp installation without composer

My shared hosting doesn't allow me to use composer install (php memory limit error). So I had to install to my clone magento2 on xampp server. http://wiki.ebizmarts.com/installation-guide-m4m2 below ...
0
votes
1answer
243 views

Plugin class Magento\NewRelicReporting\Plugin\StatePlugin doesn't exist

I just update my Magento 2.2 core components using the command composer update -vvvv and then I got a lot of updates which caused this issue below when I tried to run php bin/magento setup:upgrade. ...
0
votes
1answer
31 views

How to enable my bugfix extension to run in a specific Magento 2 version?

I'm creating a module in order to fix a bug in Magento 2.3.0 that will be part of the next release. So, I would like to restrict via Composer the dependencies of that module. How can I restrict my ...
0
votes
1answer
174 views

How to fix error in Web Setup Wizard - Command “show” failed: [Composer\Downloader\TransportException]

This is the error when I click on Extension Manager: Command "show" failed: [Composer\Downloader\TransportException] The 'https://repo.wyomind.com/packages.json' URL required authentication. You must ...
0
votes
1answer
905 views

Migrate Magento 1.9.2.1 to Magento 2.3.0

I want to migrate Magento 1.9.2.1 to Magento 2.3 (Without Sample Data). But, when I execute composer update command. It's return some errors. The "magento/inventory-composer-installer" plugin was ...
0
votes
1answer
45 views

Magento 2 load component composer dependencies

I am trying to develop simple Magento 2 module. Accoding to Composer integration guide I had to put all my dependencies into composer.json file into my module root. According to Default File Structure ...
0
votes
1answer
52 views

unable to composer update while installing Magento

magento/product-community-edition 2.2.3 requires ext-dom * -> the requested PHP extension dom is missing from your system. - magento/product-community-edition 2.2.3 requires ext-dom * -> the ...
0
votes
1answer
52 views

Magento 2 install package with composer without SSL

I am trying to install a package composer config repositories.swissup composer http://swissup.github.io/packages/ Which result in this error Your configuration does not allow connections to http:...
0
votes
0answers
18 views

Create Composer mapping files

I would like to automatically generate the mapping of my module files to the composer.json file. Is there an executable? "extra": { "map": [ ... ] }
0
votes
1answer
173 views

Elasticsearch Error - call_user_func_array() expects parameter 1 to be a valid callback

I have an M2 with Elasticsearch installed, with the Smile/Elasticsuite module. These are my versions in composer.json: "smile/elasticsuite": "2.5.15", "elasticsearch/elasticsearch": "^2.2.3" And ...
0
votes
0answers
273 views

Magento 2: Invalid credentials for … aborting

I was trying to use composer install with my project, and this message show up, please help. Thanks :) Or please tell me how to ignore a package in composer install, i've try composer remove magento/...
0
votes
1answer
123 views

Customer_Eav db schema version is not properly set

I am using Magento 2.2.5 and getting this error. 1 exception(s): Exception #0 (Magento\Framework\Exception\LocalizedException): Please update your modules: Run "composer install" from the Magento ...
0
votes
0answers
82 views

Magento 2 - Web Upgrade Fails on Component Dependency Checks

I have a Magento 2 site on version 2.1.8 and I am attempting to upgrade to 2.2.5 with the Web Setup Wizard. When I run the readiness check, it fails on Component Dependency. My composer.json file ...
0
votes
0answers
122 views

Magento 2: error 500 and issue with a Composer

I have an error 500 "site is currently unable to handle this request"., and this is what logs are writing: [Wed Jul 25 07:21:16.343013 2018] [php7:warn] [pid 396] [client 176.125.35.8:44830] PHP ...
0
votes
0answers
92 views

Magento 2 : Installing magento 2 code standards with code sniffer in ubuntu

Can anybody please tell me how do i install Magento 2 code standards in Ubuntu form scratch? I am trying to install Composer and Code sniffer 3.0 but getting alot of errors.
0
votes
1answer
111 views

Magento 2.1.3 to 2.2.5 Upgrade Checksum verification of the file failed

I stumbled into this problem while upgrading Magento 2.1.3 to 2.2.5 via composer update. Any ideas?
0
votes
1answer
42 views

Magento 2 Hardware Requirement confusion and Upgrading on Live server confusion

I have worked with Magento1 and Magento2 both. But All of my Magento2 projects are hosted under dedicated server and the permission of Upgrading and Building using composer is given by the client. So ...
0
votes
3answers
773 views

Outdated Amazon_core after composer update (Magento 2.2.4)

I am getting this error: Amazon_Core db schema version: defined in codebase - 2.0.12, currently installed - 2.0.4 and Amazon_Core db data version: defined in codebase - 2.0.12, currently installed -...
0
votes
1answer
339 views

Check Component Dependency, no obvious error

I am creating a test environment for magento, hoping that I can replicate later for some work on it, and have come up an issue on Check Component Dependency. the base config is as followed: Specs ...
0
votes
2answers
309 views

Magento 2 data migration RuntimeException

I am learning how to convert Magento 1.x to Magento 2.x I installed fresh Magento ver. 1.9.3.8 from GitHub mirror and fresh Magento 2.2.3 using composer maddy@maddy:/var/www/html/magento-composer$ ...
0
votes
2answers
1k views

I installed mageplaza smtp extension on m2 EE 2.2.3 (via composer)

I followed the directions here and installed via composer. https://github.com/mageplaza/magento-2-smtp Install via composer (recommend) Run the following command in Magento 2 root folder: composer ...