Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
0
votes
1answer
298 views

why is Magento 2 semantic versioning at 100?

I am using Composer to install Magento 2 and I've noticed that all packages are starting with 100. According to semantic versioning rules, Magento 2 packages should be at version 2.x.x something. ...
0
votes
1answer
2k views

Magento 2: Adding Sample Data to an Already Installed System

Is it possible to add the sample data to an already running Magento 2 system? Or is this only possible at install time? If I run php bin/magento sampledata:deploy This will add the sample data ...
0
votes
2answers
3k views

Magento2 Installation: Composer PHP version errors on Windows

I tried to install Magento2 on Windows which runs PHP 5.5.19 and MySQL 5.6.X versions (from xampp package) through Composer, but I received the following errors after running composer install (please ...
0
votes
3answers
839 views

Elasticsearch setup:upgrade error: No handler for type [text] declared on field [search]

I am trying to install smile/elasticsuite using composer but I am getting a really strange error. To install the module I used: composer require smile/elasticsuite:2.6.0 And got successful ...
0
votes
1answer
338 views

Upgrade magento2 to latest version via composer

I installed Magento2 via composer, following this guide. Now I see version 2.1.6 is available and I'd like to upgrade. Please confirm if these commands will do the trick or what I'm missing in case ...
0
votes
1answer
153 views

Im trying to install Magento via composer can't insert password

composer create-project --repository-url=https://repo.magento.com/ magento/project-enterprise-edition Authentication required (repo.magento.com): Username: d89125c*********************** ...
0
votes
1answer
681 views

Magento 2: Composer Update is Not Working [Failed to open stream: Connection timed out]

I'm trying to update composer but it gives below error. root@magento-2:/var/www/html/magento# composer clear-cache root@magento-2:/var/www/html/magento# composer diagnose Do not run Composer as root/...
0
votes
2answers
2k views

Magento 2 Autoload error after moving site on live domain

I set up my site on my test server and after moving it to my live domain, its giving me Autoload error Vendor autoload is not found. Please run 'composer install' under application root directory. ...
0
votes
1answer
428 views

Magento 2 setup comporser error?

Today I create newsite magento2 MAGETWO-40129: M2 GitHub Update (version 1.0.0-beta. When i install composer get ZipArchive::extractTo(): Full extraction path exceed MAXPATHLEN (260) how do fix it. ...
0
votes
1answer
3k views

Install Magento 2 with MAMP [closed]

I have MAMP & MAMP PRO. I tried to install Magento 2 beta. When i write "composer install" the system returns me this error: Your requirements could not be resolved to an installable set of ...
0
votes
1answer
390 views

how to upgrade from magento 2.3.0 to 2.3.1 steps (composer) [duplicate]

I want to upgrade my magento to the latest version. what are the steps to upgrade from Magento 2.3.0 to Magento 2.3.1 via composer?
0
votes
1answer
68 views

Magento 2.1.7 to 2.1.15 upgrade issue

I have upgraded my magento version 2.1.7 to 2.1.15. The upgrade process working fine. But the issue is my home page contents are not loading. It loada product detail page content in the home page. ...
0
votes
1answer
45 views

What is the Composer.Json file and what is it used for?

I would like to know what the composer.json file is actually used for when I create a new module. I know it's an optional file that can be created when I create a new module so why include it? ...
0
votes
1answer
86 views

Magento2 composer update throws exception

When I am running composer update I am faced with the error like: $ ./composer update X-Powered-By: PHP/7.0.31 Content-type: text/html; charset=UTF-8 Warning: Composer should be invoked via the CLI ...
0
votes
4answers
341 views

How to update safely Magento 2.0.4 to Magento 2.2.2?

I want to update from Magento 2.0.4 to latest version. I want to know commands, and which folders are going to modify in the update process. all I want command line based update process. Note: I ...
0
votes
1answer
357 views

Magento 2 Module Install With Composer going to Vendor Folder,How to install on Server

I have installed third party module with composer and we are managing code with Git.Since Module is installed with composer so it is going to Magento Vendor Folder.In git we are ignoring Vendor Folder....
0
votes
1answer
2k views

Autoload Error: Module has been already defined

This error shows up when I do the following: DL and paste this extension under DIR>vendor>magento-japan folder m2-jplocalize Run the following command: composer config repositories....
0
votes
1answer
197 views

Error when upgrading from CE 2.1.2 to 2.1.4 via Composer

Composer version is 1.4.1 I ran composer require magento/project-community-edition 2.1.4 --no-update and then composer update Error message returned: Your requirements could not be resolved to an ...
0
votes
2answers
1k views

How to add one file with classes third party library in to Magento 2?

I have a single PHP file with some classes as a library. For example: <?php class addShipment { public $packages; // przesylkaType public $id; // int } class addShipmentResponse { ...
0
votes
1answer
4k views

Your requirements could not be resolved to an installable set of packages

I tried to install magestead using the command composer global require "richdynamix/magestead" and got the following output: PHP Warning: Module 'Phar' already loaded in Unknown on line 0 Changed ...
0
votes
2answers
365 views

Magento2 composer module:uninstall: Does it make sense and why does it take so long?

We want to streamline a magento installation managed via composer. So, for example we have no need for Magento_SendFriend module, nor Magento_Review, and maybe other not essential / small modules. ...
0
votes
2answers
332 views

Magento2: Composer installation error

I'm trying to install composer on my Ubuntu 12.04 LTS machine, for Magento2 installation but the following error occurs: Some settings on your machine make Composer unable to work properly. Make sure ...
0
votes
1answer
37 views

Magento 2 - Upgrade Path

I just wanted to find out if the there is a upgrade path to follow when upgrading a Magento 2 store via composer? Example: if I want to upgrade my magento 2 store from v2.0.18 open source to v2.3.1 ...
0
votes
1answer
35 views

Upgrade Magento vendor module(dependency|library) to a newer version

Magento uses multiple "external" dependencies|libraries for example one of them is dotmailer-magento2-extension. This specific module is at version 3.1.1 as it can be seen here vendor/dotmailer/...
0
votes
2answers
41 views

extension not remove via composer

i have disable extension after i can remove extension via composer like this way php bin/magento module:disable <ExtensionProvider_ExtensionName> --clear-static-content php bin/magento setup:...
0
votes
2answers
136 views

M2 - Uninstall language pack

I installed a language pack using composer. $ composer require mageplaza/magento-2-german-language-pack:dev-master $ php bin/magento cache:flush Now when I try to uninstall again, using this command:...
0
votes
1answer
43 views

including dependency in magento

I was trying to publish one extension to magento marketplace Things are a fork of tinypng and I can see the dependency of tinypng module is automatically pulled by composer, but where they are ...
0
votes
1answer
462 views

Magento 2.2.4 Composer Patch Failed: “1 out of 1 hunk ignored”

Applying patch to v2.2.4 for Github issue 14968, but I keep getting hunk fails error. After looking Looking here: SUPEE-9767 - Hunk #1 FAILED at 225. 1 out of 1 hunk FAILED I believe the problem is ...
0
votes
1answer
79 views

M2: Impossible install language pack

I'm trying install Czech language pack via composer from mageplaza: https://www.mageplaza.com/magento-2-czech-language-pack.html When I run then get issue: Problem 1 - Installation request for ...
0
votes
1answer
62 views

Instructions to update extension in Magento 1.9

I'm relatively new to Magento and am currently using version 1.9.3.9. Out payment system providers (Adyen) have recently provided a new version of their extension with better security (on gitlab this ...
0
votes
2answers
314 views

magento 2.2.6 install via composer

I can't Install Magento 2.2.6 via composer on macOS High Sierra + I'm use MAMP Pro and getting some problems : Your requirements could not be resolved to an installable set of packages. ...
0
votes
2answers
208 views

Magento2 composer update issue

I have installed one module with composer and that module stored in vendor folder. Now i do not need that module, I have deleted from it and run the commnad "composer update" Still i can see the ...
0
votes
2answers
43 views

Magento 2 version(s) in composer

We are getting ready to upgrade from v2.2.2 to v2.2.4. Due to our deployment process, I need to push the composer.json so it can be upgraded properly via the git rather than doing it in the backend. ...
0
votes
1answer
116 views

Magento2 How to create custom module which will be install in Vendor folder using composer

I have created an extension now I want to install this using composer command in the vendor folder.
0
votes
4answers
2k views

Magento 2 : Composer runs out of memory

I am trying to install instamojo payment gateway to my magento2 store, as per the instructions givne by instamojo page https://docs.instamojo.com/page/instamojo-integeration-for-magento-2 i tried the ...
0
votes
1answer
365 views

error after “composer update”

First time I installed a module via ssh, and I accidentally make "composer update". Now my site has this error: 1 exception(s): Exception #0 (Magento\Framework\Exception\LocalizedException): Please ...
0
votes
2answers
239 views

Magento composer The system cannot find the path specified. (code: 3)

I am executing composer install but getting below error # composer install Loading composer repositories with package information The following exception may be caused by a stale entry in your cmd....
0
votes
3answers
443 views

Install Magento 2.2.3 with composer throws

I am trying install a clean version of Magento 2.2.3 using composer: composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition This error is thrown: ...
0
votes
1answer
821 views

GDPR Module Installion "Can only install one of: magento/framework[101.01.1, 100.0.02]

I am trying ton install the following GDPR module via command line for Magento version 2.2.1 : https://github.com/AdfabConnect/magento2gdpr However, the install fails and produces the below error ...
0
votes
2answers
83 views

MEQP tools run comments Issues

Im trying to run MEQP in magento 1.9.x version , but whenever I run php vendor/bin/phpcs D:\xampp\htdocs\projectname --standard=MEQP1 from the command line I get this output: dir=$(d=${0%[/\\]*}; cd "...
0
votes
1answer
46 views

How to copy phpunit test xml file of a module under dev/tests/unit/ with composer installation in Magento 2?

I wrote a module including phpunit test xml file. I want to automatically copy that xml file under dev/tests/unit/ after composer update. The composer.json of the module looks like { "name": "...
0
votes
1answer
128 views

What will happen if we install magento 2 from github and later used composer to update

Recently i am working on a Magento 2 website which was installed from github , when i started to work on that project i used composer as when while installing on my local machine it asks me to run "...
0
votes
1answer
120 views

Magento 2 : how to LIbrary import using composer

How can we library import without composer update give any solution.
0
votes
1answer
401 views

Upgrade Magento from 2.1.10 to 2.2.2

I just recently upgraded Magento from 2.1.10 to 2.2.2. Which brought up quite a few problems with most of the resolved now. Most were fixed by updating Grunt again which I thought I already did right ...
0
votes
1answer
58 views

Error: “URL required authentication”

I'm trying to move to Magento 2 finally. And was trying to install a module from GitHub via composer. I tried it on my localhost first and everything worked perfectly, I executed: php ./vendor/...
0
votes
1answer
400 views

PHP Warning after upgrade from Magento 2.1.9 to 2.1.10

I'm having some issues with an installation of Magento 2 that I'm upgrading from 2.1.9 to the 2.1.10 security update. I'm following the cli-upgrade instructions. I'm running all commands as root. I ...
0
votes
1answer
260 views

How to create composer.json file needed in order to post a module on Magento Connect (Magento Marketplace)?

I am a Magento developer, and I have to publish an extension module to marketplace. I created an account and I am a status of "partner", so on this page: https://developer.magento.com/customer/account/...
0
votes
1answer
68 views

Magento upgrade CLI problem

I want to upgrade to Magento 2.1.9. Entered command: composer require magento/product-commu**m**ity-edition 2.1.9 --no-update After command "composer update" I've got error message: Problem 1 - ...
0
votes
1answer
1k views

PHP Version Check Magento 2

I am trying to update my Magento 2 to the latest version, my system fails the readiness check with the below message: PHP Version Check Your PHP version is . The required PHP version is . Hide ...
0
votes
1answer
51 views

How do Magento2 Integration and Functional Test relate to composer vendor folder?

I want to write a full test suite for my new module. Unit tests are no problem as they can be tested in isolation, and therefore can be in a tests folder within the package. However Integration and ...