Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
1
vote
0answers
50 views

Directory / folder path?

I am Trying to upgrade from 2.3.0 -> 2.3.1 This issue began as I'm trying to add my logo to the top of emails and have been told the upgrade has a fix to the bug. i am used the luma theme. Error ...
1
vote
2answers
182 views

How to disable all optional modules in Magento 2.3?

I want to disable all third-party modules and Magento's optional modules, for example, DHL, Klarna, Temando, Vertex, etc. I disabled via admin panel and CLI There is a different way to exclude them?
1
vote
2answers
70 views

Stop composer replacing the .htacces file

When updating Magento 2 via Composer, the .htaccess file in the Magento root directory gets overwritten with the default repository version. Therefore losing my customisations, which I have to go in ...
1
vote
1answer
36 views

Mismatched Magento version while using composer

I currently have Magento running on Ubuntu Xampp, and attempted to run composer on a theme file, which prompted me to install a load of PHP extensions. I did this (7.2 for all of them, same as system ...
1
vote
0answers
63 views

Magento2 error while extension installation in create backup step

In my magento2 store I want to install the extension. I have tried this via composer as well as admin extension manager. Every time the process failed in Backup stage after generating the 4Gb of data ...
1
vote
0answers
14 views

How magento2 extension available in composer

We have planning to submit a magento2 extension into Magento marketplace. Currently extension hosted in GitHub private repository. After successful approval from "Magento marketplace" (Marketing ...
1
vote
0answers
116 views

Magento 2.3 Composer stuck while downloading https://repo.magento.com/packages.json

I have a problem since about 24 hours I guess. When I try to download Magento 2 with composer I stuck after logging with my user-credentials. The credentials are ok, it pass and go through the next ...
1
vote
0answers
114 views

Magento Server is at 100% CPU after installing Extension

I just installed a new Extension via Composer: $ composer require mageworx/module-advancedproductoptions This is the output: Using version ^2.16 for mageworx/module-advancedproductoptions ./...
1
vote
0answers
48 views

install magento on virtualbox from bitbucket

After I clone magento files from bitbucket, i try to run composer install but it gives me this error, "[RuntimeException] Failed to execute git clone --no-checkout "ssh://git@stash.studio.com:7 ...
1
vote
0answers
18 views

Validate composer requirements from modules in app/code

Is there a way to validate the version constraints from modules in app/code during updates?
1
vote
0answers
28 views

How can I add a 3rd party dependency in a custom module?

I'm building a module which requires a 3rd party library, how can I make the 3rd party library available to the module without without adding it to the composer.json magento root file? I added it ...
1
vote
0answers
47 views

Magento 2.1.9 to 2.2.0 composer update problem

Basically i want to update my store from 2.1.9 to 2.2.0. But when i run composer update i'm getting this error: - magento/product-community-edition 2.2.0 requires zendframework/zend-stdlib ^2.7.7 -&...
1
vote
1answer
198 views

Copy files from /vendor/* to another server? Mailchimp installation without composer

My shared hosting doesn't allow me to use composer install (php memory limit error). So I had to install to my clone magento2 on xampp server. http://wiki.ebizmarts.com/installation-guide-m4m2 below ...
1
vote
2answers
1k views

Unsupported declare 'strict_types' in Magento 2.3.0

Error : Unsupported declare strict_types in ../vendor/magento/inventory-composer-installer while install the extension using composer in Magento 2.3.0.
1
vote
0answers
687 views

Composer Problem. Could not find a matching version of package <name>. Check the package spelling, your versi

I have big problem ;/ And dnt know how i make this... i write composer require searchanise/search-autocomplete and Could not find a matching version of package searchanise/search-autocomplete....
1
vote
0answers
23 views

Source Key should be specified

We are in the process of moving our Magento site to a new hosting platform. After moving all of the files and making some changes to the template XML, the frontend of the site is now working as ...
1
vote
0answers
70 views

Source class for generation not found

I am using a composer library in my custom module. The link for the library is here. This library in turn uses https://github.com/tightenco/collect The {Vendor}/{Module}/composer.json is { "name":...
1
vote
3answers
226 views

n98-magerun.phar not working - PHP Fatal error: Class 'Phar' not found

I can't execute n98-magerun.phar, I get PHP Fatal error: Class 'Phar' not found. I am using PHP 5.5.14 (cli) Any hints how to solve this?
1
vote
0answers
341 views

Composer command not running magento2

I am trying to run the following command - composer require ebizmarts/mailchimp-lib But I am getting following error on command line - [UnexpectedValueException] ...
1
vote
0answers
18 views

Invalid crendetials when runing composer require magento 2 extension

I got this error when running this command composer require my extension from marketplace :
1
vote
0answers
37 views

Problem with CLI installing module

Im trying to install sitemap module for Magento 2 and i got this message via cli, i make some changes in composer.json { "name": "mageplaza/module-sitemap", "minimum-stability":"dev" "...
1
vote
0answers
101 views

Use Mage::app('admin') in Composer post scripts

I am creating a post-update-cmd script in which I call some functions. The file is lib\Vendor\Module\CustomClass.php This is the command: "post-update-cmd": [ Vendor \\ Module \\ CustomClass :: ...
1
vote
3answers
831 views

Outdated Amazon_core after composer update (Magento 2.2.4)

I am getting this error: Amazon_Core db schema version: defined in codebase - 2.0.12, currently installed - 2.0.4 and Amazon_Core db data version: defined in codebase - 2.0.12, currently installed -...
1
vote
0answers
29 views
1
vote
0answers
29 views

Using Composer on Shared Host

I have just recently started dabbling in the idea of upgrading from Magento 1.9.x to 2.2.x now. Working with installing Mangento and now having to use Composer, I am attempting to run simple commands ...
1
vote
2answers
1k views

Magento 2: How To Include 3rd Party Library in Custom Module

As an example, I'm looking to use Zendesk's API to create tickets and other things within my custom modules. They have a Packagist that can be installed via composer: composer require zendesk/...
1
vote
0answers
201 views

How to prevent composer to remove bin/magento?

When I use composer to add a package, it deletes a bunch of packages, and it deletes the bin/magento . How to prevent composer to delete bin/magento ? How can I have everything working like before ...
1
vote
0answers
33 views

How to run composer.patch on Magento 2.1

I am trying to run this patch PATCH_MDVA-4538_EE_2.1.4_v2.composer.patch when I simply run the patch command it hangs. Is there a composer.patch command that I need to do?
1
vote
1answer
650 views

Could not find package 2.2.3

When updating from 2.2.2 to 2.2.3 with composer require magento/product-community-edition 2.2.3 --no-update I get this error: [InvalidArgumentException] Could not find package magento/product-...
1
vote
1answer
366 views

Magento 2 error - Model/View/Page/Config/RendererFactory.php on line 64

I have a very annoying error on my production site which occurs once a day. My site goes down with the error below and I have to refresh cache to resolve the problem. It's Magento 2.1.7 with ...
1
vote
0answers
230 views

Validate Custom Extension Magento 2.x using validate_m2_package.php

I created a custom module but trying to convert it to extension. I am trying to validate my extension with this tool https://github.com/magento/marketplace-tools . What i tried:: File structure of ...
1
vote
2answers
1k views

Composer require | You must be using the interactive console to authenticate

I'm trying to run a composer require worldpay/magento2-module-payments on Magento ver 2.1.8 and get this error: [http]$ composer require worldpay/magento2-module-payments [Composer\Downloader\...
1
vote
0answers
42 views

Check Component Dependency magento 2.1.10

I am using Magento 2.1.10. While trying to install an extension. I am getting the following error. Also I am using php version 7.0.6, but PHP version Check is showing 5.6.25. Also earlier I tried to ...
1
vote
1answer
286 views

Magento extension install - Dependancy error

I am installing an extension I have written and published to the Magento Marketplace, but I get an error when installing from the store that makes no sense. Check Component Dependency We found ...
1
vote
1answer
197 views

Magento 2.1.10 Composer Sample Data Install Issues

I have Magento 2.2.0 setup with sample data. I am trying to setup Magento 2.1.10 with Sample Data for reference. However, when running: php bin/magento sampledata:deploy I get: Loading composer ...
1
vote
1answer
496 views

Magento 2.2.1 composer upgrade issue amazon pay

I tried to upgrade Magento 2.2.0 to version 2.2.1 via composer however i received framework error about amazon pay conflict (my amazon pay version is 1.1.4). I'm aware i need to update amazon pay to ...
1
vote
2answers
441 views

Magento 2 Composer Error While Installing Tawk.to extension

I'm trying to install Tawk.to chat in my Magento 2.1.9 shopping site hosted on a cPanel shared server environment. And I downloaded the extension files following the guidelines are given here: ...
1
vote
0answers
89 views

Magento 2: Install module from multiple repositories

Today I've stumbled into a fairly intriguing issue. At the moment I'm building a module for a client and possibly I'll use it for future clients. Now, I would like to keep the core code in a ...
1
vote
1answer
640 views

Upgrade Magento 2 via composer not working

I try to upgrade Magento 2.1.6 to Magento 2.1.9. To do this I ran this command: composer require magento/product-community-edition 2.1.9 --no-update after this I ran : composer update and I ...
1
vote
1answer
372 views

magento 2, I need to add dompdf Library Without using composer in my extension

I have created an extension for HTML to PSD by using dompdf Library. I had tried to using composer and it's working fine. But I need this Library in my custom extension. When any user add extension ...
1
vote
0answers
47 views

Why can Magento 2 only uninstall composer packages

When you run bin/magento module:uninstall Vendor_Module -r and Vendor_Module happens te be a module that's not installed by Composer, Magento will not perform an uninstall. Why did Magento add this ...
1
vote
0answers
35 views

new adminhtml theme does not show in deploy list

Using Magento 2.1.1, I would like to deploy a new adminhtml theme in cli. magento setup:static-content:deploy --theme Tc/theme. Result: [InvalidArgumentException] Tc/theme argument has invalid ...
1
vote
1answer
2k views

Class 'Mpdf\Mpdf' not found

I am trying to install the magento2-pdf-generator2 extension, but I first need to install the mpdf library, I ran the composer require mpdf/mpdf command and then ran php bin/magento setup:upgrade and ...
1
vote
1answer
83 views

How can I prepare my Github's extension to install using Composer?

Using the question below I've installed extensions hosted on private and public repositories using composer, but I need to create my custom extension now. How to install an extension on a private ...
1
vote
1answer
135 views

How to add js libraries to Magento 2 extension via composer?

I'm wondering is there a way to add third-party js libraries to Magento 2 via Composer? The main idea of this is to separate our modules from those dependencies and to have them required via Composer ...
1
vote
3answers
633 views

upgrade to 2.1.5. composer updated but setup upgrade returns with invalid argument

I've had an issue with a template I purchased and needed to update it to the latest version of Magento. I've backed up my database a files and ran: composer update When this complete I ran php bin/...
1
vote
0answers
82 views

Magento 2 installation to use Extensions

i know is a bit boring ... How I have to install magento 2 that I can simple use the Extension Manager? If I try to use the Extension Manager I get these errors: Check Updater Application ...
1
vote
0answers
93 views

Magento v. 2.1.4 Readiness Check Fails at Component Dependancy

No other information is given. (Or, if it is, I do not know where to look for it.) I have a clean Magento install, no theme, no extensions, nothing. I am on a shared server so direct php.ini edits ...
1
vote
0answers
143 views

Unable to install any extension on Magento 2.1.0 website

I have a site running on Magento 2.1.0. The site was up and running for a few weeks with no issues, we were able to install a few extensions with no problems. Suddenly, we are unable to install any ...
1
vote
0answers
17 views

How change folder when get code Module in github via composer in magento2?

I have create a module in github. When i run composer require namespace/modulename dev-develop in root magento2 folder. It get source to vendor/namespace/modulename folder. I want put code to app/...