Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

3
votes
0answers
431 views

Could not install B2B extension for magento 2.2.0-EE

I have installed Magento-EE-2.2.0 with sample data. After installation, i tried to install B2B extension using composer composer require magento/extension-b2b Used the following reference site ...
3
votes
0answers
154 views

Publishing extension to Marketplace

I'm trying to publish extension to the magento marketplace. I receive an error when i press submit button on magento's web from: Can't connect to package repository i have added my GitHub ...
3
votes
0answers
230 views

How to upgrade new version of module code by using composer in Magento 2 from third party repository

We have installed third party modules successfully using command composer update by Adding below repository to composer.json "repositories": { "0": { "type": "composer", "url": "...
3
votes
0answers
306 views

Composer\Downloader\TransportException

Invalid credentials for https://repo.magento.com/archives/magento/module-sales-archive/magento-module-sales-archive-100.1.1.0.zip I've successfully configured Composer credentials with my Magento Key ...
3
votes
0answers
117 views

Validating composer.json in magento giving me the following error

Updating through the command line and with market place took 1) Once you have packaged your extension in .zip file move it to a directory. 2) Download the validation script and extract it to the ...
2
votes
4answers
525 views

Magento 2: Composer Only Instalation

I'm trying to write up a tutorial explaining how to install Magento 2 only via composer, and use that tutorial as an in to exploring how third party composer repositories work. Looking at the current ...
2
votes
3answers
2k views

In Magento2 RC, does every module and theme need to be pulled via composer?

I added registration.php to my custom (project specific) modules and themes. But those files do not end up in vendor/composer/autoload_files.php after composer.phar dumpautoload - so the modules are ...
2
votes
6answers
2k views

Magento 2.1.9 upgrade to 2.2.0 - Error on setup:upgrade with Magento_Sales table

Upgrading magento from 2.1.9 to 2.2.0 and during the automatic bin/magento setup:upgrade process it runs all upgrades fine until it reaches the magento_sales table where it produces this error. There ...
2
votes
2answers
326 views

Installed Magento 2.1 via composer. What's step 2?

I just installed Magento 2.1 via Composer in my local XAMPP 5.6 server. composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition magento2 cd magento2 ...
2
votes
3answers
2k views

Magento 2.3 installation PHP requirement

I'm trying to update Magento 2.2 to version 2.3 using this command: composer require magento/product-community-edition=2.3.0 When doing so, I receive the following error: Loading composer ...
2
votes
3answers
4k views

Recommended way to Install Magento 2 on shared hosting, Composer or archives

The Install Guide recommends installing the software using archives (not Composer) for a shared hosting environment. However, from Magento documentation: Everyone who uses the Magento software ...
2
votes
2answers
4k views

Magento2 install sample data after - I get invalid credentials [duplicate]

I run composer update from root and I get: Loading composer repositories with package information Authentication required (repo.magento.com): I enter my credentials that I use to login here: ...
2
votes
2answers
252 views

When would you place a module in the app/code folder versus another location?

When would you place a module in the app/code folder versus another location? If I add new module in app/code folder with composer.json and another module in vendor folder using composer What ...
2
votes
2answers
1k views

PHP requirement incompatible with your PHP version | Composer module installation error

I try to install an extension using the composer: composer require magenest/module-worldpay-and-subscriptions:2.0.0 And get this: [InvalidArgumentException] Package magenest/module-worldpay-and-...
2
votes
1answer
458 views

Why we need to commit composer.lock file in magento 2?

I am a little confused regarding composer.json and composer.lock file.I have read about composer and got when we commit code then it is necessary to push composer.lock file.I am not understanding why ...
2
votes
1answer
2k views

Magento 2: usage of composer.json file?

I would like to know that why we create compose.json and What is it use. Can someone briefly explain that to me? company --module composer.json
2
votes
1answer
50 views

How to auto get Module A when install Module B in magento2?

For example I have two modules, Demo and Base. I want that when Module Demo gets installed, module Base is automatically fetched from Github and installed. I think it is related to composer. Edited ...
2
votes
1answer
147 views

How to load a classmap[ped] Composer class (packagist) in Magento 1?

I've installed and deployed magento-hackathon/magento-composer-installer in my Magento 1.9 and I am trying to add and use mpdf/mpdf (composer packagist) in a controller. This package contains a ...
2
votes
3answers
496 views

Installation issue in magento marketplace 'page doesn't contain HIT in cache header.'

I have developed customer module in magento. When i am trying to submit in marketplace its keep giving the same error even after trying so many solutions. Installation issue: http://magento.dev/gear....
2
votes
1answer
2k views

Package sjparkinson/static-review is abandoned message in Magento 2

I am using the command to upgrade 2.2.2 but getting this problem, how can I do, thank you!please help! composer update Running composer as root/super user is highly discouraged as packages, ...
2
votes
1answer
376 views

Updating Magento 2 using composer - zlib_decode(): data error

I'm tried update my Magento 2.1.0 to 2.1.5 using composer update and changing the composer.json file, but shows up this error message below, what can I do to run normally? Failed to decode response: ...
2
votes
3answers
533 views

Errors during installation- Submitting Package to Magento Marketplace

I am trying submit one Magento2 Extension on Magento2 marketplace but i am getting following error: Problem 1 Environment: Operating System - Centos 7, PHP Version - 5.6 , Magento Platform - 2.1 ...
2
votes
1answer
777 views

Composer Vendor Directory : Accessing magento classes from Vendor directory

I have installed a magento module called Mage-Resque using composer. Composer has installed all the components into a directory called Vendor. When I run the module, one of the component needs to ...
2
votes
1answer
177 views

Magento 2: why contributers can't use the Web Setup Wizard?

So earlier today I was looking for my update/cron.php folder and I ended up finding that: If you cloned the GitHub repository you don’t have an update directory and errors result if you run ...
2
votes
1answer
5k views

configuration for DB connection is absent

bin/magento setup:upgrade Cache cleared successfully File system cleanup: public_html/var/generation/Composer public_html/var/generation/Magento public_html/var/generation/Symfony The directory '...
2
votes
1answer
3k views

Magento 2 Component manager (extension installation)

I'm developing an extension for Magento 2, and was wondering what are my options for the installation process for users. I saw in the magento documentation that there supposed to be a component ...
2
votes
2answers
50 views

Installing extension via Composer

I have tried to install the extension via Composer and successfully installed. After installing, I can see the extension menu in the admin panel. However, I can't see any files in the app/code ...
2
votes
3answers
7k views

magento 2.2.6 to 2.3 upgrade fails with composer

I tried to upgrade my 2.2.6 Magento install with composer following the tutorial on Magento Website, but "composer update" fails with these errors : Your requirements could not be resolved to an ...
2
votes
2answers
263 views

Magento 2.2.3 upgrade to 2.2.4 giving error

I'm trying to upgrade my magento 2.2.3 to 2.2.4 through putty: php70 composer require magento/product-community-edition 2.2.4 --no-update php70 composer/composer.phar update and after this I try: ...
2
votes
2answers
201 views

Magento Using Composer Class in Module

I am using geoip2/geoip2:~2.0 but need to access the GeoIP data from within a magento Model Class. use GeoIp2\Database\Reader; gives an error. I am not sure how to call this in order to be able to ...
2
votes
2answers
681 views

Magento upgrade 2.19 to 2.2

Got this error, no clue how to upgrade: - magento/product-community-edition 2.2.0 requires composer/composer 1.4.1 -> satisfiable by composer/composer[1.4.1] but these conflict with your ...
2
votes
1answer
2k views

Magento 2.2.0 - Upgrade / Migrate from Magento 2.1.9

Followed the commands below to upgrade Magento 2.2.0, I am on 2.1.9 composer require magento/product-enterprise-edition 2.2.0 --no-update composer update magento/product-enterprise-edition 2.2.0 I ...
2
votes
2answers
485 views

Checking if the Magento 2 access keys are valid for Enterprise or Community

Here's a weird question, is there a way to check if a given Magento2 access keys (authentication keys) are for the Enterprise edition or Community edition without actually trying a composer ...
2
votes
1answer
2k views

Cannot see new custom Module in Magento 2.1.2

I am new to Magento, and I am trying to do add my very first module. I tried to follow two tutorials that show how to create a "Hello World" module, which basically shows a 'Hello World!' message on ...
2
votes
1answer
130 views

Uninstall meta package with related extensions

I created 2 (but planning to create 999 :) ) extensions and a meta package for it. The meta package extension contains only composer.json` { "name": "sergei/module-main", "version": "1.0.0", ...
2
votes
2answers
537 views

Deploy Magento 2 website on Staging server and Composer

I installed Magento 2 locally using Composer I use Git to track my code I need to deploy my local Magento 2 site to a staging server (shared hosting) 1) For what do I need Composer anyway on Staging ...
2
votes
1answer
86 views

Composer exception: Package is already installed

After update to new release version Magento Hackathon faced with exception while running composer update: Package: "some_package_name" is already installed. This happened only with this release. ...
2
votes
1answer
541 views

Magento Composer Installer - Require works, Suggest does not

So I'm currently playing about with Composer and Magento, and having a bit of trouble getting the magento-composer-installer to play nice. Firstly, my composer.json files! Module: { "name":"...
2
votes
1answer
31 views

Magento 2. How can I properly extend vendor/composer/installed.json?

I assume that installed.json contains all the dependencies needed for Magento. How can I properly extend vendor/composer/installed.json? Context: Magento has a hard dependency on one of the ...
2
votes
1answer
29 views

Why module go to vendor directory if install using composer Magento2?

Can anyone please tell me the reason why module go to Vendor directory when install using composer? Please refer me a link for this reason. In my custom extension, I am using this code in my ...
2
votes
2answers
50 views

Magento 2 : How to override a custom module which install via composer?

I have installed one custom module using composer as usually that module was installed in vendor directory is there any way to override phtml file in the same module like name but on app/code module ...
2
votes
1answer
454 views

Error composer 1.8.4 on magento 2.3.0 CE

I got this warning : Warning: Unsupported declare 'strict_types' in /home/SITE_NAME/public_html/vendor/magento/inventory-composer-installer/src/Plugin.php on line 6 And this error : Parse error: ...
2
votes
1answer
33 views

How to mention the magento version compatibility in composer.json

I am creating a module in Magento 2. Now I am writing composer.json. Here I write supporting PHP version "require": { "php": "~5.6.0|^7.0.0", }, How do I write my module will be supported by ...
2
votes
1answer
540 views

Magento 2 : Plugin autoload error

I have recently move a magento 2.2.5 website to a new server and now when I run an upgrade command or compile command I receive the below error. I have tried deleting any and every folder i can find ...
2
votes
2answers
807 views

Running out of memory while reindexing using -d memory_limit=3G

I recently migrated data from Magento 1.8.1 to Magento 2.1.7, which includes around 700,000 customers. After migration, I am running this command: php -d memory_limit=3G bin/magento indexer:reindex ...
2
votes
1answer
324 views

Require specific Magento 2 Github commit with composer

There are some explanations on Stackexchange on how to require a specific commit with composer, for example these: https://stackoverflow.com/questions/25878984/can-i-pull-a-specific-commit-with-...
2
votes
1answer
767 views

Magento2 - Moving or extending a module from vendor to app folder

I have an extension Magestore_Bannerslider, which the previous developer installed using composer for magento2, The module is installed and working properly. The code is in the vendor folder I need ...
2
votes
1answer
716 views

Including PHP Class in Magento 2 Controller

I have this 3rd party class Mailchimp.php which I need to include in my controller so that I can create an object and make api calls. But I'm not able to do so. I get this error when I try to run my ...
2
votes
1answer
365 views

Composer not updating package (grabbing it from repo.magento.com instead of packagist) [closed]

My package (https://packagist.org/packages/limesharp/stockists) is not getting updated when running composer update (it's currently stuck at 1.0.5 instead of grabbing 1.0.11). On a closer look at the ...
2
votes
1answer
1k views

bash: stty: command not found error in SSH

I'm trying to install applications from the Magento Repository via Bitvise SSH, but I'm getting the following error in all cases (this case is an attempt to install the Data Migration tool) right ...