Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

37
votes
7answers
54k views

How to update Magento2 using composer

I can't seem to be able to update my magento2 ce using composer. I doesn't find any updates, the only one it found was 'fabpot'. I thought this was the whole point of a composer setup, so why would I ...
6
votes
1answer
3k views

Magento2: How to include third pary module through composer.json in custom module

I created a custom module, this module depends on thirt party module(tecnickcom/tcpdf), I added this library in my custom module composer.json file { "name": "packagename/mymodule", "description": "N/...
1
vote
2answers
401 views

Magento 2 : How can you install a Magento2 quickly to last version with sample data with composer

How can you install a Magento 2 quickly to last version with sample data with composer Can you install a Magento2 last version with sample data with composer?
1
vote
1answer
197 views

Magento 2 : How quickly can you install with composer a Magento2 last version without sample data [closed]

How quickly can you install with composer a Magento2 last version without sample data
16
votes
4answers
13k views

Why `code` folder is missing under `app` folder in magento 2 stable version?

I have downloaded Magento 2 stable from https://www.magentocommerce.com/download with sample data and installed. It's working fine in both areas i.e. frontend & backend. But I could not find app/...
13
votes
1answer
4k views

Magento 2 uninstall module

Apparently, now Magento 2 supports uninstall scripts that allow db schema modification when uninstalling a module (horay!!). As explained in here this only works for module installed via composer. (I ...
8
votes
4answers
6k views

Magento 2 deployment process

Currently we commit composer.lock to the repository and then run composer install --no-dev on the production server. I don't think this is the best way to do it because it takes a few minutes for ...
6
votes
1answer
1k views

Upgrade Magento from 2.1 to 2.2.1 with sample data using composer

What steps do I need to follow to upgrade a demo installation with sample data from Magento 2.1 to the latest 2.2 version? Instructions that work for Magento Commerce (Enterprise Edition) as well as ...
3
votes
1answer
673 views

Magento 2.2.0 Upgrade error

When I am trying to upgrade my Magento version from 2.1.7 CE to 2.2.0 CE, through composer update, I am getting the following error. Problem 1 - magento/module-wishlist-sample-data 100.1.0-rc1 ...
2
votes
3answers
499 views

Installation issue in magento marketplace 'page doesn't contain HIT in cache header.'

I have developed customer module in magento. When i am trying to submit in marketplace its keep giving the same error even after trying so many solutions. Installation issue: http://magento.dev/gear....
0
votes
1answer
3k views

Install Magento 2 with MAMP [closed]

I have MAMP & MAMP PRO. I tried to install Magento 2 beta. When i write "composer install" the system returns me this error: Your requirements could not be resolved to an installable set of ...
26
votes
6answers
6k views

Magento 2 - Uninstallable set of packages when deploying magento-sample-data

I've followed this Magento DevDocs tutorial to install sample data after installing Magento 2. But after executing the last command ./bin/magento sampledata:deploy I get the following error: ./...
19
votes
1answer
4k views

Integrating composer's autoloader into Magento

So composer is awesome, and there's a lot of code in composer's packagist repository that makes writing Magento extensions easier. The problem I'm facing, is how best to (cleanly) setup autoloading. ...
14
votes
7answers
19k views

Magento 2.1.1 not compatibile with PHP 7.1.0

I've a new server with PHP v7.1.0RC3 installed. According to DevDocs Magento 2 is compatible with 7.0.2 up to 7.1.0, except for 7.0.5 which makes PHP 7.1.0 compatible with M2 however when tried to ...
12
votes
8answers
13k views

Package fabpot/php-cs-fixer is abandoned message in Magento 2

I am using Magento 2.0.5. When I run the composer update or composer install command it's showing the following warning. Package fabpot/php-cs-fixer is abandoned, you should avoid using it. Use ...
1
vote
3answers
13k views

Install extension using composer Magento 2

I'm using magento 2 , and I'm trying to install an extension from composer.json file , now I've installed composer through SSH , but I'm new to composer installations , how do I proceed now with the ...
9
votes
4answers
2k views

Cannot upgrade from 2.2.6 to 2.3 via composer

I have a clean Magento 2.2.6 with sample data that I installed using composer. I am trying to update it to Magento 2.3 so following the steps outlined here by the Magento team. After running ...
1
vote
1answer
795 views

Magento 2 .gitignore template in combination with Deploybot and Git workflow

I installed Magento 2 using composer locally (on my local Dev environment using MAMP). I added my custom theme and did all my frontend work on my local Dev site. I want my code and changes to be ...
2
votes
3answers
535 views

Errors during installation- Submitting Package to Magento Marketplace

I am trying submit one Magento2 Extension on Magento2 marketplace but i am getting following error: Problem 1 Environment: Operating System - Centos 7, PHP Version - 5.6 , Magento Platform - 2.1 ...
2
votes
1answer
586 views

Magento 2 deployment from Dev to Staging using Git

I have a local Dev environment and installed Magento 2 using composer I initialized the local /magneto2/ folder as a Git repo I added this .gitignore file to the root of my /magneto2/ folder I have a ...
0
votes
1answer
666 views

Magento 2: Composer Update is Not Working [Failed to open stream: Connection timed out]

I'm trying to update composer but it gives below error. root@magento-2:/var/www/html/magento# composer clear-cache root@magento-2:/var/www/html/magento# composer diagnose Do not run Composer as root/...
-1
votes
1answer
978 views

SQLSTATE[42S02]: Base table or view not found: 1146 Table db name xyz.core_url_rewrite' doesn't exist

in local this error are display in my magento website plzz give me right answer thanks
18
votes
1answer
6k views

How to install a specific Magento 2 version with Composer?

I want to install Magento version 2.1.7 with the Composer, I found in the docs that I can use in the require: "magento/product-community-edition": "2.1.7", but composer says that requested package ...
18
votes
4answers
4k views

Install Magento Base with Composer

I know there are nice ways to install Magento Modules (from Connect) and from GitHub (if composer.json is provided). (as described in http://magebase.com/magento-tutorials/composer-with-magento/) Is ...
4
votes
3answers
986 views

How to upgrade magento to 2.1.0-rc1 via composer?

I need to upgrade version of my magento base inside store. All the vendors I'm getting via composer and git contains only my /app/code and /web/composer.json. Current version is 2.0.7 and needed ...
8
votes
4answers
669 views

Magento 2 as composer dev requirement for extensions

When writing an extension, would it make sense to add magento/project-community-edition to the require-dev section of composer.json? The idea behind that is that it would only require a composer ...
7
votes
3answers
2k views

Magento 2: What Causes the “Failed to enable crypto” Error?

I'm trying to install Magento 2.1 via the composer meta-package with the following command composer create-project --repository=https://repo.magento.com/ magento/project-community-edition However, ...
6
votes
1answer
947 views

Error during upgrade to Magento 2.1 from 2.0.7

Since a couple of days i try to upgrade my "native" Magento 2.0.7 I use composer as suggested by documentation : composer require magento/product-community-edition 2.1.0 --no-update; composer update; ...
6
votes
3answers
8k views

Sample data for Magento 2 - PHP memory problem while installing from Composer

Recently I tried to install Magento 2 with sample data and failed. I added the proper package to the composer.json file and when I run composer update it always fails just before finishing downloading:...
3
votes
1answer
866 views

Magento 2 - discrepancy between documentation and theme files structure on github

I am creating a new theme and would like to start by duplicating the default blank theme and then modify it to become my new theme. When I checked the frontend developer guides, it indicated the ...
1
vote
2answers
2k views

Magento 2 override core Model class with psr-4 by replacing in app/code/Magento

"autoload": { "psr-4": { "Magento\\Framework\\": "lib/internal/Magento/Framework/", "Magento\\Setup\\": "setup/src/Magento/Setup/", "Magento\\": "app/code/...
4
votes
2answers
1k views

How to install modules in app/code with composer in Magento 2

How can I force composer to install modules in app/code instead of vendor directory in Magento 2? I have few modules they strictly need to be install in app/code, but when I update them with ...
3
votes
4answers
3k views

Magento 2: “https://packages.magento.com/packages.json” file could not be downloaded

I keep getting this warning when I run composer update in my Magento 2 install. Loading composer repositories with package information Your configuration does not allow connections to http://packages....
3
votes
1answer
110 views

How to make and install my module via composer with two private repositories in magento 2

Problem Description: I have created two private repositories in github under same user name. Each repository contains different modules. But while trying to install the package via composer throws ...
3
votes
0answers
435 views

Could not install B2B extension for magento 2.2.0-EE

I have installed Magento-EE-2.2.0 with sample data. After installation, i tried to install B2B extension using composer composer require magento/extension-b2b Used the following reference site ...
2
votes
0answers
1k views

Installing Data-Migration-Tool with Composer: git not found error

when I try to install the Data-Migration-Tool with Composer: composer config repositories.data-migration-tool git https://github.com/magento/data-migration-tool composer require magento/data-...
5
votes
1answer
2k views

Error in using composer to install a module in Magento 2.0

I have used Composer for installing other modules specially from github and they worked fine. However I have problem installing the following module to Magento 2.0 . The module I want to install is ...
3
votes
1answer
446 views

Installation issues on packaging a module: Magento 2

I created a custom module in Magento 2 and then tried to package it for submitting it to the Magento marketplace. I followed this link in order to create a composer file and packaging of the module: ...
2
votes
1answer
5k views

configuration for DB connection is absent

bin/magento setup:upgrade Cache cleared successfully File system cleanup: public_html/var/generation/Composer public_html/var/generation/Magento public_html/var/generation/Symfony The directory '...
2
votes
0answers
369 views

Magento2 Compile command ends at Repositories code generation 1/7

Magento v2.1.7 CE PHP 7.0 Permissions double checked When I run compile command through cli, it ends at step 2 as seen in the image below. I found that it might be due to a wrong auth.json in ...
2
votes
3answers
2k views

In Magento2 RC, does every module and theme need to be pulled via composer?

I added registration.php to my custom (project specific) modules and themes. But those files do not end up in vendor/composer/autoload_files.php after composer.phar dumpautoload - so the modules are ...
2
votes
3answers
338 views

Magento 2.1.9 Composer error

I'm getting the following error using Magento 2.1.9: "Package magento/composer's source key should be specified as {"type": ..., "url": ..., "reference": ...}, {"type":"git","url":"https:\/\/github....
2
votes
3answers
7k views

magento 2.2.6 to 2.3 upgrade fails with composer

I tried to upgrade my 2.2.6 Magento install with composer following the tutorial on Magento Website, but "composer update" fails with these errors : Your requirements could not be resolved to an ...
1
vote
3answers
623 views

upgrade to 2.1.5. composer updated but setup upgrade returns with invalid argument

I've had an issue with a template I purchased and needed to update it to the latest version of Magento. I've backed up my database a files and ran: composer update When this complete I ran php bin/...
1
vote
2answers
1k views

Can't upgrade Magento 2.2.4 to 2.2.5

I am trying to upgrade Magento 2.2.4 to 2.2.5 with composer. php bin/magento maintenance:enable php composer.phar require magento/product-community-edition 2.2.5 --no-update php composer.phar update ...
1
vote
5answers
876 views

Magento 2 - No Theme after installation

I had "magento 2" installed with composer. the installation is running correctly. Now, when I look at the backend or the frontend no Theme appears. What could be wrong? I have also tried it with the ...
1
vote
1answer
791 views

Trying to upgrade from 2.1.6 to 2.1.7 and getting a composer error

I am trying to upgrade from Magento 2.1.6 to 2.1.7 using this https://stackoverflow.com/documentation/magento2/9022/upgrading-magento#t=201704130958117574309 as my guide. I type in- composer require ...
0
votes
1answer
347 views

how to upgrade from magento 2.3.0 to 2.3.1 steps (composer) [duplicate]

I want to upgrade my magento to the latest version. what are the steps to upgrade from Magento 2.3.0 to Magento 2.3.1 via composer?
0
votes
1answer
803 views

How to install an extension on a private Github using Composer?

I'd like to know how to install extensions on my Magento 2.1 using Github / Bitbucket / Gitlab with public and private repositories. Thanks.
0
votes
1answer
746 views

bin/magento sampledata:reset tries to read nonexistent composer.json

I want to update a Magento installation with sample data from 2.0.2 to 2.0.7, so I am following the instructions here to update the sample data. When running bin/magento sampledata:reset I get the ...