Questions tagged [composer]

Composer is a tool to manage dependencies in PHP. It supports fetching dependencies from different sources like Git, SVN, PEAR, the local filesystem, etc. and also offers automated autoloading support.

Filter by
Sorted by
Tagged with
0 votes
2 answers
17 views

How i install Magento 2.4.3p2 using composer?

I am new in magento. so, please give me a hint how to install magento 2.4.3p2 using composer with sample data
0 votes
1 answer
15 views

Magento 2 no longer depends on DotdigitalGroup

After upgrading Magento from 2.4.2 to 2.4.4, I am getting this error [2022-09-19T12:09:48.690729+00:00] report.DEBUG: Source class "\Dotdigitalgroup\Sms\ViewModel\TelephoneInputConfig" for &...
0 votes
2 answers
30 views

upgrading to magento from 2.4.3 to 2.4.4 with php 8.1

I am upgrading Magento CE from 2.4.3-p1 to 2.4.4-p1 with php 8.1 but I got this problem facebook/graph-sdk does not support php 8.1 and it is PHP package not Magento 2 Module, facebook/graph-sdk 5.6....
0 votes
1 answer
8 views

Install Live Search for Magento - package not found

I've installed Magento with sample data on a virtual machine. Now I'm trying to install Live Search for it. I used the instructions from this link. As the instruction says, I run the command below: ...
0 votes
0 answers
13 views

Problems when using composer require with Magento/Framework in Magento 2.4.2

Using Magento 2.4.2 Composer 2.2.17 I am trying to install Mollie Payments in Magento 2.4.2. Using Composer version 2.2.17. After running composer require mollie/magento2, i get the following problems:...
1 vote
0 answers
47 views

curl error 56 during composer install

We have have recently upgraded Magento from 2.3.5 to 2.4.4 and trying do deploy the update to our staging server. During the composer install we get the following error after a while: $ php8.1 /usr/...
0 votes
0 answers
45 views

PHP's phar extension is missing. magento2.4.5

I have been installing Magento2.4.5 getting below error while executing composer install Can anyone suggest me how to resolve this. PHP's phar extension is missing. Composer requires it to run. ...
0 votes
1 answer
1k views

Magento 2: composer update from 2.3.0 to 2.3.5-p1 fails with missing ext-mcrypt

I have a magento 2.3.0 install (just upgraded from 2.2.7) running on php 7.2 (PHP 7.2.31-1+0~20200514.41+debian9~1.gbpe2a56b). Now I wanted to upgrade to 2.3.5-p1 using composer: composer require ...
1 vote
0 answers
21 views

Magento 2.4: Error on running composer require magento/quality-patches

I am getting this error as soon as I enter the username (access key from the marketplace): Fatal error: Uncaught Error: Call to undefined function Symfony\Component\Console\Helper\exec() in phar:///...
5 votes
1 answer
3k views

Magento 2.2.0 - Upgrade / Migrate from Magento 2.1.9 to Magento 2.2.0 with Sample Data

Followed below commands to upgrade Magento 2.1.9 to 2.2.0 using terminal 1. composer require magento/product-community-edition 2.2.0 --no-update 2. composer require \ magento/module-bundle-...
0 votes
1 answer
21 views

Moved modules from vendor to code, modules not working

I've removed a couple of modules from composer, and placed the folder/files into the app/local folder according to the structure als mentioned in the registration.php. The modules are enabled as seen ...
9 votes
5 answers
23k views

Magento 2.4.1 setup:install problem : "the default website isn't defined. Set the website and try again."

I downloaded magento 2-2.4.1.zip. Unzipped it to /var/www/html/magento24/ - my local folder for local domain http://magento24.local configured by nginx on ubuntu20.04. I had done composer update or ...
1 vote
1 answer
38 views

Move modules from vendor to app

We've took over a Magento2 store which is using several (payed) modules without a working license key which wont be provided by the previous agency. The modules are created by the previous agency, so ...
1 vote
1 answer
19 views

Update with composer

We've took over a magento store. Whenever I try to update, I'm getting the following errors: Problem 1 - magento/inventory-composer-installer 1.1.0 requires composer-plugin-api ^1.1 -> found ...
0 votes
1 answer
1k views

How to solve Magento 2 with composer 2 version error when sample data install

My application running AWS Bitnami platform. I am trying to upload sample data using composer after commands show warning message below Do you want to store credentials for repo.magento.com in /...
4 votes
1 answer
4k views

composer connection refused

Context: magento 2.1.7 community-edition composer.phar 1.7.2 installed and setup on a development server then deployed on a production server (dictinct from the previous) All worked well, including ...
2 votes
2 answers
33 views

Magento2: How to create a patch for custom module composer.json?

I want to know that can we create patch for some changes in composer.json of custom module. I am talking about custom module composer not magento composer. Its just like changes but instead of any php ...
0 votes
0 answers
9 views

Add patch to the composer.json of a module

I want to update the req php version of a custom module composer.json and for that i've made a patch but problem is module requires php 7.3 and my magento version reqs php 7.4. I can change manually ...
0 votes
1 answer
2k views

Cant install Klarna on magento 2.3.2

I tried to install Klarna in my Magento 2.3.2 website using composer trollweb. I kept getting errors as the klarna checkout was not working. In the end, I used mage2pro klarna to set it up Is there ...
1 vote
1 answer
1k views

Can't run composer command programmatically in magento 2

I am using php shell_exec method to run the magento commands in my controller. Below is my controller code. <?php namespace Vendor\Module\Controller\Adminhtml\Migrate; use Psr\Log\...
2 votes
0 answers
1k views

Composer install .zip could not be downloaded

When I run composer install I get the error message: [Composer\Downloader\TransportException] The "https://repo.magento.com/archives/magento/module-invitation/magento-module-invitation-100.3.5.0.zip" ...
3 votes
1 answer
1k views

How to make and install my module via composer with two private repositories in magento 2

Problem Description: I have created two private repositories in github under same user name. Each repository contains different modules. But while trying to install the package via composer throws ...
0 votes
2 answers
4k views

Could not find a matching version of package

I have uploaded my magento 2 module to GitHub, and published my private module to https://packagist.com/. Now module published successfully as below. And my composer as below { "name": &...
0 votes
2 answers
11 views

How to install exact same module versions to production installation

I have tested all extensions and theme in staging installation and now I need to install the exact same versions of each module and theme to the production installation by using composer. What is the ...
0 votes
0 answers
10 views

Get stuck when using magento2/vuestorefront/composer

rookie here. Im trying to connect magento2 with vuestorefront using composer. I am following this guide: https://docs.vuestorefront.io/magento/installation-setup/configure-magento.html. On step 2, ...
0 votes
1 answer
2k views

Magento 2 upgrade killed process

I want to upgrade Magento 2.1.7 to Magento 2.3.2 and I follow below commands sudo composer require magento/product-community-edition=2.3.2 --no-update sudo composer require --dev phpunit/phpunit:~6.2....
1 vote
3 answers
2k views

Syntax error when compiling / Upgrade from 2.4 to 2.4.3

I am getting this error when compiling my updated MCE 2.4.3 install. I have php 7.4.27 in magento and outside in the shell. I have read that this might be connected to wrong version of php but i ...
1 vote
5 answers
2k views

Magento 2 - No Theme after installation

I had "magento 2" installed with composer. the installation is running correctly. Now, when I look at the backend or the frontend no Theme appears. What could be wrong? I have also tried it with the ...
6 votes
1 answer
1k views

Error during upgrade to Magento 2.1 from 2.0.7

Since a couple of days i try to upgrade my "native" Magento 2.0.7 I use composer as suggested by documentation : composer require magento/product-community-edition 2.1.0 --no-update; composer update; ...
1 vote
2 answers
2k views

Win 10, WAMP, Magento 2.x install using either method help

Is there a detail and current guide for a newbie to install Magento 2 in my test environment? I am good at following detail instructions. I have spent over 3 days downloading and reading html and you ...
0 votes
1 answer
59 views

Package urls replaced by 2tvenom/cborencode

I am working on an upgrade from Magento 2.3 to 2.4.3-p2. After a recent composer update of an extension a lot of repository URLs were replaced with random entries like the below. `codeload.github.com/...
1 vote
1 answer
1k views

Magento 2 error - Model/View/Page/Config/RendererFactory.php on line 64

I have a very annoying error on my production site which occurs once a day. My site goes down with the error below and I have to refresh cache to resolve the problem. It's Magento 2.1.7 with ...
0 votes
0 answers
10 views

Magento 2.4.2: Unable to find a compatible set of packages based on your non-dev requirements alone

Running composer update command after running composer require-commerce magento/product-community-edition 2.4.4 --no-update --interactive-root-conflicts causes the following error in the process of ...
1 vote
2 answers
7k views

Class 'Mpdf\Mpdf' not found

I am trying to install the magento2-pdf-generator2 extension, but I first need to install the mpdf library, I ran the composer require mpdf/mpdf command and then ran php bin/magento setup:upgrade and ...
2 votes
3 answers
757 views

Installation issue in magento marketplace 'page doesn't contain HIT in cache header.'

I have developed customer module in magento. When i am trying to submit in marketplace its keep giving the same error even after trying so many solutions. Installation issue: http://magento.dev/gear....
3 votes
3 answers
13k views

Magento 2: How to solve an error when reindex by CLI?

I used Magento 2 stable version. when I run Magento setup:upgrade, following error occurred. [InvalidArgumentException] There are no commands defined in the "setup" namespace. And when I run Magento ...
0 votes
0 answers
118 views

Magento 2.4.2: Your requirements could not be resolved to an installable set of packages

Running the command composer update --with-all-dependencies when trying to upgrade Magento 2.4.2 to 2.4.4. throws this message in red Your requirements could not be resolved to an installable set of ...
0 votes
0 answers
37 views

Magento: 500 Internal Server Error after upgrading to 2.4.4

The store front shows 500 Internal server error after I followed all instructions in the article here to upgrade Magento. On checking the version of Magento with the command bin/magento --version ...
0 votes
1 answer
54 views

Composer\Downloader\FilesystemException Filesystem exception:

As I ran the command composer require -w as part of the process to upgrade Magento 2.4.2 to 2.4.4, I found the error seen in the image below. Below is the article I'm referring to upgrade Magento. ...
0 votes
2 answers
2k views

Can't upgrade to 2.2.3 from 2.2.2. Memory limit reached

I'm trying to upgrade my Magento installation but experiencing problems with the process: I was trying to update my site to the latest release as advised and I did so via the command line but I ran ...
0 votes
1 answer
52 views

Magento 2 Composer Install Allowed memory size exhausted

I am installing Magento 2.4.3 community edition in my local machine. Machine Specifications: 1.Linux (Ubuntu OS) 2.Nginx 3.Php 7.3 and Mysql I've set the memory limit as -1 (unlimited) and all other ...
0 votes
1 answer
17 views

Updating magento by composer error

I'm trying to update a magento2.3.4 store to magento2.3.6-p1 using composer, composer-1 require magento/product-community-edition=2.3.6-p1 What could it be? any help is appreciated... update: I ...
6 votes
2 answers
5k views

Why Composer install is asking to allow-plugins?

Why when I run composer install using Composer 2, I'm receiving these messages below asking to "trust" the Composer plugins? magento/magento-composer-installer contains a Composer plugin ...
2 votes
3 answers
3k views

M2.4 Exception throwing while executing composer require: Higher matching version 2.3.x of xxx/module-xxxx was found in public repository packagist

While executing composer require xxxx/module-xxxx I'm facing below error on the console. Repository is private at the moment. [Exception] ...
0 votes
0 answers
35 views

composer require <module_name>:<version> 2.4.4

Hello i'm trying to install a plugin with composer in Magento 2.4.4 but how can i fix following error? Thanks
0 votes
2 answers
2k views

Composer error when try install extension

I'm getting this when i'm trying to install an extension. Warning: Unsupported declare 'strict_types' in /home/SITE_NAME/public_html/vendor/magento/inventory-composer-installer/src/Plugin.php ...
2 votes
5 answers
1k views

Magento 2 Install extension but not upgrade Magento via composer

So if I understand it right the php bin/magento setup:upgrade is used for both, upgrading magento 2 and also for installing extensions via composer. How can I just install the extension without ...
0 votes
1 answer
71 views

Rewrite GuzzleHttp\Client in Magento2 not working

Though it is very basic or I suppose to have this working straight but after spending hours am looking for community experts insight/support. Have to add monitoring of all outgoing requests from ...
0 votes
0 answers
33 views

Composer hangs when downloading magento/magento2-base package

When I try do a composer install it hangs when downloading Magento base package. I confirmed it's not the keys. When I enter wrong credentials it just fails and reports the credentials are wrong. I ...
0 votes
1 answer
110 views

composer showing error when i install a plugin on magento 2.2.11

I am doing as below: /usr/local/lsws/lsphp72/bin/php composer.phar require facebook/php-business-sdk --no-plugins its showing error as: Using version ^13.0 for facebook/php-business-sdk ./composer....

1
2 3 4 5
14