I am running EE 1.14 and I am seeing more than a few errors in my products data that should be fixed upon reindexing. Since the errors persist, I am thinking that the reindex process is not working correctly. I tried running the indexer.php script from a command line and the whole process seems to run amazingly quick...essentially instantly. Each index reports that it has been reindexed in 00:00 and nothing changes.... Kind of a rambling question, but what I need is some way to confirm that the process is actually doing anything?


EE 1.13+ implemented always running cron, so the indexer would be triggered at any moment. Since this is the case the indexers in Enterprise keep a change log table(s) of data that needs to be updated by the indexers. Such could be called materialized views.

You may be experiencing a caching issue, have you tried to disable caching completely or flushing to determine if the data that is missing or invalid appears?

BTW, when running php -f shell/indexer.php the partial indexing isn't used, as this will still run a complete indexing of all EAV tables regardless of their change status.

Anyhow, hope this helps!

  • It seems the indexing is happening as expected. What seems to be not happening is the product URL rewrites being updated/created during the indexing process. The indexing is apparently a symptom of a greater ailment.... – Greg Nickoloff Mar 14 '16 at 15:27
  • @g-man1066 what happens when you try to execute the URL Rewrite indexer via CLI? php -f shell/indexer.php – B00MER Mar 14 '16 at 17:40
  • It appears to run without incident. I don't see any evidence that it did anything (hence this thread) but I don't see any errors either. – Greg Nickoloff Mar 14 '16 at 23:50

So...upon solution, this seems to have veered off-topic. I think the answer for the original question is a quality answer and may be useful for others, so I won't delete the question.

One of the errors I was initially seeing was that certain products were not getting a URL redirect even though a "url_key" was specified for those products. Changing/updating the "url_key" did not create a URL redirect either, yet, at the same time, some products were behaving as expected.

It seems that the indexer/reindexing process was running correctly. The problems I was experiencing were due to irregularities in the Magento URL rewrite processes rather than the Indexing processes.

The "real" problem is more correctly addressed here: URL Rewrites in 1.14 (EE) Don't Seem to be Created or Acted Upon for All Products along with my solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.