0

Can someone tell me which patches are needed for Magento v1.8.1.0?

The following list of patches show up on the downloads page:

  • 2747
  • 2619
  • 2725
  • 3941
  • 1868 FAILS
  • 4334 FAILS
  • 1533
  • 5344
  • 5994
  • 6237
  • 6285
  • 6482
  • 7616 FAILS
  • 7405

1868, 4334 or 7616 all fail on stock Magento v 1.8.1.0. All of these make changes to Mage_Usa, which as you see below is not the version the patches are expecting.

For example viewing 1868 we see the following:

diff --git app/code/core/Mage/Usa/etc/config.xml app/code/core/Mage/Usa/etc/config.xml
index 0174a7b..e040af8 100644
--- app/code/core/Mage/Usa/etc/config.xml
+++ app/code/core/Mage/Usa/etc/config.xml
@@ -28,7 +28,7 @@
 <config>
     <modules>
         <Mage_Usa>
-            <version>1.6.0.1</version>
+            <version>1.6.0.1.1.2</version>
         </Mage_Usa>
     </modules>
     <global>

The problem here is that this will never match on v 1.8.1.0 because the Mage_Usa version included is 1.6.0.3 NOT 1.6.0.1

<config>
    <modules>
        <Mage_Usa>
            <version>1.6.0.3</version>
        </Mage_Usa>
    </modules>

So it would be very helpful to me if someone could explain which patches are required for v. 1.8.1.0

Thanks!

  • Compare the release dates of that Magento version and all the patches. You'll easily be able to see which patches to install. – Prateek Feb 2 '16 at 7:01
  • Where do I find the release date? According to the download page: ver 1.8.1.0 - Added Dec 11, 2013 All patches listed on the downloads page have release dates in 2014, except for 1868, which patch SUPEE-4334 states is a prerequisite. Note: For versions earlier than Magento Community Edition 1.9.x, the new patches need to be installed on previous USPS patch (SUPEE-1868) issued in 2013. Please make sure the patch SUPEE-1868 is installed first. So one would assume all the patches listed above are required, but again any having to do with Mage_Usa fail. – Brad Feb 2 '16 at 16:34
2

It looks like stock Magento CE 1.8.1.0 already has patch SUPEE-1868 and part of SUPEE-4334 applied. You should be able to cleanly install SUPEE-4291 (which says it's for CE 1.9.x by the way) to get the parts of the patch that weren't included in the stock codebase. Once that's done, proceed with patches SUPEE-6237 and SUPEE-7616.

  • Yes, smart man! – NendoTaka Jul 28 '16 at 20:28
2

For required security patches, please refer to this inofficial patch matrix.

Version   SUPEE-7405  SUPEE-6788  SUPEE-6482  SUPEE-6285  SUPEE-5994  SUPEE-5344  SUPEE-3762  SUPEE-1533  APPSEC-212
1.8.1.0   Required    Required    Required    Required    Required    Required    Not Req.    Required    Required

All other patches are not required, most of the time they fix something for USPS, and you only need to apply them if this concerns you.

  • With grep '|' app/etc/applied.patches.list you will get a nice overview – Frank Groot Sep 29 '17 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.