0

I'm building my project on OSX El Capitan 10.11.3 with MAMP v3.5 and php 5.6.10.

I downloaded CE 2.0.1 with sample data and it worked fine.

However, when I was trying to upgrade to 2.0.2 released last week, it failed on readiness check, saying that my php version is 5.5.30 (system default) and two extension "intl","mcrypt" are missing. enter image description here

The weird thing is, I've already added the php5.6.10 path to env, and passed previous readiness check during the web installation. Did anyone run into the same issue?

Any help will be appreciated.

0

If u've already installed these modules, try to copy mcrypt.dll and intl.dll to folder xampp/apache/ directory (where apache's dlls)

  • It seemed that magento always looks up default php files, namely those under /usr/bin/, regardless of the env settings. So I created a symlink /etc/php.ini pointing to my local php directory and install the missing extensions, and it worked. Though the details are different, thanks for the advice nonetheless. – Tienyi Chi Feb 3 '16 at 5:55
  • @TienyiChi can you post a fully explained answer of your solution to help others – Claudiu Creanga Apr 1 '16 at 23:55
0

Ok, here's what I found:

A solution stack such as MAMP, AMPPS... etc usually runs on their own php pack, which allowed me to pass the extensions check upon installing Mage2. But when it comes to upgrading, the system somehow still look up /etc/php.ini, which is the old version, and failed.

To solve this I replace /etc/php.ini with a symlink pointing to the "real" ini in the pack.

php.ini -> /Applications/MAMP/bin/php/php5.5.26/conf/php.ini

and that was it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.