1

I can't Access system -> Configuration -> Sales -> Payment methods after server migration. its shows server error 500

log details:

2016-02-01T10:38:27+00:00 ERR (3): Notice: Undefined index: httponly  in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 96

2016-02-01T10:38:27+00:00 ERR (3): Notice: Undefined index: secure  in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 98

2016-02-01T10:38:27+00:00 ERR (3): Notice: Undefined index: domain  in /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 100

2016-02-01T10:38:29+00:00 ERR (3): Warning: simplexml_load_string(): Entity: line 90: parser error : Start tag expected, '<' not found  in /var/www/vhosts/domain.com/httpdocs/lib/Varien/Simplexml/Config.php on line 510

2016-02-01T10:38:33+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_BLOWFISH - assumed 'MCRYPT_BLOWFISH'  in /var/www/vhosts/domain.com/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 56

2016-02-01T10:38:33+00:00 ERR (3): Notice: Use of undefined constant MCRYPT_MODE_ECB - assumed 'MCRYPT_MODE_ECB'  in /var/www/vhosts/domain.com/httpdocs/lib/Varien/Crypt/Mcrypt.php on line 60

link : index.php/admin/system_config/edit/section/payment/key/

enter image description here

  • Enable logging and check your log files. Post their content as an edit to the question. Only then, it will be possible to diagnose the issue. – Prateek Feb 1 '16 at 9:46
  • @Prateek i updated the log details. am using Centos6 – Anto sujesh Feb 1 '16 at 10:41
  • Looks like mcrypt is not installed in your new server. Check with the your hosting and get it installed. This link might help further : magestore.com/magento-installation/… – Prateek Feb 1 '16 at 10:48
  • @Prateek i understood my problem clearly. thx u for ur support – Anto sujesh Feb 1 '16 at 10:52
1

Looks like mcrypt is not installed in your new server. Check with the your hosting and get it installed. This link might help further : http://www.magestore.com/magento-installation/test-server-for-compatibility-with-magento

1

Please install mcrypt. You can do the following steps.

Sudo apt-get install php5-mcrypt

And then restart your apache sever.

Sudo service apache2 restart

1

i follow the following steps to install mcrypt.

# yum install epel-release

Then, i installed the php-mcrypt module:

# yum install php-mcrypt

finally i restarted my server. now its working fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.