1

This question is regarding image upload problems in back-end only :

Problem 1:

I cannot Upload image from the Magento Admin panel(live sever) , some times im getting error:

SSL Error: Invalid or self-signed certificate

sometimes :

  • No error upload progress halts between 50 - 100 %
  • the image upload progress just halt at 100%
  • Image uploads perfectly
  • http error

Im uploading the image without any third party module/extension i had found lot of questions regarding SSL error while googling.But none of this solved my problem.

I had changed permission of media,var & tmp folder(including sub folders) permission to 775. The Same project is working perfectly on localhost.

Problem 2:

I cannot find the image preview for the images that are newly uploaded

After inspecting the source i found there is no image uploaded here:

 /media/tmp/catalog/product/h/a/some-image.jpg

But there is no issues with images on frontend

enter image description here

I believe that these two problem has some relation together. I had recently upgraded from 1.7

  • Magento is using a Flash object for the file uploader which blows chunks when it detects self-signed certificates, has to deal with .htaccess password protected development environments, or http server security certificate misconfigurations. – Fiasco Labs Jan 31 '16 at 19:28
  • @Fiasco Labs im not using secure url. & does this aapplicable to http connection? – Shan Feb 1 '16 at 20:02
  • i still .. waiting for an answer :( – Shan Feb 6 '16 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.