I upgraded to magento and now, when I try to upload a product image, the back-end shows the white square with a "?" in the centre. I attach a screenshot. Can you help me to solve this problem? enter image description here

  • @FabianBlechschmidt I don't find a solution in that topic.
    – stsnow
    Jan 30, 2016 at 12:15
  • Check for the permissions on the files, if they are 640 and 777 solves your problem then the problem is in the patch. Jan 30, 2016 at 12:16
  • Except that I don't get the ?", I am experiencing the issue on and changing to 777 did not help. After rollover the screen shows a image entry row but no image. If I try again it adds another empty row.
    – Dan
    Jan 30, 2016 at 14:43
  • I changed the folder to 777 and it didn't work. You must have been talking about Liam's answer in that link!
    – Dan
    Jan 30, 2016 at 16:24

1 Answer 1


This is less than a full answer but i looked thru the link Fabian put in comments and found an answer that I tried and it worked. Liam's answer link with comments

Here's a problem I've found when patching Magento CE with SUPEE-7405. It replaces the line:

chmod($destinationFile, 0777);


chmod($destinationFile, 0640);

in the file lib/Varien/File/Uploader.php

This stopped my images displaying in the back end, since this file permission should actually be 644. Is there any reason this has been set to 640?

When I changed the line 219 to 0777 from 0640 it worked. Until I have a better understanding I'll use this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.