0

SO last night I had to delete alot of products to start over and now Catalog URL Rewrites Index is stuck in processing. With some research I saw that this might be able to be handled via SSH but I do not have access to SSH on this server. Any ideas?

  • what server you are using ? is it shared hosting ? if so you can contact them. – Baby in Magento Jan 29 '16 at 18:37
  • shared hosting server. I have WHM access but SSH is disabled – Tommy Jan 29 '16 at 18:50
  • check with hosting team and inform them to enable if possible – Baby in Magento Jan 29 '16 at 18:57
-1

You might try changing status in index_process table for catalog_url entry to 'pending'. After that Magento should allow you to reindex it again. If it will hang, truncate core_url_rewrite table before indexing again.

  • I changed the table to pending, reindexed and same error. Tried truncating and got a lock timeout – Tommy Jan 29 '16 at 19:42
  • Try to run this SQL: FLUSH TABLE core_url_rewrite; Then try truncating again. – maquowicz Jan 29 '16 at 19:47
  • Usually when this happens qucik mysql restart is helping to solve the problem. Without ssh its problematinc. If flushing won't help you, you may try to follow "FORCE UNLOCK for locked tables in MySQL:" procedure stackoverflow.com/questions/5836623/… – maquowicz Jan 29 '16 at 19:57
  • I have ssh access now.. what should I do. I ran the php reindex on all the tables. but once it got to the rewrite index it took so long that putty timed out and I dont know if it finished – Tommy Jan 29 '16 at 21:08
  • check in backend about reindexing status – Baby in Magento Jan 31 '16 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.