0

Can somebody help me, pardon me i'm new to magento.. i want to use https://github.com/abraham/twitteroauth as external lib i put it in magento 1.9 lib directory

the folder tree like:lib\TwitterOAuth\src

then i use it in a .phtml page and its controller in \design\frontend\base\default\template

then i include the class:

require Mage::getBaseDir('lib') . '/TwitterOauth/autoload.php';
use Abraham\TwitterOAuth\TwitterOAuth;

Like 2 weeks ago it was running smoothly i could use the class until the user logged in and calledback, and i didn't face error like this. i don't how now its throwing error. why varien autoload take part on this..

0

It was my own fault actually to have it set in Developer Mode by commenting the conditional if in index.php.

//if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) {
    Mage::setIsDeveloperMode(true);
//}

I was testing something, the fix is just by uncommenting it back. I guess have to becareful on this one. lol

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.