1

I ran the 6788 patch and it reported that everything had succeeded, everything looked fine on the front end of the site.

However on closer inspection the permissions tables had not been created and the admin pages to edit block and variable permissions had not been enabled either.

The error logs have this in:

exception 'Mage_Core_Exception' with message 'Can't retrieve entity config: admin/permission_block' in \app\Mage.php:595
Stack trace:
#0 \app\code\core\Mage\Core\Model\Resource.php(272): Mage::throwException('Can't retrieve ...')
#1 \app\code\core\Mage\Core\Model\Resource\Db\Abstract.php(284): Mage_Core_Model_Resource->getTableName('admin/permissio...')
#2 \app\code\core\Mage\Core\Model\Resource\Db\Abstract.php(247): Mage_Core_Model_Resource_Db_Abstract->getTable('permission_bloc...')
#3 \app\code\core\Mage\Core\Model\Resource\Db\Collection\Abstract.php(155): Mage_Core_Model_Resource_Db_Abstract->getMainTable()
#4 \app\code\core\Mage\Core\Model\Resource\Db\Collection\Abstract.php(192): Mage_Core_Model_Resource_Db_Collection_Abstract->getMainTable()
#5 \app\code\core\Mage\Core\Model\Resource\Db\Collection\Abstract.php(135): Mage_Core_Model_Resource_Db_Collection_Abstract->_initSelect()
#6 \app\code\core\Mage\Core\Model\Config.php(1354): Mage_Core_Model_Resource_Db_Collection_Abstract->__construct(Array)
#7 \app\code\core\Mage\Core\Model\Config.php(1386): Mage_Core_Model_Config->getModelInstance('admin_resource/...', Array)
#8 \app\Mage.php(491): Mage_Core_Model_Config->getResourceModelInstance('admin/block_col...', Array)
#9 \app\code\core\Mage\Admin\Model\Block.php(79): Mage::getResourceModel('admin/block_col...')
#10 \app\code\core\Mage\Core\Model\Email\Template\Filter.php(172): Mage_Admin_Model_Block->isTypeAllowed('catalog/navigat...')

I tried creating the tables manually, but this did not help.

I also tried setting the admin_setup version back to 1.6.1.1 to try to get the upgrade script to run again, but this seemed to have no effect either.

This is on Magento 1.8.1

  • 1
    Please check if the setup script that creates these tables is readable by the webserver user, maybe there is a permission issue. – Fabian Schmengler Jan 26 '16 at 20:00
  • did you ever figure this one out. i am having same problem and totally stumped. – Randy F Nov 11 '16 at 21:08
0

Had similar issues, solved by adding a few lines on app\code\core\Mage\Admin\etc\config.xml from the old config.xml file.

<permission_variable> <table>permission_variable</table> </permission_variable> <permission_block> <table>permission_block</table> </permission_block>

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.