I installed the last Magento version and i tried to install a extension via Magento Connect in admin painel and i got the error:

Unknown cipher in list: TLSv1

I tried this solution:

In file downloader/lib/Mage/HTTP/Client/Curl.php find the code

$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');

and then change to

if(isset($var)){$this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');}

I didn't find the code above in file curl.php but i can find that code in Magento v1.9.2.2 in curl.php.

How can i solve this? Thanks.

  • Upgrade your cURL extension
    – scrowler
    Commented Jan 26, 2016 at 5:12
  • @RobbieAverill why he needs to do this??
    – MagenX
    Commented Jan 26, 2016 at 9:28
  • Because it looks like cURL doesn't recognise the TLSv1 cipher, which it should, so it's probably an old version
    – scrowler
    Commented Jan 26, 2016 at 9:57
  • Thanks for answered Robbie, as you said, i found an article that said that this is a bug in Magento as it relates to centOS servers with older legacy curl programs and to fix it, in curl.php file, i replaced this code: $this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1'); to this: $this->curlOption(CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1); and now it's working as well. Actually, my Magento store is running with this settings: CentOS 6.7 Curl 7.12.1 PHP 5.2.17 Thanks for the help
    – Michel
    Commented Jan 27, 2016 at 14:04

1 Answer 1


latest magento files:

[root@gun magento]# grep -i -r  TLS downloader/*
downloader/lib/Mage/HTTP/Client/Curl.php:        $this->curlOption(CURLOPT_SSL_CIPHER_LIST, 'TLSv1');
[root@gun magento]# php -r "require 'app/Mage.php'; echo Mage::getVersion();"[root@gun magento]#

you have probably some cache or customizations, or broken installation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.