1

Using php 5.6.17-1+deb.sury.org~wily+2 on Ubuntu 15.10 with Apache2 and MariaDB. Fully Functional Magento CE 2.0.0, But now with this Release of CE 2.0.1 I went to upgrade using the Admin backend System Upgrade. I get all the way to Readiness Check Everything passes But always_populate_raw_post_data = 0.

knowingly that this error should not occur because all 3 php.ini files have it set to =-1 which was done before installing Magento CE 2.0.0.

After looking at Google Chromes Inspect/Network elements this is the displayed error.

{responseType: "error", data: {always_populate_raw_post_data: {,…}}}
data: {always_populate_raw_post_data: {,…}}
always_populate_raw_post_data: {,…}
error: true
helpUrl: "http://php.net/manual/en/ini.core.php#ini.always-populate-    settings-data"
message: "Your PHP Version is 5.6.17-1+deb.sury.org~wily+2, but always_populate_raw_post_data = 0.↵             $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0.↵             This will stop the installer from running.↵         Please open your php.ini file and set always_populate_raw_post_data to -1.↵             If you need more help please call your hosting provider."
responseType: "error"

Because i see the {,…} and not the = 0 which means I did not change my ini tells me that something isnt right. And I don't see anyone else having this issue so I believe the problem is on my end some where i did something wrong but It installing perfectly.

Maybe my crontab is affecting the information being pulled correctly? here is my ROOT user Crontab.

*/1 * * * * php -c /etc/php5/fpm /var/www/html/magento2/bin/magento cron:run
*/1 * * * * php -c /etc/php5/fpm /var/www/html/magento2/update/cron.php
*/1 * * * * php -c /etc/php5/fpm /var/www/html/magento2/bin/magento setup:cron:run
*/1 * * * * php -c /etc/php5/fpm /var/www/html/magento2/bin/magento indexer:reindex

I have also tried

*/1 * * * * php /var/www/html/magento2/bin/magento cron:run
*/1 * * * * php /var/www/html/magento2/update/cron.php
*/1 * * * * php /var/www/html/magento2/bin/magento setup:cron:run
*/1 * * * * php /var/www/html/magento2/bin/magento indexer:reindex

I have also tried adding php flags in the .htaccess files with no luck.

Some one please help? what am i forgetting.

-1

Found a Work Around for the error always_populate_raw_post_data = 0 Setting permissions to the entire Magento Directory to 777 using

find . -type d -exec chmod 777 {} \;
find . -type f -exec chmod 777 {} \;

Allowed me to proceed to the next step and create a backup of the system. I have 31K products so its gonna be quite a while for the backup but I wanted to post this work around for anyone else having this issue.

  • That's not a good solution though because Magento is going to generate static files (at least) with different permissions. You're going to run into issues later on. I see you're modifying your crontab but you might be doing it incorrectly. Create a phpinfo.php in your web server docroot and look for the value of Loaded Configuration File. That tells you which php.ini to modify. also, you must restart your web server after changing php.ini – Steve Johnson Jan 22 '16 at 14:54
  • @SteveJohnson I have already created a phpinfo.php file on the server to test the configuration file against the required modules and setting for magento 2.0 to run properly. my setting are correct in the php.ini file. The problem exists in some file that Magento uses to check against the php settings doesn't have proper permissions to view that its -1 and not 0. if you look in my log Magento is saying always_populate_raw_post_data: {,…} which is incorrect some how Magento doesn't have access to read that file. – acidreian Jan 22 '16 at 22:04
  • If you open var/.setup_cronjob_status you should be able to see the full json file with the error. Also, your cron is run using php-cli, so the php.ini file may not be the same as in phpinfo on the web. Check which ini file is loaded when you run php -i on the command line. Also, 777 is unsafe, and will leave your store vulnerable to attacks. Please do not recommend this permissions. Checkout devdocs.magento.com/guides/v2.0/install-gde/prereq/… and devdocs.magento.com/guides/v2.0/install-gde/prereq/… to properly set permissions. – Maddy Apr 4 '16 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.