0

We have Magento CE 1.9.1.0. During the new 7405 patch install, we got some patch errors:

patching file app/code/core/Mage/Admin/Model/Observer.php
Hunk #2 FAILED at 43.
Hunk #3 succeeded at 68 with fuzz 2.
1 out of 3 hunks FAILED -- saving rejects to file app/code/core/Mage/Admin/Model/Observer.php.rej
patching file app/code/core/Mage/Admin/Model/Redirectpolicy.php
patching file app/code/core/Mage/Admin/Model/Resource/User.php
patching file app/code/core/Mage/Admin/Model/User.php
patching file app/code/core/Mage/Adminhtml/Block/Sales/Order/View/Tab/History.php
patching file app/code/core/Mage/Adminhtml/Block/Widget/Grid.php
patching file app/code/core/Mage/Adminhtml/Helper/Catalog/Product/Edit/Action/Attribute.php
patching file app/code/core/Mage/Adminhtml/Helper/Sales.php
Hunk #1 FAILED at 120.
1 out of 1 hunk FAILED -- saving rejects to file app/code/core/Mage/Adminhtml/Helper/Sales.php.rej
patching file app/code/core/Mage/Adminhtml/Model/System/Config/Backend/File.php
patching file app/code/core/Mage/Adminhtml/Model/System/Config/Backend/Image.php
patching file app/code/core/Mage/Adminhtml/Model/System/Config/Backend/Image/Favicon.php

What can I do to help resolve this? Any ideas?

  • 6
    It sounds like you may have missed a prior patch - see magento.stackexchange.com/questions/98301/… – Aric Watson Jan 21 '16 at 17:43
  • Verify that you downloaded the correct patch file for the version of Magento you are running. If you have the patch for a newer version than you are running, then you will get this error. – coreyg Jan 22 '16 at 5:34
0

Magento patches require original files. If they have been modified manually by you, or you have missed any prior patch files this error shows up.

These particular files are the ones that do not match what it expected:

app/code/core/Mage/Admin/Model/Observer.php (lines 43, and 68)
app/code/core/Mage/Adminhtml/Helper/Sales.php (line 120)

If you have modified these files manually, then replace them with the originals you hopefully had backed up.

If you have not installed SUPEE-6788, install it first before installing this patch, if that throws more errors like this keep going down the line of patches until it does not.

A successful patch install will look like this:

Checking if patch can be applied/reverted successfully...
Patch was applied/reverted successfully.
  • We stay on top of patches. Anyway, i tried to reinstall these and got messages saying they were already installed: 5344, 1533, 5994, 6285, 6284, 6788. We haven't made any edits ourselves, either. What else could I be missing? Can I just copy the new version of the files without running the .sh file? – Ron V Jan 21 '16 at 21:10
  • A detailed list of your installed patches is located in app/etc/applied.patches.list, it will contain all the patches that have been installed and the files they modified. If you have all the patches installed since 1.9.1.0 release, and do not see these problem files listed there then they have most likely be modified by some other source. Try comparing them with original 1.9.1.0 source files at diffchecker.com/diff and see if they are any different. You can get 1.9.1.0 source files from the archive: magentocommerce.com/download – wss web Jan 21 '16 at 22:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.