1

I have three custom attributes that allows me to make configurable products and create simple products to associate with them when I use the admin interface.

However using Magmi I see the following problem after import.

(Magmi plugins used: AttributeCleanup, Magmi_OptimizerPlugin, Magmi_ReindexingPlugin, CategoryImporter,ValueTrimItemProcessor, Magmi_ConfigurableItemProcessor)

In the Super product attributes configuration section I see a lot of Option: false where I would normally expect to see the option values of the associated simple products. E.g. Option: Red or Option: S42

Option: false where I would expect the option value

As you can see the simple products has proper values assigned for the custom attributes:

Simple products with their custom attributes

If I scroll up to the Quick simple product creation and create a new product it shows up correctly in the Super product attributes configuration section.

What am I doing wrong?

UPDATE: I noticed, that despite that the grid states that the value is set to Red and Dotted for all my simple products, that when I click edit on one of them it shows that the attributes are actually not set on the products. How can it be set and not set at the same time?

In 'edit' options are NOT set

I've noticed that on the rendered page there is a difference in the JSON embedded in the hidden input for each row. The imported rows has a value_index value corresponding to the value column in eav_attribute_option_value whereas the one I created in the admin interface has a value_index value corresponding to the value_id column in eav_attribute_option_value. But I would assume that the Magmi plugin would import this correctly?

UPDATE 2: It seems that the attributes created for the simple products during import are linked incorrectly. See the table catalog_product_entity_varchar. The value should contain the option id but it contains the actual option value S40 unlike the second row that is created through the UI:

Two attribute-product links one from import one from ui

UPDATE 3: I found the problem and a solution. See answer.

1

The clues in UPDATE 2 gave me idea to look up the backend_type of the attributes. Don't ask me why just intuition. Anyway they were set to varchar. I changed them to int and that solved the problem. Now the attribute values are recorded correctly during import.

After creating an attribute through the UI it seems that configurable attributes are created with backend_type int for dropdown/select. That's just how Magento works.

Magmi would import the attributes and store them in catalog_product_entity_varchar and store the value rather than the id. Interestingly enough Magento sort of worked using varchar for the option values created in the UI, but as soon as ran indexers things started disappearing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.