1

On January 17, 2016, USPS made several changes to their services, rates, and package names. The updates are reflected in this release, and include the following changes:

Standard Post renamed “Retail Ground” Flat Rate Box for Priority Mail Express Eliminated Because the USPS changes are not included in the security patch, earlier versions of Magento must be updated by installing the SUPEE-7616 patch. The patch is available for download in the same location as the security patch bundle.

I haven't enabled USPS from my admin. I was wondering if I need to install this patch.

Reason I am asking this is because I haven't installed earlier version of patches of USPS. To install this patch I will have to install them all.

2

It would be wise to patch regardless if you use the service as the files in question could be used to leverage admin access.

While there are no confirmed attacks related to the security issues, certain vulnerabilities can potentially be exploited to access customer information or take over administrator sessions.

2

Looking at the patch it looks to be removing the Standard Post option and adding Retail Ground there is no actual security improvements in the SUPEE-7616 e.g

+++ app/code/core/Mage/Usa/Model/Shipping/Carrier/Usps.php
@@ -544,7 +544,7 @@ class Mage_Usa_Model_Shipping_Carrier_Usps
                  '1'      => Mage::helper('usa')->__('Priority Mail'),
                  '2'      => Mage::helper('usa')->__('Priority Mail Express Hold For Pickup'),
                  '3'      => Mage::helper('usa')->__('Priority Mail Express'),
-                 '4'      => Mage::helper('usa')->__('Standard Post'),
+                 '4'      => Mage::helper('usa')->__('Retail Ground'),
                  '6'      => Mage::helper('usa')->__('Media Mail Parcel'),
                  '7'      => Mage::helper('usa')->__('Library Mail Parcel'),
                  '13'     => Mage::helper('usa')->__('Priority Mail Express Flat Rate Envelope'),

If you are using USPS shipping service then i would suggest to apply this patch.

1
  • Haven't noticed any issues yet, we don't use the affected services that have either been renamed or removed. – Fiasco Labs Jan 21 '16 at 2:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.