2

This is not a new question, but. nowhere I'm able to find the answer to this question.

When I reindex Catalog URL Rewrites, my custom rewrites get deleted/overwritten(???). Below is an image of the settings, what is wrong with these settings?

Magento = 1.8.0.0 but it was also occurring with the previous version.

enter image description here

  • Did you find a fix for this problem? – user9265 Jun 17 '14 at 16:16
  • 0 down vote I have the same problem. Has anybody tried the solution above? Thanks OZ.asked by by user24167 – Amit Bera Apr 9 '15 at 1:06
2

Yes. This is a commonly encountered problem with magento URL rewriting system.

A short term solution can be to create the required system URL (using category or cms page) and then edit it.

System URLs are not deleted upon re-indexing.

  • So, just to make sure, if I change the type option to system instead of custom (as it is now) my problem will be over? – Bob van Luijt Oct 22 '13 at 12:56
  • Yes. That should solve the problem. – mosiac Oct 22 '13 at 14:42
  • strange though, one would expect that "custom" would be the thing they don't erase. In a few days I'll check it out and post the results here. Thanks man! – Bob van Luijt Oct 22 '13 at 20:27
2

I think the best solution would be to set the redirect method of the regarding system rewrite (ID path "category/YOUR_ID", target path "catalog/category/view/id/YOUR_ID") to "permanent (301)" and then create a custom rewrite rule with the request path "catalog/category/view/id/YOUR_ID" to fit your needs. Saw it here and translated it into German here.

Survives reindexing, tested in Magento CE 1.9.

1

I'm not 100% sure about this, but I think It has something to do with the ID Path you provided. Id paths like category/* and product/* are considered to be category/product rewrites. When reindexing these rewrites are either deleted or overwritten by the real rewrites for that category or product.
Try changing the ID Path to some random value like this 1f129c42de5e4f043cbd88ff6360486f then reindex, and see if the error reproduces.

  • Hi Marius, thanks for the answer. But this is not it. Reason: When i try a random ID Path the link goes to (in this case) /catalog/category/view/s/customer-service/id/21/ – Bob van Luijt Oct 22 '13 at 10:14
1

This was driving me absolutely bonkers until I figured out a nice little work-around.

I create my new object (in my case it was a category for the top nav I go to URL Rewrite and note the ID Path of the new category I delete the system generated URL Rewrite I create a custom Rewrite specifying the ID Path of the deleted object, The request path, and then the path to the desired URL I then go to phpmyadmin > core_url_rewrite and find my newly created custom Rewrite I change the store_id to 0 (not changing anything else) I then go back to Magento and run a reindex. This creates a new system generated Rewrite with a higher url_rewrite_id (see in phpmyadmin > core_url_rewrite table) I then create my page with the desired path Reindex / flush caches and presto.. my top nav now has a menu item to my new page.

1

I've experienced this same problem. Magento does not support "custom url rewrites" in admin panel for many reasons.

You have 3 options: Easiest to Hardest

  1. Utilize a Static block
  2. RewriteEngine On. Add your exception (.htaccess)
  3. Interpret & Modify (index.php)

Any other method will revert on Reindex

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.