2

I'm working on a site running Magento CE 1.9.2.2. In the process of applying a new theme and as I'm clicking through the site, I'm running into an anomaly.

Every page on the site is using the new, correct theme however when I attempt to view a category page, it falls back to the base theme. The layout XML calls for the file 3columns.phtml so I then proceed to verify there is a 3columns.phtml file located in the template/page directory of my new theme. There is and all permissions are correct but it still won't load.

I then proceed to the Magento admin panel to see if that specific category or parent categories has a specified custom design - they don't. I then go through my page.xml and local.xml files for my theme, clear all cache, try new browsers and still the category page on my site loads the base theme.

So to take a more diagnostic approach, I would like to know what is happening that makes the theme fallback to Magento's base theme JUST FOR THE CATEGORY PAGE. Is there a way to log what is happening or not happening? I'm hoping to potentially catch the error or even the call for custom XML that I just can't seem to find.

  • check if you are overwriting the layout in local.xml, of the applied theme – Dimag Kharab Jan 20 '16 at 12:08
1

I assume you can hook into \Mage_Core_Model_Design_Package::setTheme or \Mage_Core_Model_Design_Package::setPackageName and check what is going on.

Either with xdebug or Mage::log()

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.