5

I'm getting this issue after run grunt exec:<theme>, this shows up:

Processed Area: frontend, Locale: en_US, Theme: Ids/prueba, File type: less. [Magento\Framework\Exception\FileSystemException]

Cannot create a symlink for "/usr/local/devs/magento2/htdocs/vendor/magento/theme-frontend-blank/web/css/source/_reset.less" and place it to "/usr/local/devs/magento2/htdocs/pub/static/frontend/Ids/prueba/en_US/css/source/_reset.less" Warning!file_get_contents(/usr/local/devs/magento2/htdocs/var/cache//mage-tags/mage---e39_INTERCEPTION): failed to open stream: No such file or directory

dev:source-theme:deploy [--type="..."] [--locale="..."] [--area="..."] [--theme="..."] [file1] ... [fileN]

Exited with code: 1. Warning: Task "exec:prueba" failed. Use --force to continue.

And after i run grunt refresh, shows the same after it cleans all the paths.

Now, running the command for the bin/magento dev:source-theme:deploy got this:

Processed Area: frontend, Locale: en_US, Theme: Magento/luma, File type: less.

[Magento\Framework\Exception\FileSystemException]

Cannot create a symlink for "/usr/local/devs/magento2/htdocs/vendor/magento/theme-frontend-blank/web/css/source/_reset.less" and place it to "/usr/local/devs/mage
nto2/htdocs/pub/static/frontend/Magento/luma/en_US/css/source/_reset.less"

dev:source-theme:deploy [--type="..."] [--locale="..."] [--area="..."] [--theme="..."] [file1] ... [fileN]

I was triyng to fix this by following a lot of instructions on other issues already, nothing worked.

Any ideas why this might be happening? I have a VM configured running of Ubuntu 14.04.3 LTS , and have node 5.4.1 with npm 3.3.12

2

I asked for a bounty, but these seems to be fixed after re run chmod 777 to pub.

Its very hard to develop in magento 2.

Edit:

Open up app/etc/di.xml and find the virtualType name="developerMaterialization" section. In that section you'll find an item name="view_preprocessed" that needs to be modified or deleted. You can modify it by changing the contents from Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink to Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

Delete the files under pub/static to get rid of any existing symlinks. You may want to be careful not to delete the .htaccess file.

  • Then I suggest you accept your answer. Although having all your files in a 777 mode isn't advisable. There might be another issue. – Julien Lachal Apr 11 '16 at 13:03
  • I cannot accep answer since I am not asker. – Flakerim Apr 14 '16 at 19:04
  • 777 is temporary. – Flakerim Apr 14 '16 at 19:05
  • @ezequiel-alba did this worked? Can you confirm? – Flakerim Apr 16 '16 at 10:17
  • @Flakerim a little late, but yeah at that moment that works! – Ezequiel Alba Aug 21 '18 at 22:15
0

Maybe this helps

Execute the following command in your terminal, adapt Placeholders accordingly:

VBoxManage setextradata YOURVMNAME VBoxInternal2/SharedFoldersEnableSymlinksCreate/YOURSHAREFOLDERNAME 1

And verify it by the command VBoxManage getextradata YOURVMNAME enumerate

0

I had the same issue with grunt throwing up this error when running grunt exec: <theme> and I realised that I didn't run my command prompt in administrator mode.

Hopefully this might help someone - obviously it might not be the contributing factor, but you never know!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.