1

Was trying to create an admin module and got the helper_class not found error

Fatal error: Class 'my_module_Helper_Data' not found in /home/myweb/public_html/app/Mage.php on line 547

But now I can't access admin panel after deleting the files I uploaded including the app/etc/modules/my_module.xml.

Tried emptying var/cache but still no luck :/!

1

Weirdest bug I've encountered and just to be clear it was a cache issue and this is how I resolved it:

class my_module_Helper_Data extends Mage_Core_Helper_Abstract
{


}   

added this code to the bottom of core Mage.php, logged into admin and refreshed cache then removed it back off the bottom of the core Mage.php.

  • What isthe general file path to get to the Mage.php file? – CodingMageSheen Dec 7 '16 at 20:21
  • 1
    I accessed it trough admin panel it was invisible to my text editor! THANK YOU FOR THIS it saved my ass – CodingMageSheen Dec 7 '16 at 21:10
  • glad it helped :) – Robert Pounder Dec 8 '16 at 9:03
0

Your helper is definitely referenced somewhere.

If disabling the module by setting active to false in the app/etc/modules/my_module.xml file does not work, that means the helper is referenced in a file which is not related to the module (template for instance).

  • No it's not I had a folder all to itself so I removed all the files it added so I could revert with no worries. – Robert Pounder Jan 19 '16 at 11:12
  • (locally that is) – Robert Pounder Jan 19 '16 at 11:12
  • Do you have compilation enabled ? Could you post your module config.xml file ? – Raphael at Digital Pianism Jan 19 '16 at 11:14
  • Don't have compilation enabled, the module 100% is not referenced anywhere else, it was when I refreshed the cache it happened – Robert Pounder Jan 19 '16 at 11:16
  • and since the module's config isn't even on the server anymore what difference would it make? – Robert Pounder Jan 19 '16 at 11:16
0

Open file [MAGENTO_ROOT]/includes/config.php

define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

Change these to following

#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

Hope it helps you

  • they are already commented – Robert Pounder Jan 19 '16 at 11:15
  • Check it by disabling local modules from app/etc/local.xml. – Rohit Kundale Jan 19 '16 at 11:22
  • did that and still same thing – Robert Pounder Jan 19 '16 at 11:25
  • its definitely a caching issue just don't understand why it's not clearing cache, double checked ftp details etc about 20 times lol – Robert Pounder Jan 19 '16 at 11:25
  • Check manually deleting var/cache directory – Rohit Kundale Jan 19 '16 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.