1

I am Trying To create a Simple Module. It's Found 404 page Error.

My config file in app/etc/modules/Codefire_Mymodule.xml

<?xml version="1.0"?>
<config>
    <modules>
        <Codefire_Mymodule>
            <actve>true</actve>
            <codePool>local</codePool>
        </Codefire_Mymodule>
    </modules>
</config>

Create Controllrer in app\code\local\Codefire\Mymodule\controllers\IndexController.php

<?php
class Codefire_Mymodule_IndexController extends Mage_Core_Controller_Front_Action
{
    public function indexAction()
    {
        echo "Hello tuts+ World";
    }
     public function testAction()
    {
        echo "test action";
    }
}

And Create My Plugin xml file in app\code\local\Codefire\Mymodule\etc\config.xml

<?xml version="1.0"?>
<config>
    <modules>
        <Codefire_Mymodule>
            <version>0.1.0</version>
        </Codefire_Mymodule>
    </modules>
    <frontend>
        <routers>
            <mymodule>
                <use>standard</use>
                <args>
                    <module>Codefire_Mymodule</module>
                    <frontName>mymodule</frontName>
                </args>
            </mymodule>
        </routers>
    </frontend>
</config>

URL: index.php/mymodule/index/index When I am Write testing in magento in display 404 page error. can You Tell me What's Issue?

4
  • paste your mention file code too.. Jan 19, 2016 at 6:39
  • check your module is listed in system > configuration > advanced Jan 19, 2016 at 7:02
  • Did you clean the cache? Jan 19, 2016 at 7:45
  • i have already clean the cache and also showing in system > configuration > advanced but is not working!
    – rajeevG
    Jan 19, 2016 at 7:51

2 Answers 2

5

You have done,a simple mistake

<actve>true</actve>

should be

<active>true</active>'

The tag: actve should be active

Edit: If you use linux system,you should check File & folder Name space does not contain space

9
  • Thanks but still is not working
    – rajeevG
    Jan 19, 2016 at 6:51
  • Clear your cache or disable them Jan 19, 2016 at 6:54
  • Yes, i have already do this but is not working!
    – rajeevG
    Jan 19, 2016 at 6:56
  • 1
    i have check ur extension at my system.it is working perfectly.Please clear magento cache
    – Amit Bera
    Jan 19, 2016 at 7:33
  • Really Amit Bera i don't know why is not working my end i access this url : domaina.com/project/index.php/mymodule
    – rajeevG
    Jan 19, 2016 at 8:11
0

Looks like a web server configuration problem you shouldn't have the index.php part in the url.

Try to configure the same store and module over a full qualified url name like:

http://project.domaina.com/mymodule

Remove the "project" and index.php from the path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.