3

I am trying to connect my web application to my Magento OAuth1. The problem is when I try the URL //mydomain/store/oauth/initiate I get a page that says: "This webpage is not found" (Error code: ERR_FILE_NOT_FOUND).

Here is my Apache .htaccess configuration (part of it):

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    RewriteBase /store/

############################################
## uncomment next line to enable light API calls processing

#    RewriteRule ^api/([a-z][0-9a-z_]+)/?$ api.php?type=$1 [QSA,L]

############################################
## rewrite API2 calls to api.php (by now it is REST only)

    RewriteRule ^api/rest api.php?type=rest [QSA,L]

So what am I doing wrong?

More information can be found here: http://www.magentocommerce.com/api/rest/authentication/oauth_authentication.html

About which URL to use.

closed as too broad by brentwpeterson, Marius Dec 9 '14 at 14:02

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you try with mydomain/store/index.php/oauth/initiate/ – Marius Sep 23 '14 at 6:50