1

As the title of this post suggests, the admin panel of my Magento2 installation wont load. Sometimes after a setup:static content:deploy and deleting all cookies, it will load the login page. After logging in, the page will load but after a few minutes there is still no result. This is my second Magento2 installation and both have the same problem. I suspect it has something to do with my Mamp PRO settings (localhost).

I've been debugging for ages now, but nothing helps. Multiple topics on the internet suggest some solutions and I've came across a couple which almost had the same problem which was a loading 'Luma' theme without the style.

I really hope someone can help me solve this problem. I really want to start developing some modules, but its just not doable like this! :'(

Things I've tried:

Mamp PRO httpd.conf :: AllowOverride None -> AllowOverride All

./magento setup:static-content:deploy (multiple times)

./magento cache:flush

./magento cache:disable

./magento deploy:mode:set developer

Verified the Apache version, Php version and MySQL version

Removed all files from pub/static (except from the .htaccess)

Run composer update multiple times

Best regards

  • The only officially supported OS for M2 is *nix. Please consider existing Vagrant projects for M2 development with linux VM, e.g. this one – Alex Paliarush Jan 16 '16 at 13:35
1

I had some problems with setting up magento2 on my LAMP on OSX 10.10. It seems I had to make some changes to the vhost.config file to properly address the localhost.

  • Sorry I meant /private/etc/apache2/extra/httpd-vhosts.conf – user35163 Jan 16 '16 at 22:40
  • Thanks for your answer. Can you tell me which changes you made? – wpoortman Jan 18 '16 at 7:18
0

I added these lines to the file

<VirtualHost *:80>  
Servername localhost  
DocumentRoot /Users/"username"/Sites/
</VirtualHost>

DocumentRoot must be where your magento install is and "username" must be your own username without the "".

0

A couple of months went by and I regained my energie to move on with Magento 2 mainly because of a cool new project which is build on the enterprise version.

My team and I figured out the reason why not all of the styling was loaded correctly. Main reason was the static content which wasn't deployed correctly the first time. But second and maybe most importantly, there was a strange bug in the right locale. So we added some extra locales to the correct theme inside the (tools/config) themes.json file. After a recompile, Magento 2 loaded the frontend like it should.

I'm not totaly sure if it was just a bug which got fixed in the months between, but I hope it gives a new look at this problem if someone else bumps against these kind of problems.

Thanks for all the answers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.