0

Every time I am getting the following message:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 81 bytes) in /public_html/lib/Varien/Object.php on line 270

However, I already have php_value memory_limit 2048M in my .htaccess .which is kinda ridiculous.

Is there a way to see why its using loads of memory?

  • Does it happen on every page ? Or only one some specific pages ? – Raphael at Digital Pianism Jan 15 '16 at 12:20
  • Every page, if I logout though the site is working fine – Goose84 Jan 15 '16 at 12:32
  • What if you switch back to the native Magento default/default theme ? Does this keep happening ? – Raphael at Digital Pianism Jan 15 '16 at 12:33
  • Also, check if you have any extensions that are only doing anything when you're logged in to the frontend, since it seems that the issue occurs only when you're logged in. – Arjen Miedema Jan 15 '16 at 12:54
  • Yes it happens when using the default theme – Goose84 Jan 15 '16 at 13:19
2

To see current memory limit you can use php function phpinfo()

I assume setting memory limit with .htaccess file is not supported at the sever, so you can try other options:

1) In the file index.php add line

ini_set('memory_limit', '2048M');

2) For the cgi/fastcgi run mode you can try to add file .user.ini as follows:

memory_limit = 2048M

After this please re-start web server or manually remove already running process.

3) If you have access to the php.ini file, then you can adjust the memory_limit value in this file also.

If all options do not work, please call you hosting provider support team :)

  • does the problem solved – Gem Jul 21 '16 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.