1

I am trying to remove sku column from New order mail template. I tried this. But there were still no changes in mail. I made changes in both base theme as well as in rwd theme which is by current theme. Any Ideas?

I have my cache disabled. I did the same changes in rwd too.But no changes in my emails.

3
  • have you use any custom theme?
    – Abdul
    Commented Jan 15, 2016 at 5:26
  • no, jst modified the rwd
    – Akash
    Commented Jan 15, 2016 at 5:32
  • yes i removed from default.phtml and as well as \app\design\frontend\base\default\template\email\order\items.phtml
    – Akash
    Commented Jan 15, 2016 at 5:34

2 Answers 2

1

Check whether a custom e-mail template is configured in System > Configuration > SALES > Sales Emails > Order > New Order Confirmation Template.

If the value is different from New Order (Default Template from Local) it means that Magento is using a custom template defined in System > Transactional Emails and it may be the root cause of your issue.

Hope it helps.

2
  • Yes I have loaded the default mail template and just put some changes in the html and using it. But i haven't made any changes in {{layout..}} code. And since the layout update handle is using the phtml files, I still don;t get why commenting the sku header column line is not making the sku column go away
    – Akash
    Commented Jan 22, 2016 at 5:33
  • Provided you refreshed/disabled the cache, the last explanation is that you are not changing the proper phtml file. Sorry I can't figure out how to help you more. Commented Jan 22, 2016 at 5:44
0

Follow bellow steps:

Step : 1 Open file at location \app\design\frontend\rwd\default\template\email\order\items\order\default.phtml

Find bellow code in above file

<p class="sku"><?php echo $this->__('SKU'); ?>: <?php echo $this->escapeHtml($this->getSku($_item)) ?></p>

Now comment above code live this

<?php /*?><p class="sku"><?php echo $this->__('SKU'); ?>: <?php echo $this->escapeHtml($this->getSku($_item)) ?></p><?php */?>
1
  • I had already tried this.
    – Akash
    Commented Jan 15, 2016 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.