2

When running 1.7.x if we tried to open a link into the admin section but we weren't logged in, we could log in and it would automatically bring us to the page we had first tried to access.

After upgrading to 1.9.2.2, after login, we are always brought to the default page (in our case that's the Orders page, but for most people, it is probably the Dashboard).

For example, clicking a link to edit a product: http://example.com/index.php/customadmin/catalog_product/edit/id/481/

If we were not logged in in 1.7.x it would ask us to log in, then bring us to that. Now it brings us to the default Admin start page.

Update 3-22-2016 - More Details

Cache and compilation are disabled.

I have tried disabling all modules that have <use>admin</use> in their config.xml files. In fact, I have tried disabling all non-core modules.

After doing so I log out, log back in, copy a URL to order, log out, visit that URL, login, and I still get rerouted to the Dashboard/Orders page.

I have tested this on a new install, and a fresh install (new store) - both have the same result.

0

That might have something to do with the SUPEE-6788 patch that is in Magento 1.9.2.2, I believe there were some backward compatibility issues with certain extensions or configurations. Take a look at the technical details of this patch here to see if you have anything in your config.xml that might have broken as a result of the update.

Do you have extensions that have 'admin' in their configuration? That might be it. From the technical details document:

For example the following config.xml file for a module:

<admin>
  <routers>
    <custom_module>
      <use>admin</use>
      <args>
        <module>custom_module</module>
        <frontName>custom_module</frontName>
      </args>
    </custom_module>
  </routers>
</admin>

Should be changed to:

<admin>
  <routers>
    <adminhtml>
      <args>
        <modules>
          <custom_module after="Mage_Adminhtml">CustomModule_Adminhtml</custom_module>
        </modules>
      </args>
     </adminhtml>
  </routers>
</admin>

Also take a look at this post for testing if you have extensions that are incompatible with SUPEE-6788 and might be causing issues.

1
  • Unfortunately that didn't do the trick. I went through and disabled any modules that were had <use>admin</use> in their config.xml files. Also adding a small update to the question.
    – Jonathan
    Mar 23 '16 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.