1

pretty sure this has to do with rewrite module, but i don't know enough about how .htacess and httpd to figure this out, after trying for hours. Had the same issue with WAMP and enabling rewrite module solved this there.

this is my httpd.conf (/etc/httpd/conf/)

Options Indexes FollowSymLinks MultiViews AllowOverride All # Allow open access: Require all granted

Options Indexes FollowSymLinks MultiViews AllowOverride All Require all granted

LoadModule rewrite_module modules/mod_rewrite.so

My .htaccess file has the following

enable rewrites

Options +FollowSymLinks
RewriteEngine on

File permissions set to 755; under my sql database (core_config_data) secure and unsecure base url set to http://127.0.0.1, web/url/redirect set to 0.

Anyone have any idea what could be wrong here? when I load the page all i get is text, no css or javascript, any help would be greatly appreciated, just can't figure this out.

  • If you review your browser's network traffic, does it successfully load the CSS / JS files or are they generating a 404 error message? Is the URL what you expect it to be or are you getting something abnormal? – John Cuthbert Jan 13 '16 at 17:03
  • thanks for replying, so i am on firefox, I checked with firebug. It says (JavaScript seems to be disabled in your browser). I am pretty sure it has to do something with an apache module or rewrite not set up properly. I had a similar issue with a WAMP installtion i did and the rewrite module fixed it there. When i check the phpinfo rewite mod is enabled so i can't figure it out. – learning it Jan 14 '16 at 19:32
  • What is about file permissions on the media folder? – Amasty Jan 16 '16 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.