1

New info

This is something to do with modman and symlinks. In the staging environment I'm deploying a tarball with no symlinks (and everything works) but in development I use modman with symlinks to modules. What I can't figure out is why some modules load fine and others don't.

Original post

I need some help figuring out what is happening here or even how to troubleshoot it.

Developing Magento on my local dev machine (OSX - XAMPP, PHP/5.6.12, Apache/2.4.16) I am finding that certain Magento extensions don't load. They don't even show up in System -> Configuration -> Advanced -> Advanced -> Disable Modules Output.

Some extensions do show, others don't and I can't find any pattern. It is like the extension xml files in app/etc/modules don't even get parsed - there are no PHP errors, nothing in system.log or exception.log - totally silent failure from what I can see. Happens the same in 3 of my dev setups each for different Magento installs.

I take the exact same code and push to my staging server (CentOS 6.x, PHP/5.6.16, Apache/2.2.15) and all the extensions load fine.

Running magerun dev:module:list on both environments shows all modules correctly!

I have a script that sets appropriate file permissions and so ownership and permissions are consistent in both environments.

Any ideas what could be going on? In writing this I've realised the Apache versions are different so maybe there is something funky going on there, but that doesn't make a lot of sense.

Can anyone suggest where I should look, or how I could begin to debug? Or has anyone seen this kind of behaviour before?

Any pointers appreciated!

  • Clear your cache may be it will work – Rohit Kundale Jan 13 '16 at 8:48
  • I should have mentioned cache is disabled, has been cleared, etc. – BlueC Jan 13 '16 at 9:25
  • u can run cli php -f bin/magento setup:upgrade – xanka Jan 13 '16 at 9:45
  • @xanka this is Magento 1.9.x as per tags, not 2.x – BlueC Jan 13 '16 at 9:49
1

After a lot of debugging, turns out it was a permissions problem, doh! Fixed it by applying 755 (directory) and 644 (file) permissions to everything under .modman:

find .modman -type d -exec chmod 755 {} \;
find .modman -type f -exec chmod 644 {} \;

For good luck, on OS X remove any com.apple.quarantine extended attributes:

xattr -r -d com.apple.quarantine .modman

Seems to have fixed it up. Was pulling my hair out with this!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.