2

I added some routes to my Magento extension and it worked on localhost and my test server, however, when a client installed the extension all the new routes lead to the site's 404 page.

The client assured me he cleaned the cache (don't know which cache though, he just said he cleaned the cache), and the module is enabled and has output since other things work.

Any ideas why the new routes don't work? They are defined like this:

config.xml:

<routers>
    <vendorname_module_debuge_data>
        <use>standard</use>
        <args>
            <module>Vendorname_Module</module>
            <frontName>vendorname_debug_data</frontName>
        </args>
    </vendorname_module_debuge_data>
</routers>

and the controller:

class Vendorname_Module_DebugDataController extends Mage_Core_Controller_Front_Action
{
    public function dumpAction()
    {
        ...
        echo "something...";
    }
}

But please don't focus on syntax, settings etc as it work perfectly both on localhost and on my test server. Just not on the client for some reason.

Any ideas?

2

You have an issue at controller name Space.

The controller name should be Vendorname_Module_DebugdataController that Data's D should lower case. Also need to change at File name DebugdataController.php .

Lower and upper case letter are create issue at linux base server. As per as magento system Controller file name's all characters should be in Lower case excluding File name first letter and Controller's C.

Contoller file name should follow above rules.

  • indeed it was case-sensitive issue on Linux, something that slip-through when testing on windows. using url with /DebugData/ instead of /debugdata/ solved this. thanks! – Ronen Ness Jan 11 '16 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.