2

I am Using Magento 1.9.2.2 to my site.Getting index.php every url in Front end and Admin When trying to Remove index.php using Option "Use Web Server Rewrites : YES" Then in Front Url Structure Getting without index.php but when trying to open without index.php getting 404 Error.

i have downloaded fresh .htaccess from magento and uploaded to my Magento Root Directory But Not Working.Please Help me to Solve it Out

5

It seems your server is not configured mod_rewrite module, please enable it and try.

Ref: https://www.digitalocean.com/community/tutorials/how-to-set-up-mod_rewrite-for-apache-on-ubuntu-14-04 [Follow Step 2 — Enabling mod_rewrite]


Modify server directory block under server configuration file as below:

<Directory /var/www/html>
       Options Indexes FollowSymLinks MultiViews
       # changed from None to FileInfo
       AllowOverride All
       Order allow,deny
       allow from all
</Directory>
  • mode_rewrite Enabled Already – ondesk007 Jan 11 '16 at 7:33
  • Can you please verify Options Indexes FollowSymLinks MultiViews, AllowOverride All, Order allow,deny and allow from all is set to rewrite directory options in server configuration file. – Jayesh Patel Jan 11 '16 at 7:48
  • Just i was Reading a Post Where ask to check mod_rewrite if OK then Make AllowOverride All in etc/httpd/conf/httpd.conf file . I have downloaded httpd.conf file . It was AllowOverride None and I just Replaced AllowOverride All but can't Replaced Asking Permission Denied to write.I am using AWS Linux . Need to give permission – ondesk007 Jan 11 '16 at 7:53
  • If you have root user access then you can do this using sudo which allows you to modify /etc/httpd/conf/httpd.conf file – Jayesh Patel Jan 11 '16 at 7:58
  • After Input Command : "sudo nano /etc/httpd/conf/httpd.conf " press Enter – ondesk007 Jan 11 '16 at 8:07
2

There will be two things you need to check.

Please check. mod_rewrite is enable in your server. if mode_rewrite is enable.

Then please replace .htaccess with fresh magento .htaccess

Hope it helps you

  • Server mode_rewrite in ENABLE and Replaced .htaccess with Fresh Magento ,htaccess BUT SAME Problem – ondesk007 Jan 11 '16 at 7:33
  • @user2255224 check Catalog URL Rewrites in index section. is it indexed? – Rohit Kundale Jan 11 '16 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.