1

I want to configure USPS and Fedex shipping on a magento website. I have configured everything in the admin panel but nothing works for me.

For USPS :

When I change Show Method if Not Applicable to "No" it shows on frontend Please enter a valid value for Shipping method to complete this order.

And when it is set to "YES" it shows an error on the frontend :

USPS Settings

Also for Fedex I have configured everything but it does not show anything on the frontend. No error nothing. Below are the screenshots of my settings in the admin panel.

enter image description here

enter image description here

Also i have enabled log in admin panel and added code in Fedex.php and set permission given here

Please help me where am I doing wrong?

  • The error message appears if the response from USPS or Fedex is not valid, or if the credentials are wrong. There are also extra validation functions for these methods. Most probably one of them does not pass. You can try to debug this by looking in Mage_Usa modules for code like $this->getConfigData('specificerrmsg') and see what happens near that. That is the error message that you see in the checkout process. – Marius Oct 18 '13 at 13:18
  • Thanks for the reply. Can you please give me some details to how to track the code as I am new to magento and dont know much about the code. – Raina Oct 18 '13 at 13:25
  • 1
    search in your files for that piece of code and try to figure out what happens in the methods that have that. You can try adding Mage::log(SOME VARIABLE) in those methods and check var/log/system.log to see their values. Or you can use xdebug. The main idea is to ...debug. Unfortunately I have close to 0 experience with USPS and Fedex (on Magento and outside it) so I cannot give you more details. – Marius Oct 18 '13 at 13:38
  • I have already checked the log files but there is no log recorded in the system.log and exception.log files. I have also checked the permissions to var/log/ folders and files. – Raina Oct 18 '13 at 14:59
  • Have you got something on it? Why it isn't working for fedex? because i am facing the same problem. – aton1004 Mar 12 '15 at 4:27
2

I had the same issue. I tried using different network configuration and IP settings. Also configured the Firewall and Anti-Virus.. PROBLEM SOLVED FOR ME!

  • My credentials correct, i have two store in single magento, store 1 display Fedex shipping cost, but store 2 not displaying shipping cost, how can i solve this issue? – zus Mar 10 '18 at 12:33
1

Check your User Id and Password which you are giving in the USPS settings.In my case I was having this issue because of invalid credentials.

0

If you know in July 28, 2013 USPS make some changes to own API and you should install patches to USPS module of Magento: http://www.magentocommerce.com/blog/magento-community-edition-alert-important-patch-for-usps-api/
And also FEDEX api also was changed in May, 2012. Use updated extension: http://www.webshopapps.com/fedex-shipping.html

If you have already updated your modules, see var/logs/ to find some issues.

  • Thanks for the reply. Do you mean that I have to set all the credentials in the webshopapps fedex section instead of fedex section? – Raina Oct 18 '13 at 14:57
  • Yes, webshopapps fedex section – mageUz Oct 18 '13 at 18:32
0

The beauty of link-only answers. This no longer works -> http://www.magentocommerce.com/blog/magento-community-edition-alert-important-patch-for-usps-api/

USPS API RateV3 ends on Sept. 28, 2014

Following are patches (July 2013) for Magento Community Edition to support USPS API RateV4:

If you installed these patches last year, you're done, if you installed a third party module that allowed you to use Priority Mail and Priority Mail Express with the RateV3 API (didn't install these patches) then you need to apply them before Sept. 28.

1.8.x.x can ignore the following.

Versions prior to 1.7.x.x require applying a shipping methods patch first so Magento will support USPS API RateV4. The second API Upgrade patch supports the changes to the USPS Priority Mail and Priority Mail Express postage methods.

Target Magento Release             Upgrade of Shipping Methods Patch  USPS API Upgrade Patch
                                   (if not previously applied)
Magento Community Edition 1.7.x.x  Not Required                       PATCH_SUPEE-1868_CE_1.7.0.2_v1.sh
Magento Community Edition 1.6.2.0  MAGEBP-706_CE_1.6.2.0_v4.patch     PATCH_SUPEE-1868_CE_1.7.0.2_v1.sh
Magento Community Edition 1.6.1.0  MAGEBP-706_CE_1.6.1.0_v4.patch     PATCH_SUPEE-1868_CE_1.7.0.2_v1.sh
Magento Community Edition 1.6.0.0  MAGEBP-706_CE_1.6.0.0_v4.patch     PATCH_SUPEE-1868_CE_1.7.0.2_v1.sh
Magento Community Edition 1.5.1.0  MAGEBP-706_CE_1.5.1.0_v4.patch     PATCH_SUPEE-1868_CE_1.7.0.2_v1.sh
Magento Community Edition 1.5.0.1  MAGEBP-706_CE_1.5.0.1_v4.patch     PATCH_SUPEE-1868_CE_1.7.0.2_v1.sh
Magento Community Edition 1.4.2.0  MAGEBP-706_CE_1.4.2.0_v4.patch     PATCH_SUPEE-1868_CE_1.4.2.0_v1.sh

Available from the following links:

USPS API RateV4 patch (must be applied first)

http://info.magento.com/rs/magentocommerce/images/MAGEBP-706_CE_1.4.2.0_v4.patch
http://info.magento.com/rs/magentocommerce/images/MAGEBP-706_CE_1.5.1.0_v4.patch
http://info.magento.com/rs/magentocommerce/images/MAGEBP-706_CE_1.6.2.0_v4.patch

API Update Specific to 1.4.2.0:

http://info.magento.com/rs/magentocommerce/images/PATCH_SUPEE-1868_CE_1.4.2.0_v1.sh

API Update for all others up to 1.7.x.x

http://info.magento.com/rs/magentocommerce/images/PATCH_SUPEE-1868_CE_1.7.0.2_v1.sh

Users of 1.7.x will probably have already installed this above patch so they could ship by Priority Mail and Priority Mail Express back in early August 2013.

If you merely installed third party modules that supported using Priority Mail and Priority Mail Express with the RateV3 calculator on 1.6.x.x and previous, you will have to apply both the Shipping Methods Patch and USPS API Upgrade Patch

0

I suggest a flow to eliminate the issues.

Check the logs in <magento_root>/var/logs

I was debugging my usps method, so I opened shipping_usps.log In the node RateV4Response I was getting error 2147219500 - "Please enter the package weight"

The products in my implementation were created through an outside API and set to enable shipping though without all the required Magento fields (at least the required fields for entering shipping information through the admin form).

I set the weight up for the Product, and voila it worked!

If you can paste the error code that you get from the logs I may be able to help you in a more specific way. Otherwise, look at the response and derive what you can.

  • I have the same error in magento 2. My error in debug.log is - 'result' => array ( 'error' => 'Unable to read response, or response is empty', 'code' => 0, ), – Piyush Dangre May 3 '17 at 5:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.