1

After adding a simple product, went to view it in the front end, getting this error:

Fatal error: Call to undefined method Mage_Catalog_Model_Product_Type_Simple::getUsedProducts() in /home/ottocap/public_html/app/code/core/Mage/Catalog/Model/Resource/Product/Type/Configurable/Attribute/Collection.php on line 160

Please help.

closed as off-topic by Raphael at Digital Pianism, Qaisar Satti, Fabian Schmengler, benmarks Mar 20 '16 at 20:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Raphael at Digital Pianism, Qaisar Satti, benmarks
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Looks like some custom code tries to treat the simple product like a configurable product. – Fabian Schmengler Mar 19 '16 at 13:27
2

This will be impossible to help with, since there is really not enough information.

You say it is a simple product, but from the error you can clearly see that something is trying to use configurable product type functionality. This is most likely caused by some 3rdparty code/custom code that is not correctly determining the product type, and then trying to load configurable product child products.

You need to find that code. Your best way forward is to use a debugger.

Since you know where the failure is happening: home/ottocap/public_html/app/code/core/Mage/Catalog/Model/Resource/Product/Type/Configurable/Attribute/Collection.php on line 160 you can simply place a breakpoint on that line, wait for it to break, and then step backwards via the call-stack. You will literally get the calling code in a matter of seconds, and from that determine what is up.

1

(Mage_Catalog_Model_Product_Type_Simple) Simple class not searching. Check this class is there at location Code/core/mage/catalog/model/product/type/simple.php

Not the answer you're looking for? Browse other questions tagged or ask your own question.