1

I have installed EV SSL on my site. But in chrome it isnt showing any padlock sign.

i checked the site for ssl scan here and it is giving error

Insecure < form > call. Found on line # 2243 in file: www.smartteck.co.uk/index.html

but i can not figure out what is on line 2243 the only form i have is newsletter signup in my footer and i can not see any problem with that.

can any one tell me what is wrong there?

1

I'm seeing two form tags with 'http' action tags. You can see via the 'console' tag in Chrome developer tools:

Mixed Content: The page at 'https://www.smartteck.co.uk/' was loaded over a secure connection, but contains a form which targets an insecure endpoint 'http://www.smartteck.co.uk/catalogsearch/result/'. This endpoint should be made available over a secure connection.

(index):1922 Mixed Content: The page at 'https://www.smartteck.co.uk/' was loaded over a secure connection, but contains a form which targets an insecure endpoint 'http://www.smartteck.co.uk/newsletter/subscriber/new/'. This endpoint should be made available over a secure connection.

1

I just checked the webshop and it seems fixed to me. Just for everyone who has the same issue, make sure that all requests on your page are over HTTPS. So your stylesheets, scriptfiles, images, etc. But also the form actions, images within stylesheets and external links.

1

I have solved this issue, what it was my basic url was set to http://www.mysite.co.uk and secure as you know was on https this was causing issue with serach engine field and newsletter field. all i had to do was change my basic url from http://www.mysite.co.uk/ to https://www.mysite.co.uk/ so now all my conetent should serve on https.

by default it selcted to show front end on https, magento do not serve all pages on https only secure pages. like checkout etc.

there for when opening in https all the internal stuff was still serving from basic url which was http and was causing error.

for any one facing same issue. just go to:

system > configuration > web > unsecure

and set the basic url from https.

and enable Use Secure URLs in Frontend

  • It works for me. I was getting an error from this whynopadlock.com for my site. Your answer helped me. – Manikandan Arunachalam Jun 26 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.