13

I have successfully installed Magento 2 on the wamp server but I'm having a slight issue of loading the admin page as it is giving me a 404. Also, when loading its homepage the default theme that is luma in my case doesn't apply and instead gives me the following errors:

Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/mage/calendar.css     
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-m.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-l.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/print.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/images/logo.svg    
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-m.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-l.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/requirejs/require.js 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/print.css     
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/mage/requirejs/mixins.js 
Failed to load resource: the server responded with a status of 404 (Not Found)
requirejs-config.js:602 Uncaught ReferenceError: require is not defined
127.0.0.1/:24 Uncaught ReferenceError: require is not defined
127.0.0.1/:26 Uncaught ReferenceError: require is not defined
1

7 Answers 7

18

Css and js will created at run time in pub/static folder In first time,if css and js missing then run below command

if you are using windows: php bin\magento setup:static-content:deploy

if using linux of 'git bash': php bin/magento setup:static-content:deploy

3
  • Also, make sure you enabled Apache server rewrites Jan 7, 2016 at 14:42
  • Would appreciate if you could break down the steps. How to run the Windows command? How to know if it actually worked? Jun 28, 2017 at 19:49
  • It's worth nothing that if you've downloaded the source from github and you install via the browser you will need to enable developer mode. The above command will complain that you don't need to run setup:static-content:deploy in developer mode so ensure you append -f to the above command. If you've set a different language other than en_US you will also need to supply those: php bin\magento setup:static-content:deploy -f en_US en_GB Feb 17, 2020 at 22:53
16

I was also facing this problem. Admin gives 404 error and frontend didn't attach css(i.e. Luma didnot showing in proper format..).so i did these steps to solve these both problems in magento 2. 1)go to terminal and run this command

sudo gedit /etc/apache2/apache2.conf

And change:-

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride none
Require all granted

To

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

chnage only AllowOverride none to All

and

2) go to terminal and run command :-

sudo a2enmod rewrite
sudo service apache2 restart

Then give the permission to your var,pub and app/etc. and then go to your admin and frontend it works properly.

2
  • 2
    man i tried 1000s of solution but only this one worked for me thanks a lot! Apr 3, 2017 at 6:13
  • This is the only thing that worked for me. Thanks a lot. Magento version 2.4, installation type was composer. Dec 25, 2020 at 9:04
8

For those who are using wamp server, then run these commands in your CLI.

C:\wamp\bin\php\php5.5.12>php.exe
C:\wamp\www\\bin\magento setup:static-content:deploy

6

I was also facing this issue. After fresh install of magento 2 with demo data when navigating to the frontend and backend too in localhost. Got MIME type mismatch errors for calendar.css and require.js. Nothing worked for me unless deployed the static content through

php bin/magento setup:static-content:deploy

in git bash and while it is default mode.

3

I was facing the same problem, I used Alan Storm solution from that article - http://alanstorm.com/magento_2_adding_frontend_files_to_your_module

use that command in ssh

find /path/to/magento2/pub/static -exec chmod 777 '{}' +
find /path/to/magento2/var/ -exec chmod 777 '{}' + 
3

Enable URL rewrites.

1) Open terminal in Ubuntu and execute these commands:

sudo a2enmod rewrite

sudo service apache2 restart

2) Make sure you have the .htaccess file in your root directory of magento, if there is no .htaccess file copy the /pub/.htaccess file and paste it in the root directory

3) Open /etc/apache2/apache2.conf file using following commands:

sudo nano /etc/apache2/apache2.conf

And change the following lines of code:

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride none
Require all granted

To

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

Save and close the file by Ctrl + X

  • Restart the apache

    sudo service apache2 restart

0

If All the Required Static Files present in {root}/pub/static directory then please make .htaccess file is present in {root}/pub/static dir or not. if .htaccess file is missing at {root}/pub/static dir then create a .htaccess file and paste below code

<IfModule mod_php7.c>
    php_flag engine 0
</IfModule>

<IfModule mod_php.c>
    php_flag engine 0
</IfModule>

# To avoid situation when web server automatically adds extension to path
Options -MultiViews

<IfModule mod_rewrite.c>
    RewriteEngine On

    ## you can put here your pub/static folder path relative to web root
    #RewriteBase /magento/pub/static/

    # Remove signature of the static files that is used to overcome the browser cache
    RewriteRule ^version.+?/(.+)$ $1 [L]

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-l

    RewriteRule .* ../static.php?resource=$0 [L]
    # Detects if moxieplayer request with uri params and redirects to uri without params
    <Files moxieplayer.swf>
        RewriteCond %{QUERY_STRING} !^$
        RewriteRule ^(.*)$ %{REQUEST_URI}? [R=301,L]
     </Files>
</IfModule>

############################################
## setting MIME types

# JavaScript
AddType application/javascript js jsonp
AddType application/json json

# HTML
AddType text/html html

# CSS
AddType text/css css

# Images and icons
AddType image/x-icon ico
AddType image/gif gif
AddType image/png png
AddType image/jpeg jpg
AddType image/jpeg jpeg
AddType image/webp webp
AddType image/avif avif
AddType image/avif-sequence avifs

# SVG
AddType image/svg+xml svg svgz

# Fonts
AddType application/vnd.ms-fontobject eot
AddType application/x-font-ttf ttf
AddType application/x-font-otf otf
AddType application/x-font-woff woff
AddType application/font-woff2 woff2

# Manifest
AddType application/manifest+json webmanifest

# Archives and exports
AddType application/zip gzip
AddType application/x-gzip gz gzip
AddType application/x-bzip2 bz2
AddType text/csv csv
AddType application/xml xml

<IfModule mod_headers.c>

    <FilesMatch .*\.(ico|jpg|jpeg|png|gif|svg|webp|avif|avifs|js|css|eot|ttf|otf|woff|woff2|html|json|webmanifest)$>
        Header append Cache-Control public
    </FilesMatch>

    <FilesMatch .*\.(zip|gz|gzip|bz2|csv|xml)$>
        Header append Cache-Control no-store
    </FilesMatch>

</IfModule>

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    ExpiresActive On

    # Data
    <FilesMatch \.(zip|gz|gzip|bz2|csv|xml)$>
        ExpiresDefault "access plus 0 seconds"
    </FilesMatch>
    ExpiresByType text/xml "access plus 0 seconds"
    ExpiresByType text/csv "access plus 0 seconds"
    ExpiresByType application/json "access plus 0 seconds"
    ExpiresByType application/zip "access plus 0 seconds"
    ExpiresByType application/x-gzip "access plus 0 seconds"
    ExpiresByType application/x-bzip2 "access plus 0 seconds"

    # Manifest
    <FilesMatch \.(webmanifest)$>
        ExpiresDefault "access plus 0 seconds"
    </FilesMatch>
    ExpiresByType application/manifest+json "access plus 0 seconds"

    # CSS, JavaScript, html
    <FilesMatch \.(css|js|html|json)$>
        ExpiresDefault "access plus 1 year"
    </FilesMatch>
    ExpiresByType text/css "access plus 1 year"
    ExpiresByType text/html "access plus 1 year"
    ExpiresByType application/javascript "access plus 1 year"
    ExpiresByType application/json "access plus 1 year"

    # Favicon, images, flash
    <FilesMatch \.(ico|gif|png|jpg|jpeg|svg|svgz|webp|avif|avifs)$>
        ExpiresDefault "access plus 1 year"
    </FilesMatch>
    ExpiresByType image/gif "access plus 1 year"
    ExpiresByType image/png "access plus 1 year"
    ExpiresByType image/jpg "access plus 1 year"
    ExpiresByType image/jpeg "access plus 1 year"
    ExpiresByType image/svg+xml "access plus 1 year"
    ExpiresByType image/webp "access plus 1 year"
    ExpiresByType image/avif "access plus 1 year"
    ExpiresByType image/avif-sequence "access plus 1 year"

    # Fonts
    <FilesMatch \.(eot|ttf|otf|svg|woff|woff2)$>
        ExpiresDefault "access plus 1 year"
    </FilesMatch>
    ExpiresByType application/vnd.ms-fontobject "access plus 1 year"
    ExpiresByType application/x-font-ttf "access plus 1 year"
    ExpiresByType application/x-font-otf "access plus 1 year"
    ExpiresByType application/x-font-woff "access plus 1 year"
    ExpiresByType application/font-woff2 "access plus 1 year"
    ExpiresByType font/opentype "access plus 1 year"
    ExpiresByType font/truetype "access plus 1 year"

</IfModule>

Note: Magento 2.4.4.

if above .htaccess code not works. then try this .htaccess file code

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.