1

I am learning Magento Admin menu development. I am trying to develop a simple menu in Magento Admin Panel. My codes are as below

location of file: app/etc/modules/Alanstormdotcom_Helloworld.xml

<?xml version="1.0" encoding="utf-8"?>
<config>
    <modules>
        <Alanstormdotcom_Helloworld>
            <active>true</active>
            <codePool>local</codePool>
        </Alanstormdotcom_Helloworld>
    </modules>
</config>

location of file: app/code/local/Pulsestorm/Adminhello/etc/adminhtml.xml

<?xml version="1.0"?>
<config>
    <menu>
        <pulsestorm translate="title" module="pulsestorm_adminhello">
            <title>Pulse Storm</title>
            <sort_order>1</sort_order>
            <children>
                <example>
                    <title>Example</title>
                    <sort_order>1</sort_order>
                    <action>adminhtml/adminhello/index</action>
                </example>
            </children>
        </pulsestorm>
    </menu>
</config>

location of file: app/code/local/Pulsestorm/Adminhello/etc/config.xml

<?xml version="1.0"?>
<config>
    <config>    
        <modules>
            <Alanstormdotcom_Helloworld>
                <version>0.1.0</version>
            </Alanstormdotcom_Helloworld>
        </modules>
    </config> 
    <global>
        <helpers>
            <pulsestorm_adminhello>
                <class>Pulsestorm_Adminhello_Helper</class>
            </pulsestorm_adminhello>
        </helpers>
    </global>
</config>

location of file: app/code/local/Pulsestorm/Adminhello/Helper/Data.php

<?php
class Pulsestorm_Adminhello_Helper_Data extends Mage_Core_Helper_Abstract
{
}

But I could not see any menu in my admin panel. what is the issue here?? Thanks

1

You have miss-configured your config.xml file.

Change it to:

<?xml version="1.0"?>
<config>   
        <modules>
            <Alanstormdotcom_Helloworld>
                <version>0.1.0</version>
            </Alanstormdotcom_Helloworld>
        </modules>
    <global>
        <helpers>
            <pulsestorm_adminhello>
                <class>Pulsestorm_Adminhello_Helper</class>
            </pulsestorm_adminhello>
        </helpers>
    </global>
</config>

You had extra <config> in the file.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.