0

I am transfering my magento CE1.9.0.1 from a share hosting to a VPS. Conf of my VPS is Debian 8 Apache 2.4.10 Mysql 5.6 PHP Version => 5.6.14-0+deb8u1

I set up apache and upload my site and since I got the error here after. I cleared var/cache and var/sesion but without sucess.

I correctly modified app/etc/config.xml and local.xml

But never success to get rid of this error.

a:4:{i:0;s:56:
"Mage registry key "_resource_helper/core" already exists";i:1;s:1486:"
#0 /var/www/velenka.com/public_html/app/Mage.php(223): Mage::throwException('Mage registry k...')
#1 /var/www/velenka.com/public_html/app/Mage.php(563): Mage::register('_resource_helpe...', false)
#2 /var/www/velenka.com/public_html/app/code/core/Mage/Core/Model/Resource/Db/Collection/Abstract.php(534): Mage::getResourceHelper('core')
#3 /var/www/velenka.com/public_html/app/code/core/Mage/Core/Model/Resource/Db/Collection/Abstract.php(520): Mage_Core_Model_Resource_Db_Collection_Abstract->_prepareSelect(Object(Varien_Db_Select))
#4 /var/www/velenka.com/public_html/lib/Varien/Data/Collection/Db.php(566): Mage_Core_Model_Resource_Db_Collection_Abstract->getData()
#5 /var/www/velenka.com/public_html/app/code/core/Mage/Core/Model/Resource/Website/Collection.php(137): Varien_Data_Collection_Db->load(false, false)
#6 /var/www/velenka.com/public_html/lib/Varien/Data/Collection.php(729): Mage_Core_Model_Resource_Website_Collection->load()
#7 /var/www/velenka.com/public_html/app/code/core/Mage/Core/Model/App.php(634): Varien_Data_Collection->getItemById('0')
#8 /var/www/velenka.com/public_html/app/code/core/Mage/Core/Model/App.php(466): Mage_Core_Model_App->_initStores()
#9 /var/www/velenka.com/public_html/app/code/core/Mage/Core/Model/App.php(349): Mage_Core_Model_App->_initCurrentStore('', 'store')
#10 /var/www/velenka.com/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#11 /var/www/velenka.com/public_html/index.php(87): Mage::run('', 'store')
#12 {main}";
s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";}
0

You need add this on local.xml:

<model><![CDATA[mysql4]]></model>

IF you already did this and error persist, you need clear your cache. Inside of your magento folder:

rm -rf var/cache/

or remove manually. ;)

also check https://stackoverflow.com/questions/11931934/magento-mage-registry-key-resource-helper-core-already-exists and https://gist.github.com/Nolwennig/210440a07a4b48feca0c#file-xml

I hope this will help you.

  • I saw those posts already and my local.xml has it already. I deleted cache and session but without success. I am now running out of clue... :( – Gwenael Cholet Jan 4 '16 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.