0

I am using Magento 1.9.2 CE edition, Whenever I do a product import, system allows me to import only 42 products maximum, I have tried increasing PHP memory, file size and upload limit as well however still facing the same issue.

Please help, I have attached the error screen as well.

enter image description here

  • I strongly recommend not using Dataflow at all as it's extremely slow and outdated since Magento CE 1.5. Try ImportExport instead. – Andreas von Studnitz Jan 15 '16 at 19:48
  • I wonder why there is no error message for these error entries... . – hakre Apr 3 '16 at 13:03
0

I might be late but here's what i did to overcome the same issue.

Split your CSV product file into little CSV files, consisting of 40 products each, with the help of a free online CSV splitter - http://splitfile.vavro.me (I had a CSV file of 3000+ products. So it got split into 75 files.)

Then upload all those little CSV files to your server's "var/import/" folder. Now login into your magento's back-end, go to System>Import/Export>Dataflow-Profiles, choose your profile then go to 'Run-Profile'. Here you can see all the uploaded CSV files listed in a drop-down. Now execute the files one by one. Pretty long process, but worth it.

Note that after executing each file, you need to wait for at least 2 minutes to get the indexes refreshed. Or else you might end up getting the same red blank errors again!

| improve this answer | |
  • If you can reproduce this issue, can you share why there is no error message in those red error entries? What have you done to analyze the problem, can you share about that as well? Was it try and error? Seems aktwardly complicated to use an onlline service for such a workaround anyways... . – hakre Apr 3 '16 at 13:02
  • @hakre, after a week of research I still couldn't figure out the reason behind this strange error! As I was running out of time I had no other option than trying out this method. Well, about how I analyzed the problem - I did know that if the CSV file has less than 42 records, there will not be any such errors. Hence thought of splitting one huge file into many little chunks. And to my luck, this worked! If you're afraid of using a third party online file splitting service, there are multiple ways of doing it yourself, offline. All I can say is, just google it! :) – AtomicLife Apr 3 '16 at 14:33
  • Yeah, the error is really strange. Such a limit makes no sense and also the missing message is also very strange. Something must be really broken. – hakre Apr 3 '16 at 14:39
  • @hakre, The strange thing is, even after years of having this issue, magento has still not looked into this! Will keep you posted if I get some more information on this error. – AtomicLife Apr 3 '16 at 14:49
  • Well, that might be because when you use the community edition you need to take care of that your own, not Magento. With the Enterprise Edition you get that kind of support you might be looking for. – hakre Apr 3 '16 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.