1

I'm having an issue, just trying to create a new website. I'm entering the information in System / Manage stores / Create Website.

First, It fails with a fatal Error 512 Mo exhausted ...

I increased memory in php.ini to 1024M and now it fails with a message :

An error occurred while saving. Please review the error log.

In exception.log I get this :

Exception message: Error cleaning cache by mode matchingAnyTag: read error on connection Trace: #0 ...../Cm_Cache_Backend_Redis/Cm/Cache/Backend/Redis.php(671): Zend_Cache::throwException('Error cleaning ...', Object(CredisException))

So .... I'm a bit confused, can't find anything anywhere about this issue.

I tried editing the file, checking where the problem may come from but still no clue.

Thanks for any lead.

EDIT : ok so ... Changing the read_timeout value in /app/etc/mylocalfile.xml is actually delaying the exception, so the exception does seem to come from redis reading timing out...

Question is : Why the hell is the website creation taking sooooo long ?

Retrying with a 200sec timeout (100 sec just failed)

2

Well ... I guess my redis database was corrupted or something.

redis-cli then flushall

And it's smooth again now.

  • or echo flushall | redis-cli :) – MagenX Dec 30 '15 at 13:15
  • you can just use redis-cli flushall. No need to open the cli prompt or echo into it. – Andre S. Mar 20 at 1:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.